aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-14 20:02:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-14 20:05:52 +0000
commite05f19307906e5ee506da0f2c8ccdaa0da50c98e (patch)
treeadcddbeb81bd176237518908c32a69717e565752 /main/linux-grsec
parentbaa25bc422f17ca67fe4b974025b6ddfaa67c017 (diff)
downloadaports-e05f19307906e5ee506da0f2c8ccdaa0da50c98e.tar.bz2
aports-e05f19307906e5ee506da0f2c8ccdaa0da50c98e.tar.xz
main/linux-grsec: fix build on x86
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD1
-rw-r--r--main/linux-grsec/pax-cmpxchg8b_emu.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index cbe547ff4a..6e17a82ddb 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -18,6 +18,7 @@ install=
source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
http://dev.alpinelinux.org/~ncopa/grsec/grsecurity-3.1-4.9.9-201702122044.patch
+ pax-cmpxchg8b_emu.patch
config-grsec.x86
config-grsec.x86_64
config-grsec.armhf
diff --git a/main/linux-grsec/pax-cmpxchg8b_emu.patch b/main/linux-grsec/pax-cmpxchg8b_emu.patch
new file mode 100644
index 0000000000..432e3f5072
--- /dev/null
+++ b/main/linux-grsec/pax-cmpxchg8b_emu.patch
@@ -0,0 +1,12 @@
+diff --git a/arch/x86/lib/cmpxchg8b_emu.S b/arch/x86/lib/cmpxchg8b_emu.S
+index 34c859b..6793bf2 100644
+--- a/arch/x86/lib/cmpxchg8b_emu.S
++++ b/arch/x86/lib/cmpxchg8b_emu.S
+@@ -8,6 +8,7 @@
+
+ #include <linux/linkage.h>
+ #include <asm/export.h>
++#include <asm/alternative-asm.h>
+
+ .text
+