aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-pam
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-08 10:40:52 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-08 10:40:52 +0000
commit18d1cb5dde72658fcb91eb21864b5c22b44f0cab (patch)
tree198998f87fc12a62ba5699f49b4a78d4c98e5a5a /main/linux-pam
parent364d51e6f42a946e9fa61b30d094350e724868f2 (diff)
downloadaports-18d1cb5dde72658fcb91eb21864b5c22b44f0cab.tar.bz2
aports-18d1cb5dde72658fcb91eb21864b5c22b44f0cab.tar.xz
main/linux-pam: upgrade to 1.1.8, and fix musl build
Diffstat (limited to 'main/linux-pam')
-rw-r--r--main/linux-pam/APKBUILD40
-rw-r--r--main/linux-pam/fix-compat.patch21
-rw-r--r--main/linux-pam/linux-pam-1.1.6-destdir.patch48
3 files changed, 54 insertions, 55 deletions
diff --git a/main/linux-pam/APKBUILD b/main/linux-pam/APKBUILD
index c244e671bb..cbad0c4184 100644
--- a/main/linux-pam/APKBUILD
+++ b/main/linux-pam/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=linux-pam
-pkgver=1.1.6
+pkgver=1.1.8
pkgrel=0
pkgdesc="pluggable authentication modules for linux"
url="http://www.kernel.org/pub/linux/libs/pam"
@@ -14,14 +14,16 @@ install=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz2
linux-pam-innetgr.patch
+ fix-compat.patch
+ libpam-fix-build-with-eglibc-2.16.patch
+
base-auth.pamd
base-account.pamd
base-password.pamd
base-session.pamd
base-session-noninteractive.pamd
other.pamd
- libpam-fix-build-with-eglibc-2.16.patch
- linux-pam-1.1.6-destdir.patch"
+ "
_builddir="$srcdir"/Linux-PAM-$pkgver
prepare() {
@@ -32,11 +34,15 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+
+ # disable insecure modules
+ sed -e 's/pam_rhosts//g' -i modules/Makefile.am
}
build() {
cd "$_builddir"
autoreconf -vif || return 1
+ [ "$CLIBC" = "musl" ] && export ac_cv_search_crypt=no
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -73,13 +79,33 @@ package() {
find "$pkgdir" -name *.la -print | xargs rm
}
-md5sums="7b73e58b7ce79ffa321d408de06db2c4 Linux-PAM-1.1.6.tar.bz2
+md5sums="35b6091af95981b1b2cd60d813b5e4ee Linux-PAM-1.1.8.tar.bz2
c309401e103cc86e8b25557ff3eb0b53 linux-pam-innetgr.patch
+283a399db933a7598fc63ada5d3eb38c fix-compat.patch
+23320dadf8e36846b6bbd7903f95ece5 libpam-fix-build-with-eglibc-2.16.patch
aa5bb7c9d8e4687aea1ae69b7447254a base-auth.pamd
fafcf29cb9bab788cb4933106be31883 base-account.pamd
117535e4938f478efced1398b408cf96 base-password.pamd
baec6808544bf6cebc59e07467f8c213 base-session.pamd
afbdd8eb4db5c31dfd8e8da35c698b90 base-session-noninteractive.pamd
-b8e839ece64df173f16d28520eb8d66c other.pamd
-23320dadf8e36846b6bbd7903f95ece5 libpam-fix-build-with-eglibc-2.16.patch
-cc3bb10c851bb925708cc8b74967e3b7 linux-pam-1.1.6-destdir.patch"
+b8e839ece64df173f16d28520eb8d66c other.pamd"
+sha256sums="c4b1f23a236d169e2496fea20721578d864ba00f7242d2b41d81050ac87a1e55 Linux-PAM-1.1.8.tar.bz2
+fb609212837c67da7da033a0daa01d1c2e34166867530e6924102b655e00ebde linux-pam-innetgr.patch
+4e1f855779a73960f48e570ce507884325a3aef374721e3973e1e22a60b9bec0 fix-compat.patch
+01c9216a2a833d10c2b42e1182b161b125d869e8620e60989636feb721d466c5 libpam-fix-build-with-eglibc-2.16.patch
+daedb66d2b6c324f62100657383f3da6af196ad516837f36a3142da5318b8874 base-auth.pamd
+51dba5c32d8cfa0c1795b2ed72af7aa5871f7943a20f89d2e4ad00b9053bc9c8 base-account.pamd
+16c2d6f750f8bb320d64537554c48e3474f13623e7f6e231135d2cd2362745a3 base-password.pamd
+5bf97347375ffc626fd3ed2e8d39abde566c2eca3f5e06a737ccffd48aede5de base-session.pamd
+a65802b72a44b0c2083bce7e7d0cd1b04782272a6281a65c5b0075b8f9bccd5f base-session-noninteractive.pamd
+2e4850ba8db3aee3fe97eaf76286ada585d821cd8affc97c845eb58b2bf68bb6 other.pamd"
+sha512sums="245785ab4e187ceaab6393967352c8d2a2319c64e1e83285d0251cc02995dc2edab8e3001301b6d9f6774c441b7557d9caf4dfdf94c7cd5d44aa53ae759d9e5d Linux-PAM-1.1.8.tar.bz2
+ca32ecdacfc5b8f1482031203b616932b646a008b02080315ea2589af5962180d4ff4339c27fe9f6a878a89f47fb69429f4ac75d67b0e70ad7765a4db1dc74d9 linux-pam-innetgr.patch
+52b97e23084f7b835ce1fa441663f91a50ea797cb38ba2c6662bcdaf0d25ba487118442674ac347fb17353af126dd6b3b696612faa56cac428dd842d14e1c90d fix-compat.patch
+f49edf3876cc6bcb87bbea4e7beaeb0a382d596898c755f5fbaf6c2ed4e0c8f082b2cd16dde8a74af82bb09a1334f463e07a4bb5b8a48f023ff90a67ad2fdd44 libpam-fix-build-with-eglibc-2.16.patch
+0672ab21adb969af2a0082e2559f1196d8a4f8b1cff2836f97e5f24edb03b6aed156c61cf335a4df978e423dcd9934ffee8cb5784ed5dde704d7e5ddec4ba9f6 base-auth.pamd
+85462201a4044c7e170e617d39b0eceb4790abc6c0504999117548030a16d80a9d2078d1ad97690d7d346e6374201f0c52e792ccb08ce2b1c4bbf0cc2be96f5b base-account.pamd
+8223b815148c3b9b874d2c283840f6428c266e56c7cf49ce8fc508c4945ae31c837bef96dab17f64a60812d1c9cd0055cf0a50d7951d23070b69bd2e5bb9666d base-password.pamd
+b0138f662715974bd865d755c5e7d403faf5b9ad1b7e2b1d1598ad7eb5764a9ff407f1a5e6ce7f16db9fc10f8d643323b494563416fd6a654032529b52213c5b base-session.pamd
+444e20046843057b17c0aac14d2b71a68923b989b3d8b478bbf684698673683186e928e5ca2e6cb9a1c76abc4248044a0e10ef6b06b3f51857106796ecce250d base-session-noninteractive.pamd
+d103ba06b2c4929171e09c845f9866539220cd20d8d56a03d25850342ef5eabe281e958dfe1eaefd550c00f9440e8700c1d74c88c3001f933134ca6fd7cb9b7b other.pamd"
diff --git a/main/linux-pam/fix-compat.patch b/main/linux-pam/fix-compat.patch
new file mode 100644
index 0000000000..4096c3a475
--- /dev/null
+++ b/main/linux-pam/fix-compat.patch
@@ -0,0 +1,21 @@
+--- Linux-PAM-1.1.6.orig/modules/pam_lastlog/pam_lastlog.c
++++ Linux-PAM-1.1.6/modules/pam_lastlog/pam_lastlog.c
+@@ -10,6 +10,7 @@
+
+ #include "config.h"
+
++#include <paths.h>
+ #include <fcntl.h>
+ #include <time.h>
+ #include <errno.h>
+@@ -48,6 +49,10 @@
+
+ #ifndef _PATH_BTMP
+ # define _PATH_BTMP "/var/log/btmp"
++#endif
++
++#ifndef __GLIBC__
++#define logwtmp(args...)
+ #endif
+
+ /* XXX - time before ignoring lock. Is 1 sec enough? */
diff --git a/main/linux-pam/linux-pam-1.1.6-destdir.patch b/main/linux-pam/linux-pam-1.1.6-destdir.patch
deleted file mode 100644
index 6859ccb60d..0000000000
--- a/main/linux-pam/linux-pam-1.1.6-destdir.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From d7e6b921cd34f7ad8fc4d05065c75d13ba330896 Mon Sep 17 00:00:00 2001
-From: Tomas Mraz <tmraz@fedoraproject.org>
-Date: Fri, 17 Aug 2012 14:46:40 +0200
-Subject: [PATCH] Add missing $(DESTDIR) when making directories on install.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-modules/pam_namespace/Makefile.am: Add missing $(DESTDIR) when making
-$(namespaceddir) on install.
-modules/pam_sepermit/Makefile.am: Add missing $(DESTDIR) when making
-$(sepermitlockdir) on install.
-
-Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
----
- modules/pam_namespace/Makefile.am | 2 +-
- modules/pam_sepermit/Makefile.am | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/modules/pam_namespace/Makefile.am b/modules/pam_namespace/Makefile.am
-index a28f196..ebb00f3 100644
---- a/modules/pam_namespace/Makefile.am
-+++ b/modules/pam_namespace/Makefile.am
-@@ -40,7 +40,7 @@ if HAVE_UNSHARE
- secureconf_SCRIPTS = namespace.init
-
- install-data-local:
-- mkdir -p $(namespaceddir)
-+ mkdir -p $(DESTDIR)$(namespaceddir)
- endif
-
-
-diff --git a/modules/pam_sepermit/Makefile.am b/modules/pam_sepermit/Makefile.am
-index cfc5594..bc82275 100644
---- a/modules/pam_sepermit/Makefile.am
-+++ b/modules/pam_sepermit/Makefile.am
-@@ -35,7 +35,7 @@ if HAVE_LIBSELINUX
- securelib_LTLIBRARIES = pam_sepermit.la
-
- install-data-local:
-- mkdir -p $(sepermitlockdir)
-+ mkdir -p $(DESTDIR)$(sepermitlockdir)
- endif
- if ENABLE_REGENERATE_MAN
- noinst_DATA = README pam_sepermit.8 sepermit.conf.5
---
-1.7.8.6
-