aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-pam
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-05 15:37:31 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-05 15:37:46 +0100
commit9b8e0b3b7d00434c1c9457b737d389f2a15f2b53 (patch)
tree15fcd976757e206ebcc63caafd2d1a8d852e195e /main/linux-pam
parent5226fab5c4bbebe99965c393bea1ef5686cbf6fe (diff)
downloadaports-9b8e0b3b7d00434c1c9457b737d389f2a15f2b53.tar.bz2
aports-9b8e0b3b7d00434c1c9457b737d389f2a15f2b53.tar.xz
main/linux-pam: upgrade to 2.16
Diffstat (limited to 'main/linux-pam')
-rw-r--r--main/linux-pam/APKBUILD15
-rw-r--r--main/linux-pam/libpam-fix-build-with-eglibc-2.16.patch10
-rw-r--r--main/linux-pam/linux-pam-1.1.6-destdir.patch48
3 files changed, 68 insertions, 5 deletions
diff --git a/main/linux-pam/APKBUILD b/main/linux-pam/APKBUILD
index a5968c5e5f..b116403250 100644
--- a/main/linux-pam/APKBUILD
+++ b/main/linux-pam/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=linux-pam
-pkgver=1.1.5
+pkgver=1.1.6
pkgrel=0
pkgdesc="pluggable authentication modules for linux"
url="http://www.kernel.org/pub/linux/libs/pam"
@@ -9,7 +9,7 @@ arch="all"
license="BSD"
depends=
depends_dev="gettext-dev"
-makedepends="$depends_dev bison flex"
+makedepends="$depends_dev bison flex autoconf automake libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz2
@@ -19,7 +19,9 @@ source="https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz
base-password.pamd
base-session.pamd
base-session-noninteractive.pamd
- other.pamd"
+ other.pamd
+ libpam-fix-build-with-eglibc-2.16.patch
+ linux-pam-1.1.6-destdir.patch"
_builddir="$srcdir"/Linux-PAM-$pkgver
prepare() {
@@ -34,6 +36,7 @@ prepare() {
build() {
cd "$_builddir"
+ autoreconf -vif || return 1
./configure --prefix=/usr \
--libdir=/lib \
--sysconfdir=/etc \
@@ -67,11 +70,13 @@ package() {
find "$pkgdir" -name *.la -print | xargs rm
}
-md5sums="927ee5585bdec5256c75117e9348aa47 Linux-PAM-1.1.5.tar.bz2
+md5sums="7b73e58b7ce79ffa321d408de06db2c4 Linux-PAM-1.1.6.tar.bz2
c309401e103cc86e8b25557ff3eb0b53 linux-pam-innetgr.patch
aa5bb7c9d8e4687aea1ae69b7447254a base-auth.pamd
fafcf29cb9bab788cb4933106be31883 base-account.pamd
117535e4938f478efced1398b408cf96 base-password.pamd
baec6808544bf6cebc59e07467f8c213 base-session.pamd
afbdd8eb4db5c31dfd8e8da35c698b90 base-session-noninteractive.pamd
-b8e839ece64df173f16d28520eb8d66c other.pamd"
+b8e839ece64df173f16d28520eb8d66c other.pamd
+23320dadf8e36846b6bbd7903f95ece5 libpam-fix-build-with-eglibc-2.16.patch
+cc3bb10c851bb925708cc8b74967e3b7 linux-pam-1.1.6-destdir.patch"
diff --git a/main/linux-pam/libpam-fix-build-with-eglibc-2.16.patch b/main/linux-pam/libpam-fix-build-with-eglibc-2.16.patch
new file mode 100644
index 0000000000..1a0716598e
--- /dev/null
+++ b/main/linux-pam/libpam-fix-build-with-eglibc-2.16.patch
@@ -0,0 +1,10 @@
+--- Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c.orig
++++ Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c
+@@ -47,6 +47,7 @@
+ #include <time.h> /* for time() */
+ #include <errno.h>
+ #include <sys/wait.h>
++#include <sys/resource.h>
+
+ #include <security/_pam_macros.h>
+
diff --git a/main/linux-pam/linux-pam-1.1.6-destdir.patch b/main/linux-pam/linux-pam-1.1.6-destdir.patch
new file mode 100644
index 0000000000..6859ccb60d
--- /dev/null
+++ b/main/linux-pam/linux-pam-1.1.6-destdir.patch
@@ -0,0 +1,48 @@
+From d7e6b921cd34f7ad8fc4d05065c75d13ba330896 Mon Sep 17 00:00:00 2001
+From: Tomas Mraz <tmraz@fedoraproject.org>
+Date: Fri, 17 Aug 2012 14:46:40 +0200
+Subject: [PATCH] Add missing $(DESTDIR) when making directories on install.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+modules/pam_namespace/Makefile.am: Add missing $(DESTDIR) when making
+$(namespaceddir) on install.
+modules/pam_sepermit/Makefile.am: Add missing $(DESTDIR) when making
+$(sepermitlockdir) on install.
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
+---
+ modules/pam_namespace/Makefile.am | 2 +-
+ modules/pam_sepermit/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/modules/pam_namespace/Makefile.am b/modules/pam_namespace/Makefile.am
+index a28f196..ebb00f3 100644
+--- a/modules/pam_namespace/Makefile.am
++++ b/modules/pam_namespace/Makefile.am
+@@ -40,7 +40,7 @@ if HAVE_UNSHARE
+ secureconf_SCRIPTS = namespace.init
+
+ install-data-local:
+- mkdir -p $(namespaceddir)
++ mkdir -p $(DESTDIR)$(namespaceddir)
+ endif
+
+
+diff --git a/modules/pam_sepermit/Makefile.am b/modules/pam_sepermit/Makefile.am
+index cfc5594..bc82275 100644
+--- a/modules/pam_sepermit/Makefile.am
++++ b/modules/pam_sepermit/Makefile.am
+@@ -35,7 +35,7 @@ if HAVE_LIBSELINUX
+ securelib_LTLIBRARIES = pam_sepermit.la
+
+ install-data-local:
+- mkdir -p $(sepermitlockdir)
++ mkdir -p $(DESTDIR)$(sepermitlockdir)
+ endif
+ if ENABLE_REGENERATE_MAN
+ noinst_DATA = README pam_sepermit.8 sepermit.conf.5
+--
+1.7.8.6
+