aboutsummaryrefslogtreecommitdiffstats
path: root/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
diff options
context:
space:
mode:
authorTravis Tilley <ttilley@gmail.com>2015-05-27 12:39:40 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-29 13:38:55 +0000
commit08fdc9700ce1b4e47bebc9c9d08959f5e50bc0c1 (patch)
treea2be5477ecf414d7932779f755518cb4b74a6c75 /main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
parent2e13d49d9449cb2fab62471594f3980307bf4cef (diff)
downloadaports-08fdc9700ce1b4e47bebc9c9d08959f5e50bc0c1.tar.bz2
aports-08fdc9700ce1b4e47bebc9c9d08959f5e50bc0c1.tar.xz
main/llvm: update to 3.6.1
clean up and update patchset switch to cmake perform a two-stage build with a minimal bootstrap compile of clang add clang extras update package list to split out clang documentation enable pulling from the svn release tags fix making use of abuild CFLAGS/CXXFLAGS during build don't run check-llvm, as the tests fail when running under PaX
Diffstat (limited to 'main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch')
-rw-r--r--main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch b/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
new file mode 100644
index 0000000000..89174112b6
--- /dev/null
+++ b/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
@@ -0,0 +1,12 @@
+diff --git i/runtime/CMakeLists.txt w/runtime/CMakeLists.txt
+index 9f1cd78..5b3da2e 100644
+--- i/runtime/CMakeLists.txt
++++ w/runtime/CMakeLists.txt
+@@ -46,6 +46,7 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
+ -DCOMPILER_RT_INSTALL_PATH=lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}
+ -DCOMPILER_RT_INCLUDE_TESTS=${LLVM_INCLUDE_TESTS}
+ -DCOMPILER_RT_ENABLE_WERROR=ON
++ -DLLVM_HOST_TRIPLE=${LLVM_HOST_TRIPLE}
+ INSTALL_COMMAND ""
+ STEP_TARGETS configure build
+ )