aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsyncd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-19 21:17:49 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-19 21:19:52 +0000
commit3681c50d3ece8447e5977fec4056485bbb702109 (patch)
treeebb2bd480f581eef415a3846b8cc0910702b0fa9 /main/lsyncd
parent113e3fc801a63b6c891b520d13f104c62d674b97 (diff)
downloadaports-3681c50d3ece8447e5977fec4056485bbb702109.tar.bz2
aports-3681c50d3ece8447e5977fec4056485bbb702109.tar.xz
main/lsyncd: upgrade to 2.2.3 and fixes
- fix doc subpkg - switch to lua 5.3 as 5.1 is no longer supported
Diffstat (limited to 'main/lsyncd')
-rw-r--r--main/lsyncd/APKBUILD19
-rw-r--r--main/lsyncd/fix-mandir.patch9
-rw-r--r--main/lsyncd/lpostcmd.patch25
3 files changed, 16 insertions, 37 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
index 55a573198e..064ddd83d4 100644
--- a/main/lsyncd/APKBUILD
+++ b/main/lsyncd/APKBUILD
@@ -1,27 +1,31 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsyncd
-pkgver=2.2.2
+pkgver=2.2.3
pkgrel=0
+_luaver=5.3
pkgdesc="Live Syncing (Mirror) Daemon"
url="https://github.com/axkibe/lsyncd"
arch="all"
license="GPL-2.0-or-later"
depends="rsync"
-makedepends="$depends_dev cmake lua lua-dev"
-options="!check"
+makedepends="$depends_dev cmake lua$_luaver lua$_luaver-dev"
+options="!check" # needs passwordless ssh access to localhost
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/axkibe/lsyncd/archive/release-$pkgver.tar.gz
fix-realpath.patch
fix-mandir.patch
- lpostcmd.patch
$pkgname.initd"
builddir="$srcdir"/lsyncd-release-$pkgver
build() {
cd "$builddir"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DINSTALL_MANDIR=/usr/share
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DLUA_COMPILER=/usr/bin/luac$_luaver \
+ -DLUA_EXECUTABLE=/usr/bin/lua$_luaver \
+ -DLUA_INCLUDE_DIR=/usr/include/lua$_luaver \
+ -DLUA_LIBRARY=/usr/lib/lua$_luaver/liblua.so
make
}
@@ -36,8 +40,7 @@ package() {
}
-sha512sums="489d4fc91787a53f1480749fce6a281406aedb7e3617cd5f383b30c47870b2a8a912317a3faee5ad5f6358c10a136a69e07ee854f753846be1e11023cea5fed0 lsyncd-2.2.2.tar.gz
+sha512sums="2193a342f8aa7d8cfb55378c9c59ca61d2d8e4026263fd6e6560c730c712cef1f189305a3f9bca58f5b9c9ffae5af12e1d75e5355d5bdae86a47ad9595b8169a lsyncd-2.2.3.tar.gz
2cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch
-00508996b83297fd069bd4580581859d5ef696ec906a2011d62f2582630c7d98188a851490f5503ba1302ef34f56e6b36780a1ce00806dbeeb62421e2ef8283d fix-mandir.patch
-d0f971e99726fd5b7157928f4c790b9aeaf05becd23a2898101b89567297816c866b13cddb8b91cbe87cf3e0c05e3a613896c28f2926269c21f4f857ce1de189 lpostcmd.patch
+6283f973768467942a69cb4fd835cfef81ffd1d9acccdea21b1f40730f67d5ff0e8db33772f28be2a6abb352c9596a01dbf215aa228072f7439b69ad8c691c61 fix-mandir.patch
441b76ec944d9d74100dfca55efe871e9092b37cd49ec79a2a94e281dc0326b4def1645a827f7d3edcddc95d6e74c99621b62991396fb3693b1832c42fd86cdc lsyncd.initd"
diff --git a/main/lsyncd/fix-mandir.patch b/main/lsyncd/fix-mandir.patch
index 3ea5b9b285..6eceefe36a 100644
--- a/main/lsyncd/fix-mandir.patch
+++ b/main/lsyncd/fix-mandir.patch
@@ -1,8 +1,9 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -106,4 +106,4 @@
+--- ./CMakeLists.txt.orig
++++ ./CMakeLists.txt
+@@ -107,5 +107,5 @@
target_link_libraries( lsyncd ${LUA_LIBRARIES} )
install( TARGETS lsyncd RUNTIME DESTINATION bin )
-install( FILES doc/manpage/lsyncd.1 DESTINATION man )
-+install( FILES doc/manpage/lsyncd.1 DESTINATION share/man )
++install( FILES doc/manpage/lsyncd.1 DESTINATION share/man/man1 )
+
diff --git a/main/lsyncd/lpostcmd.patch b/main/lsyncd/lpostcmd.patch
deleted file mode 100644
index 7f16bf4914..0000000000
--- a/main/lsyncd/lpostcmd.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -ru lsyncd-2.1.5.orig/examples/lpostcmd.lua lsyncd-2.1.5/examples/lpostcmd.lua
---- lsyncd-2.1.5.orig/examples/lpostcmd.lua 2015-01-30 09:28:40.376456301 -0200
-+++ lsyncd-2.1.5/examples/lpostcmd.lua 2015-01-30 09:28:12.746457070 -0200
-@@ -6,7 +6,7 @@
- -- after every successfullycompleted rsync operation.
- -- for example to restart servlets on the target host or so.
-
-+rsyncpostcmd = {
--local rsyncpostcmd = {
-
- -- based on default rsync.
- default.rsync,
-@@ -83,12 +83,3 @@
- end
- }
-
--
--sync {
-- rsyncpostcmd,
-- source = "src",
-- host = "beetle",
-- targetdir = "/path/to/trg",
-- postcmd = "/usr/local/bin/restart-servelt.sh",
--}
--