aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsyncd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-01-08 11:14:15 +0200
committerTimo Teräs <timo.teras@iki.fi>2015-01-08 11:14:57 +0200
commit4c5a6852d499231f038d466970f5374977c09a7d (patch)
tree647d49cc310bedf3abc70049578b374b0eb2819b /main/lsyncd
parent99fc0aafe050da949421bbf4b61420f0b2b81d7f (diff)
downloadaports-4c5a6852d499231f038d466970f5374977c09a7d.tar.bz2
aports-4c5a6852d499231f038d466970f5374977c09a7d.tar.xz
main/lsyncd: fix lpostcmd example script after upgrade
Seems the upstream lpostcmd.lua example is outdated, and needs few additional fixes again. fixes #3678.
Diffstat (limited to 'main/lsyncd')
-rw-r--r--main/lsyncd/APKBUILD8
-rw-r--r--main/lsyncd/lpostcmd.patch19
2 files changed, 18 insertions, 9 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
index 7e3e597794..312831cbc1 100644
--- a/main/lsyncd/APKBUILD
+++ b/main/lsyncd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsyncd
pkgver=2.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Live Syncing (Mirror) Daemon"
url="http://code.google.com/p/lsyncd/"
arch="all"
@@ -55,13 +55,13 @@ package() {
md5sums="fb10547494ec5ec662fe88343047c364 lsyncd-2.1.5.tar.gz
a14565df7274ebd0b605301ca39ae885 fix-realpath.patch
-51e42290519bb2f4492d18b0209dfab1 lpostcmd.patch
+2d1ff04792a8b8188afe1d3d11069443 lpostcmd.patch
c9e77dddc6dc3eef6f35bf2d23658818 lsyncd.initd"
sha256sums="4a793056c4ed833edb59436d7711bb65f7e38a4d8d44371cc9dc5eb91fbc461f lsyncd-2.1.5.tar.gz
26454c77bb005c165c10b05b232c587669d35ab98e0ac889a11923106126f98e fix-realpath.patch
-1e7cdd7fa8e510faaf4a04f4ee43b03c6d6ab8a754e576d630f54e882bf7bdb1 lpostcmd.patch
+3972481b8369db8b71bed82982c5b827dcd22b177c6843c03a45f31b9d257e2d lpostcmd.patch
770b2c123d062ddcbf7c9eb709c56f9dd812cce66bf5e76b88a86609cc9925b0 lsyncd.initd"
sha512sums="7be939e979525f8e4687432ffe952b1d09b8a34b4d7f92ebe86b5cddb765dbd602258682612529e9cc51305d6d001e72de9e6da62761397df23ecda30fd6a12b lsyncd-2.1.5.tar.gz
2cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch
-389bd6857ac075a27c00b06bbceffb82a501b67c352a43982add42bf58f506b9bfb765486937c3776b213286da1bd5c566dd3ee2435b64aa899a9b807eee028c lpostcmd.patch
+1d31787059e427b49aee572a91e5ba315e4d06c7f8238415ded76144a8fb48286917d3a1dedb3ec82c6ad8bf4d058462c10b2ffa99f4dd0a2f48655e2fc2535a lpostcmd.patch
e283f81c4d8c2c5b7cc333920a7f69f059846eb537a1c8700bfaf9e07f65740e76afe4726348d785c00fae11067fabb0917cacb42193b96d550807cc9b65a445 lsyncd.initd"
diff --git a/main/lsyncd/lpostcmd.patch b/main/lsyncd/lpostcmd.patch
index c5d6944193..3525a066bc 100644
--- a/main/lsyncd/lpostcmd.patch
+++ b/main/lsyncd/lpostcmd.patch
@@ -1,5 +1,5 @@
---- a/examples/lpostcmd.lua
-+++ b/examples/lpostcmd.lua
+--- lsyncd-2.1.5/examples/lpostcmd.lua 2013-06-03 14:48:29.000000000 -0300
++++ ../lpostcmd.lua 2015-01-08 11:11:52.500886631 -0200
@@ -6,7 +6,7 @@
-- after every successfullycompleted rsync operation.
-- for example to restart servlets on the target host or so.
@@ -18,7 +18,7 @@
spawn(event, "/usr/bin/ssh",
config.host, config.postcmd)
return
-@@ -58,7 +58,7 @@
+@@ -58,11 +58,11 @@
return default.collect(agent,exitcode)
end
error("this should never be reached")
@@ -27,8 +27,17 @@
-- called before anything else
-- builds the target from host and targetdir
-@@ -75,13 +75,3 @@
- return default.rsync.prepare(config)
+- prepare = function(config)
++ prepare = function(config, level, skipTarget)
+ if not config.host then
+ error("rsyncpostcmd neets 'host' configured", 4)
+ end
+@@ -72,16 +72,6 @@
+ if not config.target then
+ config.target = config.host .. ":" .. config.targetdir
+ end
+- return default.rsync.prepare(config)
++ return default.rsync.prepare(config, level, skipTarget)
end
}
-