aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsyncd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-04-11 10:12:42 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-04-11 10:12:42 +0300
commitaa6f7efd4f5b46dd477ddabc120ec76ed3ebc631 (patch)
treef0d8c0f79ca4abea22749d1a30f8a5263c36fa39 /main/lsyncd
parent672de25ac676f5da1b471b3cfdcc23bf855a4cfa (diff)
downloadaports-aa6f7efd4f5b46dd477ddabc120ec76ed3ebc631.tar.bz2
aports-aa6f7efd4f5b46dd477ddabc120ec76ed3ebc631.tar.xz
main/lsyncd: moved from testing
Diffstat (limited to 'main/lsyncd')
-rw-r--r--main/lsyncd/APKBUILD52
-rw-r--r--main/lsyncd/lsyncd.initd32
2 files changed, 84 insertions, 0 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
new file mode 100644
index 0000000000..61a797cf3f
--- /dev/null
+++ b/main/lsyncd/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lsyncd
+pkgver=2.0.4
+pkgrel=2
+pkgdesc="Live Syncing (Mirror) Daemon"
+url="http://code.google.com/p/lsyncd/"
+arch="all"
+license="GPLv2+"
+depends="rsync"
+depends_dev=
+makedepends="$depends_dev lua-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://lsyncd.googlecode.com/files/lsyncd-$pkgver.tar.gz
+ $pkgname.initd"
+
+_builddir="$srcdir"/lsyncd-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$pkgdir/etc/lsyncd"
+ cp "$_builddir"/examples/*.lua \
+ "$pkgdir"/etc/lsyncd/
+ install -Dm755 "$srcdir/$pkgname.initd" \
+ "$pkgdir/etc/init.d/$pkgname" || return 1
+
+}
+
+md5sums="0b4557dd3d87a02ae0cbd7b5fc16cd0c lsyncd-2.0.4.tar.gz
+b3d38982ef1a6e09a76586418ec6c35d lsyncd.initd"
diff --git a/main/lsyncd/lsyncd.initd b/main/lsyncd/lsyncd.initd
new file mode 100644
index 0000000000..5578b1a2af
--- /dev/null
+++ b/main/lsyncd/lsyncd.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+
+NAME=lsyncd
+DAEMON=/usr/bin/$NAME
+PIDFILE=/var/run/$NAME.pid
+USER=root
+GROUP=root
+CONF=/etc/lsyncd/lsyncd.lua
+
+depend() {
+ need net
+}
+
+start() {
+ touch "$PIDFILE"
+ chown $USER:$GROUP "$PIDFILE"
+ ebegin "Starting $NAME"
+ start-stop-daemon --start --quiet \
+ --pidfile "$PIDFILE" \
+ --user "$USER" --group "$GROUP" \
+ --chdir /etc/lsyncd \
+ --exec "$DAEMON" -- \
+ "$CONF" -pidfile "$PIDFILE"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --quiet \
+ --pidfile "$PIDFILE"
+ eend $?
+}