aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsyncd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-01-30 10:47:20 +0200
committerTimo Teräs <timo.teras@iki.fi>2015-01-30 10:48:09 +0200
commitb5baa711a9758d453cb33a6e23de7163e5b40c66 (patch)
tree03badc06fed2e9b8b94210ec3bb26e97be2e9c09 /main/lsyncd
parent6f0559e6f3b1e5e7de0f8d28816971941809324d (diff)
downloadaports-b5baa711a9758d453cb33a6e23de7163e5b40c66.tar.bz2
aports-b5baa711a9758d453cb33a6e23de7163e5b40c66.tar.xz
main/lsyncd: additional fixes to lpostcmd
Diffstat (limited to 'main/lsyncd')
-rw-r--r--main/lsyncd/0001-Add-missed-comma.patch25
-rw-r--r--main/lsyncd/0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch25
-rw-r--r--main/lsyncd/0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch34
-rw-r--r--main/lsyncd/0003-Add-checkgauge-in-lpostcmd.patch31
-rw-r--r--main/lsyncd/APKBUILD24
-rw-r--r--main/lsyncd/lpostcmd.patch39
6 files changed, 141 insertions, 37 deletions
diff --git a/main/lsyncd/0001-Add-missed-comma.patch b/main/lsyncd/0001-Add-missed-comma.patch
new file mode 100644
index 0000000000..3348955698
--- /dev/null
+++ b/main/lsyncd/0001-Add-missed-comma.patch
@@ -0,0 +1,25 @@
+From 7addc7060b05e664b8e09e5c13b294e8e6394481 Mon Sep 17 00:00:00 2001
+From: Kazunori SAKAMOTO <exkazuu@gmail.com>
+Date: Fri, 3 Jan 2014 17:11:48 +0900
+Subject: [PATCH] Add missed comma.
+
+---
+ examples/lpostcmd.lua | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/lpostcmd.lua b/examples/lpostcmd.lua
+index e11639b..b48b0da 100644
+--- a/examples/lpostcmd.lua
++++ b/examples/lpostcmd.lua
+@@ -58,7 +58,7 @@ local rsyncpostcmd = {
+ return default.collect(agent,exitcode)
+ end
+ error("this should never be reached")
+- end
++ end,
+
+ -- called before anything else
+ -- builds the target from host and targetdir
+--
+2.2.2
+
diff --git a/main/lsyncd/0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch b/main/lsyncd/0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
new file mode 100644
index 0000000000..34f3de1a10
--- /dev/null
+++ b/main/lsyncd/0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
@@ -0,0 +1,25 @@
+From 19b08adf3520a221e77fe6ea4ebbeddd66966cac Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 30 Jan 2015 09:08:58 +0200
+Subject: [PATCH 1/3] Fix lpostcmd to use isPostcmd via rawget as intended
+
+---
+ examples/lpostcmd.lua | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/lpostcmd.lua b/examples/lpostcmd.lua
+index b48b0da..11f7faf 100644
+--- a/examples/lpostcmd.lua
++++ b/examples/lpostcmd.lua
+@@ -25,7 +25,7 @@ local rsyncpostcmd = {
+ -- uses rawget to test if "isPostcmd" has been set without
+ -- triggering an error if not.
+ local isPostcmd = rawget(event, "isPostcmd")
+- if event.isPostcmd then
++ if isPostcmd then
+ spawn(event, "/usr/bin/ssh",
+ config.host, config.postcmd)
+ return
+--
+2.2.2
+
diff --git a/main/lsyncd/0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch b/main/lsyncd/0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
new file mode 100644
index 0000000000..27f921a93d
--- /dev/null
+++ b/main/lsyncd/0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
@@ -0,0 +1,34 @@
+From 5b76dc1cb6cacd5a086dc3870e39ab2d251ed5dc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 30 Jan 2015 09:12:02 +0200
+Subject: [PATCH 2/3] Fix lpostcmd prepare to work with recent changes
+
+---
+ examples/lpostcmd.lua | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/examples/lpostcmd.lua b/examples/lpostcmd.lua
+index 11f7faf..8ad339e 100644
+--- a/examples/lpostcmd.lua
++++ b/examples/lpostcmd.lua
+@@ -62,7 +62,7 @@ local rsyncpostcmd = {
+
+ -- called before anything else
+ -- builds the target from host and targetdir
+- prepare = function(config)
++ prepare = function(config, level, skipTarget)
+ if not config.host then
+ error("rsyncpostcmd neets 'host' configured", 4)
+ end
+@@ -72,7 +72,7 @@ local rsyncpostcmd = {
+ if not config.target then
+ config.target = config.host .. ":" .. config.targetdir
+ end
+- return default.rsync.prepare(config)
++ return default.rsync.prepare(config, level, skipTarget)
+ end
+ }
+
+--
+2.2.2
+
diff --git a/main/lsyncd/0003-Add-checkgauge-in-lpostcmd.patch b/main/lsyncd/0003-Add-checkgauge-in-lpostcmd.patch
new file mode 100644
index 0000000000..35729fa100
--- /dev/null
+++ b/main/lsyncd/0003-Add-checkgauge-in-lpostcmd.patch
@@ -0,0 +1,31 @@
+From abbf307b9720140a3dd71e96f8ea0328e1bd7115 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 30 Jan 2015 09:25:53 +0200
+Subject: [PATCH 3/3] Add checkgauge in lpostcmd
+
+---
+ examples/lpostcmd.lua | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/examples/lpostcmd.lua b/examples/lpostcmd.lua
+index 8ad339e..e413112 100644
+--- a/examples/lpostcmd.lua
++++ b/examples/lpostcmd.lua
+@@ -11,6 +11,14 @@ local rsyncpostcmd = {
+ -- based on default rsync.
+ default.rsync,
+
++ checkgauge = {
++ default.rsync.checkgauge,
++ host = true,
++ targetdir = true,
++ target = true,
++ postcmd = true,
++ },
++
+ -- for this config it is important to keep maxProcesses at 1, so
+ -- the postcmds will only be spawned after the rsync completed
+ maxProcesses = 1,
+--
+2.2.2
+
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
index c6c83b13e6..1cefb970db 100644
--- a/main/lsyncd/APKBUILD
+++ b/main/lsyncd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsyncd
pkgver=2.1.5
-pkgrel=3
+pkgrel=4
pkgdesc="Live Syncing (Mirror) Daemon"
url="http://code.google.com/p/lsyncd/"
arch="all"
@@ -14,6 +14,10 @@ install=""
subpackages="$pkgname-doc"
source="http://lsyncd.googlecode.com/files/lsyncd-$pkgver.tar.gz
fix-realpath.patch
+ 0001-Add-missed-comma.patch
+ 0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
+ 0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
+ 0003-Add-checkgauge-in-lpostcmd.patch
lpostcmd.patch
CVE-2014-8990.patch
$pkgname.initd"
@@ -56,16 +60,28 @@ package() {
md5sums="fb10547494ec5ec662fe88343047c364 lsyncd-2.1.5.tar.gz
a14565df7274ebd0b605301ca39ae885 fix-realpath.patch
-2d1ff04792a8b8188afe1d3d11069443 lpostcmd.patch
+d342bf626a302c5b10a1dfaa114b3608 0001-Add-missed-comma.patch
+e5071ed33b4e0afb6697e9fe3ca1aa8e 0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
+2265cc5b0d3833a125207e2bb774cbf7 0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
+11da73fdade84dcb23309fed76ad2122 0003-Add-checkgauge-in-lpostcmd.patch
+77a42725c786745a67d5435bf9978ad5 lpostcmd.patch
8f3d89a6594e62a3e4ed5732ce22bda7 CVE-2014-8990.patch
c9e77dddc6dc3eef6f35bf2d23658818 lsyncd.initd"
sha256sums="4a793056c4ed833edb59436d7711bb65f7e38a4d8d44371cc9dc5eb91fbc461f lsyncd-2.1.5.tar.gz
26454c77bb005c165c10b05b232c587669d35ab98e0ac889a11923106126f98e fix-realpath.patch
-3972481b8369db8b71bed82982c5b827dcd22b177c6843c03a45f31b9d257e2d lpostcmd.patch
+c9417a8f347b430feb760a2af09687fd1ebca07acee7fb9fc9b9e258b1c895ba 0001-Add-missed-comma.patch
+ff2514730329052a75640f827b72947aa19726d9c65e5564d4aa8aeec4d21ccf 0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
+d79f9dc6fc81a1dc980fbee01edf87307787f519919e995e8cc6fc31784dd9ee 0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
+7aebb029703d03fe566b6100fb5702e90829cd56bd71e9a429a3d440a9fc00dd 0003-Add-checkgauge-in-lpostcmd.patch
+1cf732eefa4be22e1a86bbd85aad5ac0903ebf5d99f97e02b233341297ed7e2c lpostcmd.patch
0896409e11c7e2d464cdca6dbd4493477d7858fe58d7dcf5eb63a01609892fad CVE-2014-8990.patch
770b2c123d062ddcbf7c9eb709c56f9dd812cce66bf5e76b88a86609cc9925b0 lsyncd.initd"
sha512sums="7be939e979525f8e4687432ffe952b1d09b8a34b4d7f92ebe86b5cddb765dbd602258682612529e9cc51305d6d001e72de9e6da62761397df23ecda30fd6a12b lsyncd-2.1.5.tar.gz
2cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch
-1d31787059e427b49aee572a91e5ba315e4d06c7f8238415ded76144a8fb48286917d3a1dedb3ec82c6ad8bf4d058462c10b2ffa99f4dd0a2f48655e2fc2535a lpostcmd.patch
+fe36e46409ff12e659d23c4243ca2ff8865f0da551d1920921e3c7a198ce0910bf73137cf0b052784aafa418702ddcfd669268b83040d90bdcf0d68948ef6d34 0001-Add-missed-comma.patch
+758fce99c5f6d89ad7ac160e6b387dcc750bac6f3ab07b7f533acda642cd698b6da2861dddf9e98472f6f4b2b85688d6f251c8fee968857405cecc86988353a9 0001-Fix-lpostcmd-to-use-isPostcmd-via-rawget-as-intended.patch
+313072937ba4787780daac94bc61444eb1588a289f60c8a0de37a170fc3bf1bf4bdc5ef17b41c50a26843a63943a2aca43bcca2f74f6a10c1fcac467323342a1 0002-Fix-lpostcmd-prepare-to-work-with-recent-changes.patch
+8792b684de39e4aa30800f45668ab67dc55db297cf9867b18022f690b3d01b67520c55c75667ea85e2026b5c5b52a1d054abce3778632c5ef9ace8f22dfa9db7 0003-Add-checkgauge-in-lpostcmd.patch
+d0f971e99726fd5b7157928f4c790b9aeaf05becd23a2898101b89567297816c866b13cddb8b91cbe87cf3e0c05e3a613896c28f2926269c21f4f857ce1de189 lpostcmd.patch
43d3b511d3242be65e3e9aece581d0caa59b43025087b5bdd856cf833ce84438bde90f926c657332414cb45393a3a78433ae2c5b4c8be652f9a4ac80891e09e7 CVE-2014-8990.patch
e283f81c4d8c2c5b7cc333920a7f69f059846eb537a1c8700bfaf9e07f65740e76afe4726348d785c00fae11067fabb0917cacb42193b96d550807cc9b65a445 lsyncd.initd"
diff --git a/main/lsyncd/lpostcmd.patch b/main/lsyncd/lpostcmd.patch
index 3525a066bc..7f16bf4914 100644
--- a/main/lsyncd/lpostcmd.patch
+++ b/main/lsyncd/lpostcmd.patch
@@ -1,46 +1,19 @@
---- lsyncd-2.1.5/examples/lpostcmd.lua 2013-06-03 14:48:29.000000000 -0300
-+++ ../lpostcmd.lua 2015-01-08 11:11:52.500886631 -0200
+diff -ru lsyncd-2.1.5.orig/examples/lpostcmd.lua lsyncd-2.1.5/examples/lpostcmd.lua
+--- lsyncd-2.1.5.orig/examples/lpostcmd.lua 2015-01-30 09:28:40.376456301 -0200
++++ lsyncd-2.1.5/examples/lpostcmd.lua 2015-01-30 09:28:12.746457070 -0200
@@ -6,7 +6,7 @@
-- after every successfullycompleted rsync operation.
-- for example to restart servlets on the target host or so.
--local rsyncpostcmd = {
+rsyncpostcmd = {
+-local rsyncpostcmd = {
-- based on default rsync.
default.rsync,
-@@ -25,7 +25,7 @@
- -- uses rawget to test if "isPostcmd" has been set without
- -- triggering an error if not.
- local isPostcmd = rawget(event, "isPostcmd")
-- if event.isPostcmd then
-+ if isPostcmd then
- spawn(event, "/usr/bin/ssh",
- config.host, config.postcmd)
- return
-@@ -58,11 +58,11 @@
- return default.collect(agent,exitcode)
- end
- error("this should never be reached")
-- end
-+ end,
-
- -- called before anything else
- -- builds the target from host and targetdir
-- prepare = function(config)
-+ prepare = function(config, level, skipTarget)
- if not config.host then
- error("rsyncpostcmd neets 'host' configured", 4)
- end
-@@ -72,16 +72,6 @@
- if not config.target then
- config.target = config.host .. ":" .. config.targetdir
- end
-- return default.rsync.prepare(config)
-+ return default.rsync.prepare(config, level, skipTarget)
+@@ -83,12 +83,3 @@
end
}
--
+
-
-sync {
- rsyncpostcmd,