aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-asn1
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-07-31 17:10:11 +0300
committerTimo Teräs <timo.teras@iki.fi>2015-07-31 17:10:38 +0300
commitf9376f05439ebebe90c0fb5ef0bf2e8a45c86259 (patch)
tree053b6bd0b2c3582f1d8434b13025d45f58346745 /main/lua-asn1
parent199a1151af56772547c7863963f6f2b13d7af90f (diff)
downloadaports-f9376f05439ebebe90c0fb5ef0bf2e8a45c86259.tar.bz2
aports-f9376f05439ebebe90c0fb5ef0bf2e8a45c86259.tar.xz
main/lua-asn1: fix authid tagging
Diffstat (limited to 'main/lua-asn1')
-rw-r--r--main/lua-asn1/APKBUILD15
-rw-r--r--main/lua-asn1/fix-authkeyid-tagging.patch13
2 files changed, 23 insertions, 5 deletions
diff --git a/main/lua-asn1/APKBUILD b/main/lua-asn1/APKBUILD
index ee02e87c52..a766db13da 100644
--- a/main/lua-asn1/APKBUILD
+++ b/main/lua-asn1/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=lua-asn1
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="ASN.1 framework for Lua"
url=https://github.com/kunkku/lua-asn1
arch=noarch
@@ -11,7 +11,9 @@ depends=
makedepends=
install=
subpackages=
-source=$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
+ fix-authkeyid-tagging.patch
+ "
_builddir=$srcdir/$pkgname-$pkgver
prepare() {
@@ -33,6 +35,9 @@ package() {
make install "ROOT_DIR=$pkgdir"
}
-md5sums="954157a3ab08eb14186533ea7a8ea70f lua-asn1-1.0.0.tar.gz"
-sha256sums="60bdcb40f8528a4c30c3bdb1c2926e3558d3f5b50d515d71b14511b206f98c1e lua-asn1-1.0.0.tar.gz"
-sha512sums="a50ac73ee8e5e585bf641fbb18da8e0255401196fdac1d5c54d9a2354228e91d1194db0a2fa9121ccd199113c8db2863f1d8043bbfb22d8355443326ccd898b4 lua-asn1-1.0.0.tar.gz"
+md5sums="954157a3ab08eb14186533ea7a8ea70f lua-asn1-1.0.0.tar.gz
+85a6d5cfb6ec8db82e4606e172fc94c3 fix-authkeyid-tagging.patch"
+sha256sums="60bdcb40f8528a4c30c3bdb1c2926e3558d3f5b50d515d71b14511b206f98c1e lua-asn1-1.0.0.tar.gz
+d5783f093a6ae938e4b5dc2d74e9f156331436c3cbc6e18bce680559894e5c65 fix-authkeyid-tagging.patch"
+sha512sums="a50ac73ee8e5e585bf641fbb18da8e0255401196fdac1d5c54d9a2354228e91d1194db0a2fa9121ccd199113c8db2863f1d8043bbfb22d8355443326ccd898b4 lua-asn1-1.0.0.tar.gz
+d98a946dffbe7f1ab22d3c923ed17a0f69cb55f08389e3795d86c5487ca9a6e3a1bf44a6351fe6e15cfd6b93b4de5b9ff5d788cacfb3de932483b261a4b829e9 fix-authkeyid-tagging.patch"
diff --git a/main/lua-asn1/fix-authkeyid-tagging.patch b/main/lua-asn1/fix-authkeyid-tagging.patch
new file mode 100644
index 0000000000..8e81bca2e9
--- /dev/null
+++ b/main/lua-asn1/fix-authkeyid-tagging.patch
@@ -0,0 +1,13 @@
+diff --git a/asn1/rfc5280.lua b/asn1/rfc5280.lua
+index 9c077ed..315383b 100644
+--- a/asn1/rfc5280.lua
++++ b/asn1/rfc5280.lua
+@@ -10,7 +10,7 @@ local M = {}
+ M.KeyIdentifier = asn1.octet_string()
+
+ M.AuthorityKeyIdentifier = asn1.sequence{
+- {'keyIdentifier', asn1.explicit(0, M.KeyIdentifier)}
++ {'keyIdentifier', asn1.octet_string{tag=0}}
+ }
+
+ M.CRLDistributionPoints = asn1.sequence_of(