aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-crypto
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-03-17 07:10:00 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-03-17 12:41:33 +0000
commitb00e3ee5a862950cf95d548de0f1e54c55da52c2 (patch)
tree9828acb3509b1f4036240caae420174a93f2c4c7 /main/lua-crypto
parent41681c753490d6bd82cd563df426cc6b7d3a9ccb (diff)
downloadaports-b00e3ee5a862950cf95d548de0f1e54c55da52c2.tar.bz2
aports-b00e3ee5a862950cf95d548de0f1e54c55da52c2.tar.xz
main/lua-crypto: fix bug
lua5.1 LUA_CFLAGS is blank thus fails configure script
Diffstat (limited to 'main/lua-crypto')
-rw-r--r--main/lua-crypto/APKBUILD13
-rw-r--r--main/lua-crypto/lua5.1-blank-LUA_CFLAGS-fails-configure.patch21
2 files changed, 27 insertions, 7 deletions
diff --git a/main/lua-crypto/APKBUILD b/main/lua-crypto/APKBUILD
index c706a5434b..7be8faa23d 100644
--- a/main/lua-crypto/APKBUILD
+++ b/main/lua-crypto/APKBUILD
@@ -2,20 +2,21 @@
_luaversions="5.1 5.2 5.3"
pkgname=lua-crypto
pkgver=0.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="a Lua frontend to the OpenSSL cryptographic library"
url="http://mkottman.github.io/luacrypto/"
arch="all"
license="MIT/X11"
depends=
-makedepends="libressl-dev"
+makedepends="libressl-dev lua-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-crypto:split_${_v/./_}"
done
-source="luacrypto-$pkgver.tar.gz::https://github.com/mkottman/luacrypto/archive/$pkgver.tar.gz"
+source="luacrypto-$pkgver.tar.gz::https://github.com/mkottman/luacrypto/archive/$pkgver.tar.gz
+ lua5.1-blank-LUA_CFLAGS-fails-configure.patch"
_builddir="$srcdir"/luacrypto-$pkgver
@@ -71,7 +72,5 @@ for _v in $_luaversions; do
eval "split_${_v/./_}() { _split $_v; }"
done
-
-md5sums="07271929beec760a42eff012803490a1 luacrypto-0.3.2.tar.gz"
-sha256sums="63c5d7e2539779039114335b9a8f149d63382c4db298d69e70488a0108143bb4 luacrypto-0.3.2.tar.gz"
-sha512sums="4cb20d2cc348a11f140210dffb803629034c72cc7232590f4488f559d5c7233e0c41e56fcd0863959ac0b07e64c9aa79ea573e4126fdc11bc3f1b3b49d13343e luacrypto-0.3.2.tar.gz"
+sha512sums="4cb20d2cc348a11f140210dffb803629034c72cc7232590f4488f559d5c7233e0c41e56fcd0863959ac0b07e64c9aa79ea573e4126fdc11bc3f1b3b49d13343e luacrypto-0.3.2.tar.gz
+cca8745c5b46fa8b3adc237eb1d926c008b6d03637978568537da8c505479272f2b08bbcf1b016883eb783dd88759533aae5fd14fe3d5927b36f54074afdcd34 lua5.1-blank-LUA_CFLAGS-fails-configure.patch"
diff --git a/main/lua-crypto/lua5.1-blank-LUA_CFLAGS-fails-configure.patch b/main/lua-crypto/lua5.1-blank-LUA_CFLAGS-fails-configure.patch
new file mode 100644
index 0000000000..a6fb53832c
--- /dev/null
+++ b/main/lua-crypto/lua5.1-blank-LUA_CFLAGS-fails-configure.patch
@@ -0,0 +1,21 @@
+
+---
+ configure | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure b/configure
+index eb01472..970eb8d 100755
+--- a/configure
++++ b/configure
+@@ -12331,6 +12331,8 @@ $as_echo_n "checking for LUA... " >&6; }
+
+ if test -n "$LUA_CFLAGS"; then
+ pkg_cv_LUA_CFLAGS="$LUA_CFLAGS"
++ elif test -n "$LUA_LIBS"; then
++ pkg_cv_LUA_LIBS="$LUA_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua\""; } >&5
+--
+2.11.1
+