aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-filesystem
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:14:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:14:54 +0000
commit5c0dbeab91eaa30171af6e1f72b6b11301e9dce3 (patch)
tree95d56827808f57aea219850f496d7f599f0ee7ee /main/lua-filesystem
parent988dd094caa1823cdaacc0de38cd21a661a6e9ca (diff)
downloadaports-5c0dbeab91eaa30171af6e1f72b6b11301e9dce3.tar.bz2
aports-5c0dbeab91eaa30171af6e1f72b6b11301e9dce3.tar.xz
main/lua-filesystem: moved from testing
Diffstat (limited to 'main/lua-filesystem')
-rw-r--r--main/lua-filesystem/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/lua-filesystem/APKBUILD b/main/lua-filesystem/APKBUILD
new file mode 100644
index 0000000000..2864086990
--- /dev/null
+++ b/main/lua-filesystem/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-filesystem
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="Lua library to complement the set of functions related to file systems"
+url="http://www.keplerproject.org/luafilesystem/"
+license="GPL"
+depends=
+makedepends="lua-dev"
+install=
+subpackages=
+source="http://github.com/downloads/keplerproject/luafilesystem/luafilesystem-$pkgver.tar.gz"
+
+_builddir="$srcdir"/luafilesystem-$pkgver
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make LUA_LIBDIR="$pkgdir"/usr/lib/lua/5.1 install
+}
+
+md5sums="3cf4882bbce956e7a0b010f148f194a3 luafilesystem-1.5.0.tar.gz"