aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-penlight
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 08:32:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-08 22:00:35 -0300
commitd630e98ca3f7102882e072a00f1bc204d14e61da (patch)
tree84496d7bbd8865be59e41e60fdb450dc5660cf99 /main/lua-penlight
parent1ea3a54e39763914f410eb897a799e8d30ea7488 (diff)
downloadaports-d630e98ca3f7102882e072a00f1bc204d14e61da.tar.bz2
aports-d630e98ca3f7102882e072a00f1bc204d14e61da.tar.xz
main/lua-penlight: enable luajit on s390x
Diffstat (limited to 'main/lua-penlight')
-rw-r--r--main/lua-penlight/APKBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/main/lua-penlight/APKBUILD b/main/lua-penlight/APKBUILD
index eae4748b59..056d355978 100644
--- a/main/lua-penlight/APKBUILD
+++ b/main/lua-penlight/APKBUILD
@@ -8,17 +8,13 @@ url="http://stevedonovan.github.io/Penlight"
arch="noarch"
license="MIT"
depends="lua lua-filesystem"
-provides="$pkgname-shared=$pkgver-r$pkgrel" # for backward compatibility
-replaces="$pkgname-shared" # for backward compatibility
+checkdepends="luajit"
subpackages="$pkgname-doc"
source="$_rockname-$pkgver.tar.gz::https://github.com/stevedonovan/Penlight/archive/$pkgver.tar.gz"
builddir="$srcdir/Penlight-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
+provides="$pkgname-shared=$pkgver-r$pkgrel" # for backward compatibility
+replaces="$pkgname-shared" # for backward compatibility
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
@@ -27,9 +23,7 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
-
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on Lua $lver"
lua$lver run.lua tests
done
@@ -40,8 +34,6 @@ package() {
local rockdir="$pkgdir/usr/lib/luarocks/rocks-common/$_rockname/$pkgver-1"
local docdir="$pkgdir/usr/share/doc/$pkgname"
- cd "$builddir"
-
mkdir -p "$lmod_dir" "$docdir"
cp -r lua/pl "$lmod_dir"/
cp -r examples "$docdir"/