aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-posix
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-10 05:46:12 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-10 05:46:12 +0000
commit394715c229fb75604f813c39f24430159023a31c (patch)
treefee21459727ea85bfb7a2c999d26a47747b415a9 /main/lua-posix
parente85b4e9ec001bd6a30ed3812b65e99c475e56365 (diff)
downloadaports-394715c229fb75604f813c39f24430159023a31c.tar.bz2
aports-394715c229fb75604f813c39f24430159023a31c.tar.xz
main/lua-posix: fix musl build
fix lua-version.patch to have proper escape for dot, and use the patch. need to also autoregen configury for it to take affect.
Diffstat (limited to 'main/lua-posix')
-rw-r--r--main/lua-posix/0001-Removed-Lua-5.2-functions-lua_len-and-lua_tointegerx.patch30
-rw-r--r--main/lua-posix/APKBUILD14
-rw-r--r--main/lua-posix/lua-version.patch4
3 files changed, 12 insertions, 36 deletions
diff --git a/main/lua-posix/0001-Removed-Lua-5.2-functions-lua_len-and-lua_tointegerx.patch b/main/lua-posix/0001-Removed-Lua-5.2-functions-lua_len-and-lua_tointegerx.patch
deleted file mode 100644
index c6fffd54fb..0000000000
--- a/main/lua-posix/0001-Removed-Lua-5.2-functions-lua_len-and-lua_tointegerx.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9f6c2a8fe34db847df957e55e0375b5cf15a44b9 Mon Sep 17 00:00:00 2001
-From: nmcveity <nmcveity@gmail.com>
-Date: Mon, 4 Mar 2013 22:49:27 -0800
-Subject: [PATCH] Removed Lua 5.2 functions lua_len and lua_tointegerx
-
-This fixes issue #71.
----
- lposix.c | 6 +-----
- 1 file changed, 1 insertion(+), 5 deletions(-)
-
-diff --git a/lposix.c b/lposix.c
-index ffd3c57..bf5accb 100644
---- a/lposix.c
-+++ b/lposix.c
-@@ -901,11 +901,7 @@ static int runexec(lua_State *L, int use_shell)
- const char *path = luaL_checkstring(L, 1);
- int i,n=lua_gettop(L), table = 0;
- if (n >= 1 && lua_type(L, 2) == LUA_TTABLE) {
-- int isint;
-- lua_len(L, 2);
-- n = lua_tointegerx(L, -1, &isint);
-- if (!isint)
-- luaL_error(L, "argument 2 is a table, but has non-numeric length");
-+ n = lua_objlen(L, 2);
- table = 1;
- } else
- n--;
---
-1.8.1.5
-
diff --git a/main/lua-posix/APKBUILD b/main/lua-posix/APKBUILD
index 7443ba4bbb..8cc4668678 100644
--- a/main/lua-posix/APKBUILD
+++ b/main/lua-posix/APKBUILD
@@ -19,7 +19,9 @@ for _i in $_luaversions; do
subpackages="$subpackages lua$_i-posix:_posix_${_i/./_}
lua$_i-curses:_curses_${_i/./_}"
done
-source="luaposix-$pkgver.tar.gz::https://github.com/luaposix/luaposix/archive/release-v$pkgver.tar.gz"
+source="luaposix-$pkgver.tar.gz::https://github.com/luaposix/luaposix/archive/release-v$pkgver.tar.gz
+ lua-version.patch
+ "
@@ -32,6 +34,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ aclocal && autoconf && automake --add-missing || return 1
for _i in $_luaversions; do
cp -r "$_sdir" "$srcdir"/build-$_i
done
@@ -89,6 +92,9 @@ for _i in $_luaversions; do
eval "_posix_${_i/./_}() { _split_posix $_i; }"
done
-md5sums="a25ff76d54bbbebf7a1f3b20c9806ee3 luaposix-31.tar.gz"
-sha256sums="c5ed2f6c16b9f31d3ca0db05f9b660db69c966baab244878480ab6658abbbe24 luaposix-31.tar.gz"
-sha512sums="263d0ffdb4043199a37bccc2f74419e72d6d812f74104fae6bd979a13217ab58275c6d6e21a0aaa4232851fa29941eececa22bc441fb37bebbdc2842b1c37c3f luaposix-31.tar.gz"
+md5sums="a25ff76d54bbbebf7a1f3b20c9806ee3 luaposix-31.tar.gz
+30da8a857ac8026b6cf6932decdccc61 lua-version.patch"
+sha256sums="c5ed2f6c16b9f31d3ca0db05f9b660db69c966baab244878480ab6658abbbe24 luaposix-31.tar.gz
+68a3e67e61b853927a4113a3603d528afe97999fae3bc37b9669e1045ddce299 lua-version.patch"
+sha512sums="263d0ffdb4043199a37bccc2f74419e72d6d812f74104fae6bd979a13217ab58275c6d6e21a0aaa4232851fa29941eececa22bc441fb37bebbdc2842b1c37c3f luaposix-31.tar.gz
+7cde55168dd183ea9a922c2ddfee78a0d43dcc5fa313725c1718693d327fcdc682bb692b4d3a9968322ce53f1dba42990a5b7b150a6d892fcc3f887538a4dea5 lua-version.patch"
diff --git a/main/lua-posix/lua-version.patch b/main/lua-posix/lua-version.patch
index e975c6e66e..bdd1ea0bc6 100644
--- a/main/lua-posix/lua-version.patch
+++ b/main/lua-posix/lua-version.patch
@@ -7,7 +7,7 @@
- [ ax_cv_lua_version=`$LUA -e "print(_VERSION)" | \
- sed "s|^Lua \(.*\)|\1|" | \
- grep -o "^@<:@0-9@:>@\+\\.@<:@0-9@:>@\+"`
-+ [ ax_cv_lua_version=`$LUA -e 'print(_VERSION:match("^Lua (%d+\.%d+)$"))'`
++ [ ax_cv_lua_version=`$LUA -e 'print(_VERSION:match("^Lua (%d+%.%d+)$"))'`
])
AS_IF([test "x$ax_cv_lua_version" = 'x'],
[AC_MSG_ERROR([invalid Lua version number])])
@@ -17,7 +17,7 @@
[
- _ax_test_ver=`$1 -e "print(_VERSION)" 2>/dev/null | \
- sed "s|^Lua \(.*\)|\1|" | grep -o "^@<:@0-9@:>@\+\\.@<:@0-9@:>@\+"`
-+ _ax_test_ver=`$1 -e 'print(_VERSION:match("^Lua (%d+\.%d+)$"))' 2>/dev/null`
++ _ax_test_ver=`$1 -e 'print(_VERSION:match("^Lua (%d+%.%d+)$"))' 2>/dev/null`
AS_IF([test "x$_ax_test_ver" = 'x'],
[_ax_test_ver='0'])
AX_COMPARE_VERSION([$_ax_test_ver], [ge], [$2])