aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-resty-core
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-18 23:08:22 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-18 23:09:21 +0100
commitd7360089095359b6f57aa4ab6a276649da7b0ef6 (patch)
tree32a57df25277671e1e44864440c17edc0ec9c136 /main/lua-resty-core
parent503ecf7ff1beb35ac11deb9a2c0a4805925ad939 (diff)
downloadaports-d7360089095359b6f57aa4ab6a276649da7b0ef6.tar.bz2
aports-d7360089095359b6f57aa4ab6a276649da7b0ef6.tar.xz
main/lua-resty-core: move from testing
It's needed for nginx-mod-http-lua.
Diffstat (limited to 'main/lua-resty-core')
-rw-r--r--main/lua-resty-core/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/lua-resty-core/APKBUILD b/main/lua-resty-core/APKBUILD
new file mode 100644
index 0000000000..22d974ce24
--- /dev/null
+++ b/main/lua-resty-core/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=lua-resty-core
+pkgver=0.1.17
+pkgrel=1
+pkgdesc="New FFI-based API for lua-nginx-module"
+url="https://github.com/openresty/lua-resty-core"
+arch="noarch"
+license="BSD-2-Clause"
+depends="luajit lua-resty-lrucache"
+source="https://github.com/openresty/lua-resty-core/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # FIXME: tests require OpenResty and additional dependencies
+
+package() {
+ make install DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common"
+
+ echo 'rock_manifest = {}' > rock_manifest
+ install -D -m 644 rock_manifest \
+ "$pkgdir"/usr/lib/luarocks/rocks-common/$pkgname/$pkgver-1
+}
+
+sha512sums="76313f33d3a5c3d5ba1ba202b6b6b02ad8155f6f25a55504ded14228263930b7049baf7475f72156b7192af66d20a7ea5d36b3561e4335c746d5baa5ba03b2ba lua-resty-core-0.1.17.tar.gz"