aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-rex
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:50:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:50:15 +0000
commit62818e2599b53602074b541ef87481623dd20eaa (patch)
tree80e5412104b6f0c77ebbdda0b240b91bd075c1e8 /main/lua-rex
parentadd4fdd4a7eab526b3f599a14a1a522482bc278e (diff)
downloadaports-62818e2599b53602074b541ef87481623dd20eaa.tar.bz2
aports-62818e2599b53602074b541ef87481623dd20eaa.tar.xz
main/lua-rex: moved from testing
Diffstat (limited to 'main/lua-rex')
-rw-r--r--main/lua-rex/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/main/lua-rex/APKBUILD b/main/lua-rex/APKBUILD
new file mode 100644
index 0000000000..04fb749703
--- /dev/null
+++ b/main/lua-rex/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-rex
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Lua bindings to regular expression library pcre and posix"
+url="http://lrexlib.luaforge.net/"
+license="MIT"
+depends="lua-rex-pcre lua-rex-posix"
+makedepends="pcre-dev lua-dev"
+install=
+subpackages="$pkgname-pcre $pkgname-posix"
+source="http://luaforge.net/frs/download.php/3599/lrexlib-$pkgver.zip"
+
+_builddir="$srcdir"/lrexlib-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i -e "s/^MYCFLAGS.*/MYCFLAGS = $CFLAGS -fPIC/" src/defaults.mak
+ sed -i -e "s/^LD .*/LD = gcc/" \
+ src/common.mak
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 build_pcre build_posix
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+pcre() {
+ pkgdesc="Lua bindings to pcre regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/pcre/rex_pcre.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+posix() {
+ pkgdesc="Lua bindings to posix regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/posix/rex_posix.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+md5sums="c75d4164ac5036219eac87b488ded9b7 lrexlib-2.4.0.zip"