aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-subprocess
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2014-12-30 15:15:04 +0000
committerTed Trask <ttrask01@yahoo.com>2014-12-30 15:15:04 +0000
commitf4d9dcf020c16b1708c0174e50246659aa27c2c1 (patch)
tree3c03c69ea2cff8402f6bcf74a8b26467ece34c42 /main/lua-subprocess
parentad3b4a874f61b6c0cba7e97a7360293fd462e888 (diff)
downloadaports-f4d9dcf020c16b1708c0174e50246659aa27c2c1.tar.bz2
aports-f4d9dcf020c16b1708c0174e50246659aa27c2c1.tar.xz
main/lua-subprocess: Add Lua 5.1/5.2 libs as depends of main package and remove linking of lua core
Diffstat (limited to 'main/lua-subprocess')
-rw-r--r--main/lua-subprocess/APKBUILD9
-rw-r--r--main/lua-subprocess/makefile.patch9
2 files changed, 13 insertions, 5 deletions
diff --git a/main/lua-subprocess/APKBUILD b/main/lua-subprocess/APKBUILD
index e1dd45adeb..b73aa7e890 100644
--- a/main/lua-subprocess/APKBUILD
+++ b/main/lua-subprocess/APKBUILD
@@ -4,7 +4,7 @@
_luaversions="5.1 5.2"
pkgname=lua-subprocess
pkgver=0.0.20141229
-pkgrel=0
+pkgrel=1
pkgdesc="A Lua module written in C that allows you to create child processes and communicate with them"
url="https://github.com/tdtrask/lua-subprocess"
arch="all"
@@ -15,6 +15,7 @@ depends_dev=""
makedepends="$depends_dev asciidoc"
subpackages=""
for _i in $_luaversions; do
+ depends="$depends lua$_i-subprocess"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-subprocess:split_${_i/./_}"
done
@@ -91,8 +92,8 @@ for _i in $_luaversions; do
done
md5sums="a2ab629c701eba6f3300405daf104f1d lua-subprocess-0.0.20141229.tar.gz
-f1e3718f4bcc74c7903354c5ddab0229 makefile.patch"
+8e784d1a4c78ca60bdd61c635026ee72 makefile.patch"
sha256sums="6d58417d9e2791408092ec2b232072c0461343954d3f72ee6943b0103ac6ce20 lua-subprocess-0.0.20141229.tar.gz
-0f99c91db81e4dc2d3f49fdb6ab4bc6970f369752f2092c286456c6641ada1f3 makefile.patch"
+019f7eb263abe4015581eae90c55ce2265b24ca213239bc02f565a107f8622ab makefile.patch"
sha512sums="5d0648a883102172bc086a0054f76832d25ce760149f0e0ddac927a325815b1937e780efc5d553bb6b751ed7642d728ff37745be134dfdb42753bde3b338a1b9 lua-subprocess-0.0.20141229.tar.gz
-86cccb94ad5bf13c0ce85bc61d899f83d48ee46f06f8a49ef1f720c08a055165c2cb1b5b0596f8d14a237bcab7f2de7e9b2f2ecb11441802e07e6baa01d50b1f makefile.patch"
+af4e25d8d503e9cb8296a2b8d8b19577e64b412f56607bf38bc828a7c214904ecdf9619fc2541461bc4dda6c6fcd47cbb1051499bd2f132dad76092cf3ae5e9d makefile.patch"
diff --git a/main/lua-subprocess/makefile.patch b/main/lua-subprocess/makefile.patch
index 6fa2b20597..01facb37e6 100644
--- a/main/lua-subprocess/makefile.patch
+++ b/main/lua-subprocess/makefile.patch
@@ -1,6 +1,13 @@
--- a/Makefile
+++ b/Makefile
-@@ -25,7 +25,7 @@ LUA_CFLAGS := $(shell pkg-config --cflags --libs $(lua_package))
+@@ -19,13 +19,13 @@
+ endif
+
+ CFLAGS ?= -Wall -Wextra -pedantic -O2
+-LUA_CFLAGS := $(shell pkg-config --cflags --libs $(lua_package))
++LUA_CFLAGS := $(shell pkg-config --cflags $(lua_package))
+
+ .PHONY: all
all: subprocess.so subprocess.html
subprocess.so: $(SOURCES)