aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-xml
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2015-12-30 20:49:25 +0000
committerTed Trask <ttrask01@yahoo.com>2015-12-30 20:49:35 +0000
commitb0ee6cbe8ae634efc250b3ebc541a296ef0f0cd1 (patch)
tree07cc0efe57e5c5cf0adc626172f53f53c9523878 /main/lua-xml
parentcd505c70dad8fd25587cc3cffccc24e21189b966 (diff)
downloadaports-b0ee6cbe8ae634efc250b3ebc541a296ef0f0cd1.tar.bz2
aports-b0ee6cbe8ae634efc250b3ebc541a296ef0f0cd1.tar.xz
main/lua-xml: Fix TAG bug and bump pkgrel
Diffstat (limited to 'main/lua-xml')
-rw-r--r--main/lua-xml/0001-Fix-error-where-TAG-should-be-xml.TAG.patch44
-rw-r--r--main/lua-xml/APKBUILD14
2 files changed, 53 insertions, 5 deletions
diff --git a/main/lua-xml/0001-Fix-error-where-TAG-should-be-xml.TAG.patch b/main/lua-xml/0001-Fix-error-where-TAG-should-be-xml.TAG.patch
new file mode 100644
index 0000000000..8b6763b910
--- /dev/null
+++ b/main/lua-xml/0001-Fix-error-where-TAG-should-be-xml.TAG.patch
@@ -0,0 +1,44 @@
+From 5c266ff6effbb1c89c3798b7332ed21685cf6acb Mon Sep 17 00:00:00 2001
+From: Ted Trask <ttrask01@yahoo.com>
+Date: Wed, 30 Dec 2015 20:36:52 +0000
+Subject: [PATCH] Fix error where TAG should be xml.TAG
+
+---
+ LuaXml.lua | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/LuaXml.lua b/LuaXml.lua
+index 8a10a2d..2ebc0ae 100644
+--- a/LuaXml.lua
++++ b/LuaXml.lua
+@@ -8,9 +8,9 @@ xml.TAG = 0
+ function xml.tag(var,tag)
+ if base.type(var)~="table" then return end
+ if base.type(tag)=="nil" then
+- return var[TAG]
++ return var[xml.TAG]
+ end
+- var[TAG] = tag
++ var[xml.TAG] = tag
+ end
+
+ -- creates a new LuaXML object either by setting the metatable of an existing Lua table or by setting its tag
+@@ -21,7 +21,7 @@ function xml.new(arg)
+ end
+ local var={}
+ base.setmetatable(var,{__index=xml, __tostring=xml.str})
+- if base.type(arg)=="string" then var[TAG]=arg end
++ if base.type(arg)=="string" then var[xml.TAG]=arg end
+ return var
+ end
+
+@@ -115,4 +115,4 @@ function xml.find(var, tag, attributeKey,attributeValue)
+ end
+ end
+
+-return xml
+\ No newline at end of file
++return xml
+--
+2.6.4
+
diff --git a/main/lua-xml/APKBUILD b/main/lua-xml/APKBUILD
index cbe0f12953..ea439a06d5 100644
--- a/main/lua-xml/APKBUILD
+++ b/main/lua-xml/APKBUILD
@@ -3,7 +3,7 @@ _luaversions="5.1 5.2"
pkgname=lua-xml
_name=LuaXML
pkgver=130610
-pkgrel=2
+pkgrel=3
pkgdesc="a minimal set of functions for the processing of XML data in Lua"
url="http://viremo.eludi.net/LuaXML/index.html"
arch="all"
@@ -17,7 +17,8 @@ for _v in $_luaversions; do
subpackages="$subpackages lua$_v-xml:split_${_v/./_}"
done
-source="http://viremo.eludi.net/LuaXML/LuaXML_$pkgver.zip"
+source="http://viremo.eludi.net/LuaXML/LuaXML_$pkgver.zip
+0001-Fix-error-where-TAG-should-be-xml.TAG.patch"
_builddir="$srcdir"
@@ -71,6 +72,9 @@ for _v in $_luaversions; do
eval "split_${_v/./_}() { _split $_v; }"
done
-md5sums="25e4c276c5d8716af1de0c7853aec2b4 LuaXML_130610.zip"
-sha256sums="f2c7475c9ff842d110cfcbc0d0859856b4df18baea3edb5b9379c41a92415e6e LuaXML_130610.zip"
-sha512sums="8f4ab1ba0b186ae8778ec7e2cdf5ebb403233ac9a551c6e476d0554bc27b0eb16a69a070c56747d59d6ee7aa53be70245d9be302ca69ea02226c3543b0ca654f LuaXML_130610.zip"
+md5sums="25e4c276c5d8716af1de0c7853aec2b4 LuaXML_130610.zip
+a22f3177c2e00c5e51836a4a49c70321 0001-Fix-error-where-TAG-should-be-xml.TAG.patch"
+sha256sums="f2c7475c9ff842d110cfcbc0d0859856b4df18baea3edb5b9379c41a92415e6e LuaXML_130610.zip
+979ec2c6610651bcbb6dd8184ca6d673e98cb2adfe5af83b1366f48ce6cfb398 0001-Fix-error-where-TAG-should-be-xml.TAG.patch"
+sha512sums="8f4ab1ba0b186ae8778ec7e2cdf5ebb403233ac9a551c6e476d0554bc27b0eb16a69a070c56747d59d6ee7aa53be70245d9be302ca69ea02226c3543b0ca654f LuaXML_130610.zip
+60ba65a0d47065e2609ca4d5c8d994fc29b9d4c6b5b0a060fa7f83612c71937999648e48dd26063f6528811eb053fe912ee5b6c4465576912c9dacb9bb406cae 0001-Fix-error-where-TAG-should-be-xml.TAG.patch"