aboutsummaryrefslogtreecommitdiffstats
path: root/main/lucene++
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:05:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:38:32 -0300
commit313aa6128f0102ea93b84cc185bfef114627cae0 (patch)
treeecb820b9e20a26350e9f8f0e6bbb724571c93bba /main/lucene++
parent85b0d0f9003155f91366a0aea43c9bf84f5ecc32 (diff)
downloadaports-313aa6128f0102ea93b84cc185bfef114627cae0.tar.bz2
aports-313aa6128f0102ea93b84cc185bfef114627cae0.tar.xz
main/lucene++: modernize
Diffstat (limited to 'main/lucene++')
-rw-r--r--main/lucene++/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/main/lucene++/APKBUILD b/main/lucene++/APKBUILD
index 11c6154021..c28540f4ff 100644
--- a/main/lucene++/APKBUILD
+++ b/main/lucene++/APKBUILD
@@ -2,38 +2,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lucene++
pkgver=3.0.7
-pkgrel=11
+pkgrel=12
pkgdesc="C++ port of the popular Java Lucene library"
url="https://github.com/luceneplusplus/LucenePlusPlus"
arch="all"
-license="LGPL-3.0-or-later Apache-2.0"
-depends=""
+license="LGPL-3.0-or-later OR Apache-2.0"
depends_dev="boost-dev"
makedepends="$depends_dev cmake linux-headers"
-install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
builddir="$srcdir/LucenePlusPlus-rel_$pkgver"
build() {
- mkdir "$builddir"/build
- cd "$builddir"/build
- cmake \
- -DCMAKE_BUILD_TYPE:String="release" \
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_DESTINATION=/usr/lib \
-DBoost_LIBRARY_DIR=/usr/lib \
-DENABLE_CUSTOM_ALLOCATOR='FALSE' \
-DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
- -DCOTIRE_ADDITIONAL_PREFIX_HEADER_IGNORE_PATH='/usr/include/fortify' \
- ..
- make
+ -DCOTIRE_ADDITIONAL_PREFIX_HEADER_IGNORE_PATH=/usr/include/fortify
+ make -C build
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 lucene++-3.0.7.tar.gz"