aboutsummaryrefslogtreecommitdiffstats
path: root/main/lucene++
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-06-03 21:17:50 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-06-03 21:17:50 +0200
commit36c28107e6edf226f0d484efb77a7bcabbffcb16 (patch)
treeb863974f44e3082019de518015659c854eb83b7d /main/lucene++
parent727f02b8fdf77cc82f8ba87bf28d3ac950e40ad9 (diff)
downloadaports-36c28107e6edf226f0d484efb77a7bcabbffcb16.tar.bz2
aports-36c28107e6edf226f0d484efb77a7bcabbffcb16.tar.xz
testing/lucene++: move to main
Diffstat (limited to 'main/lucene++')
-rw-r--r--main/lucene++/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/lucene++/APKBUILD b/main/lucene++/APKBUILD
new file mode 100644
index 0000000000..f5fc33e7fa
--- /dev/null
+++ b/main/lucene++/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=lucene++
+pkgver=3.0.7
+pkgrel=0
+pkgdesc="C++ port of the popular Java Lucene library"
+url="https://github.com/luceneplusplus/LucenePlusPlus'"
+arch="all"
+license="GPL Apache"
+depends=""
+depends_dev="boost-dev"
+makedepends="$depends_dev cmake linux-headers ccache"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
+
+_builddir="$srcdir/LucenePlusPlus-rel_$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ mkdir "$_builddir"/build
+ cd "$_builddir"/build
+ # stupid (but functional) hack to prevent fority header to break
+ # the build. Remeber to remove ccache from deps when fixed.
+ export PATH="/usr/lib/ccache/bin/:$PATH"
+ cmake "$_builddir" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_DESTINATION=/usr/lib \
+ -DBoost_LIBRARY_DIR=/usr/lib \
+ -DENABLE_CUSTOM_ALLOCATOR='FALSE' \
+ -DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e260c1ff9c10af7070faee29f325f955 lucene++-3.0.7.tar.gz"
+sha256sums="6c19f203311e4b44a0ccf7b1127db77436eb47159ea1c54f7531a0b1ca585e0c lucene++-3.0.7.tar.gz"
+sha512sums="92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 lucene++-3.0.7.tar.gz"