aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxc-templates-legacy
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 14:26:53 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-02 08:02:12 +0000
commit7dd93c8970df95fd081e3fca7ab97c5439bf3067 (patch)
treea07353b864e17d934d3413cdf0ee0b40bc77da74 /main/lxc-templates-legacy
parent704d5a88f356872bd94ac4dc41d931965effeb84 (diff)
downloadaports-7dd93c8970df95fd081e3fca7ab97c5439bf3067.tar.bz2
aports-7dd93c8970df95fd081e3fca7ab97c5439bf3067.tar.xz
main/lxc-templates-legacy: new aport
These are the legacy templates from 2.x. more info: https://brauner.github.io/2018/02/27/lxc-removes-legacy-template-build-system.html
Diffstat (limited to 'main/lxc-templates-legacy')
-rw-r--r--main/lxc-templates-legacy/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/main/lxc-templates-legacy/APKBUILD b/main/lxc-templates-legacy/APKBUILD
new file mode 100644
index 0000000000..d7752f099f
--- /dev/null
+++ b/main/lxc-templates-legacy/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=lxc-templates-legacy
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Legacy LXC container templates"
+url="https://linuxcontainers.org"
+arch="noarch"
+license="LGPL-2.1"
+depends="bash tar"
+subpackages="$pkgname-alpine"
+source="https://linuxcontainers.org/downloads/lxc/lxc-templates-$pkgver.tar.gz"
+builddir="$srcdir/lxc-templates-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+alpine() {
+ pkgdesc="$pkgdesc (for Alpine)"
+ depends=
+ mkdir -p "$subpkgdir"/usr/share/lxc/templates \
+ "$subpkgdir"/usr/share/lxc/config
+ local i; for i in templates/lxc-alpine config/alpine.userns.conf \
+ config/alpine.common.conf; do
+ mv $pkgdir/usr/share/lxc/$i "$subpkgdir"/usr/share/lxc/${i%/*}/
+ done
+}
+
+sha512sums="3e9d5304f5e06580eeb766570ddfebb0c80061c2d7e47c9ea37d834fe0cf4fabe7eedd667e4937df3f2451bc3e7aa1e98a1b386f3b19964dc218ff0e21011632 lxc-templates-3.0.3.tar.gz"