aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxdm/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-04 07:59:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-04 07:59:00 +0000
commit29687b058f4158b4be6cbb7dea7e4a624a71c804 (patch)
treeb7cc8c36611a8075458f5c5d10fe0736535ded13 /main/lxdm/APKBUILD
parent0e0157912972f71045f650a52ae8cb2bd55d3ebf (diff)
downloadaports-29687b058f4158b4be6cbb7dea7e4a624a71c804.tar.bz2
aports-29687b058f4158b4be6cbb7dea7e4a624a71c804.tar.xz
main/lxdm: moved from testing
Diffstat (limited to 'main/lxdm/APKBUILD')
-rw-r--r--main/lxdm/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/main/lxdm/APKBUILD b/main/lxdm/APKBUILD
new file mode 100644
index 0000000000..05f9931dc1
--- /dev/null
+++ b/main/lxdm/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=lxdm
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="LXDE desktop login manager"
+url="http://wiki.lxde.org/en/LXDM"
+license="GPL"
+depends="bash"
+makedepends="autoconf automake gtk+-dev consolekit-dev"
+install=
+source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz
+ lxdm.initd
+ lxdm-execinfo.patch
+ lxdm-nopam.patch"
+arch="all"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i..."
+ patch -s -p1 -N -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+
+ autoreconf
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-pam
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+}
+
+md5sums="1d0688e088edab7c3c563263eb2f9654 lxdm-0.3.0.tar.gz
+d6455d172d5d897f6bfcefe9a1a632c7 lxdm.initd
+045da38f5bb183ccacc489ea7e50e927 lxdm-execinfo.patch
+0d44e8cd97894fd680e3f09e680c3481 lxdm-nopam.patch"