aboutsummaryrefslogtreecommitdiffstats
path: root/main/lynx
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-10-09 01:29:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-09 07:14:32 +0000
commit28d62f838e4912dd3bb1d4073c852431fc95fc71 (patch)
tree49102f1d637eb82072e65b4a59137f3aa29ce87d /main/lynx
parent0b0f30dbfb3a37ff07e296da09b5d12ad2e08824 (diff)
downloadaports-28d62f838e4912dd3bb1d4073c852431fc95fc71.tar.bz2
aports-28d62f838e4912dd3bb1d4073c852431fc95fc71.tar.xz
main/lynx: fix download link and depend on gzip
The lynx website has been moved to http://lynx.invisible-island.net the latest version available from that website is 2.8.8, version 2.8.8_p2 doesn't seem to be a valid lynx version (any more?). Furthermore lynx uses some GNU gzip longopts and therefore needs to have a GNU gzip runtime dependency.
Diffstat (limited to 'main/lynx')
-rw-r--r--main/lynx/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/main/lynx/APKBUILD b/main/lynx/APKBUILD
index f3b05b2a65..0bb7913804 100644
--- a/main/lynx/APKBUILD
+++ b/main/lynx/APKBUILD
@@ -1,23 +1,21 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=lynx
-pkgver=2.8.8_p2
+pkgver=2.8.8
+_relver=${pkgver}rel.2
pkgrel=0
-_v=${pkgver%_*}
-_d=${_v//./-}
-_ver=${pkgver/_p/rel.}
-
pkgdesc="Cross-platform text-based browser"
-url="http://lynx.isc.org"
+url="http://lynx.invisible-island.net/"
arch="all"
license="GPL"
-depends=
+depends="gzip"
makedepends="openssl-dev gettext zlib-dev glib-dev perl ncurses-dev"
install=""
subpackages="$pkgname-doc"
-source="http://lynx.isc.org/lynx${_v}/lynx${_ver}.tar.bz2"
+source="http://invisible-mirror.net/archives/lynx/tarballs/${pkgname}${_relver}.tar.bz2"
-_builddir="$srcdir/${pkgname}${_d}"
+_builddir="$srcdir"/${pkgname}${pkgver//./-}
prepare() {
local i
cd "$_builddir"
@@ -35,6 +33,10 @@ build() {
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-ipv6 \
|| return 1
make helpdir=/usr/share/doc/lynx/help \
docdir=/usr/share/doc/lynx || return 1