aboutsummaryrefslogtreecommitdiffstats
path: root/main/lzo
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/lzo
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
downloadaports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.bz2
aports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.xz
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/lzo')
-rw-r--r--main/lzo/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/main/lzo/APKBUILD b/main/lzo/APKBUILD
index c522e773a5..e58bb7b53f 100644
--- a/main/lzo/APKBUILD
+++ b/main/lzo/APKBUILD
@@ -13,9 +13,15 @@ install=
subpackages="$pkgname-dev"
source="http://www.oberhumer.com/opensource/lzo/download/$pkgname-$pkgver.tar.gz"
-build() {
- cd "$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \