aboutsummaryrefslogtreecommitdiffstats
path: root/main/make
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-06-20 11:33:01 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-06-20 11:33:01 +0200
commit8717b793c48072646087a3c062bf7ceaf2fca053 (patch)
tree501fc805452b7bf94ce78881dd587fe5b097fd60 /main/make
parente1346ab2294fdb0f8fd1c05f4df4904b1859a18f (diff)
downloadaports-8717b793c48072646087a3c062bf7ceaf2fca053.tar.bz2
aports-8717b793c48072646087a3c062bf7ceaf2fca053.tar.xz
main/make: upgrade to 4.2.1
Diffstat (limited to 'main/make')
-rw-r--r--main/make/APKBUILD20
-rw-r--r--main/make/double-colon-targets.patch134
2 files changed, 8 insertions, 146 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index 55fc1bea90..9344398f47 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=make
-pkgver=4.2
-pkgrel=1
+pkgver=4.2.1
+pkgrel=0
pkgdesc="GNU make utility to maintain groups of programs"
url="http://www.gnu.org/software/make"
arch="all"
@@ -10,7 +10,6 @@ depends=""
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
fix-atexit-exit.patch
- double-colon-targets.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -45,12 +44,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="85ad14d08766201ffe71efa866f4fb91 make-4.2.tar.bz2
-842902e4a28f29e953f022f80b3ce57c fix-atexit-exit.patch
-54cbf3670d2216c5c937d846617a455c double-colon-targets.patch"
-sha256sums="4e5ce3b62fe5d75ff8db92b7f6df91e476d10c3aceebf1639796dc5bfece655f make-4.2.tar.bz2
-ecf0edef6b8cf173d2f792c61f5a3e6f289d789e9b9ce5ff9186c6c17022bd87 fix-atexit-exit.patch
-d749aec54275f7bdfdad805a67b0619e910550ee8827cb6ee5efd76512963f8b double-colon-targets.patch"
-sha512sums="2e8668a130dadc9885a67d80032bf5554c6456741153f3224a4f0eb17ac268b22f062f9e4d66aedda4d1c926494c0b493fe5e941fb5d28ead6adbdf2f09d9128 make-4.2.tar.bz2
-a1639d9caf84a24a9f161a30d8b5dcd079b13faf2a5e3d514ff39fa11b13e796c7ff34c46ac2b56656d52129b4d3627c6102b129a4ab011f065076d872ef3992 fix-atexit-exit.patch
-b30713e417ea2b1e13c1e21caa55a835adaf77e618ddbfbb07e27681145d0920a9db9f71290b8025a0221b66bc013295b9dfed0660d7bd42f5beae4e646495f8 double-colon-targets.patch"
+md5sums="15b012617e7c44c0ed482721629577ac make-4.2.1.tar.bz2
+842902e4a28f29e953f022f80b3ce57c fix-atexit-exit.patch"
+sha256sums="d6e262bf3601b42d2b1e4ef8310029e1dcf20083c5446b4b7aa67081fdffc589 make-4.2.1.tar.bz2
+ecf0edef6b8cf173d2f792c61f5a3e6f289d789e9b9ce5ff9186c6c17022bd87 fix-atexit-exit.patch"
+sha512sums="9cf00869a2f938492554f71d8cb288b5b009b3bd0489ef164f2c8f6532fc37db5c7e20af1dea288536e7c9710ee0bc6e1ddcdfc4928a8540e6e43661741825b8 make-4.2.1.tar.bz2
+a1639d9caf84a24a9f161a30d8b5dcd079b13faf2a5e3d514ff39fa11b13e796c7ff34c46ac2b56656d52129b4d3627c6102b129a4ab011f065076d872ef3992 fix-atexit-exit.patch"
diff --git a/main/make/double-colon-targets.patch b/main/make/double-colon-targets.patch
deleted file mode 100644
index 744cd05b23..0000000000
--- a/main/make/double-colon-targets.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-diff -upr make-4.2.orig/filedef.h make-4.2/filedef.h
---- make-4.2.orig/filedef.h 2016-06-01 10:55:27.566366858 +0200
-+++ make-4.2/filedef.h 2016-06-01 10:55:48.086259674 +0200
-@@ -58,6 +58,8 @@ struct file
- FILE_TIMESTAMP last_mtime; /* File's modtime, if already known. */
- FILE_TIMESTAMP mtime_before_update; /* File's modtime before any updating
- has been performed. */
-+ unsigned int considered; /* equal to 'considered' if file has been
-+ considered on current scan of goal chain */
- int command_flags; /* Flags OR'd in for cmds; see commands.h. */
- enum update_status /* Status of the last attempt to update. */
- {
-@@ -96,8 +98,6 @@ struct file
- unsigned int ignore_vpath:1;/* Nonzero if we threw out VPATH name. */
- unsigned int pat_searched:1;/* Nonzero if we already searched for
- pattern-specific variables. */
-- unsigned int considered:1; /* equal to 'considered' if file has been
-- considered on current scan of goal chain */
- unsigned int no_diag:1; /* True if the file failed to update and no
- diagnostics has been issued (dontcare). */
- };
-diff -upr make-4.2.orig/main.c make-4.2/main.c
---- make-4.2.orig/main.c 2016-06-01 10:55:27.579700121 +0200
-+++ make-4.2/main.c 2016-06-01 10:55:48.086259674 +0200
-@@ -2262,10 +2262,6 @@ main (int argc, char **argv, char **envp
-
- for (i = 0, d = read_files; d != 0; ++i, d = d->next)
- {
-- /* Reset the considered flag; we may need to look at the file
-- again to print an error. */
-- d->file->considered = 0;
--
- if (d->file->updated)
- {
- /* This makefile was updated. */
-diff -upr make-4.2.orig/remake.c make-4.2/remake.c
---- make-4.2.orig/remake.c 2016-06-01 10:55:27.563033542 +0200
-+++ make-4.2/remake.c 2016-06-01 10:55:48.086259674 +0200
-@@ -57,8 +57,9 @@ unsigned int commands_started = 0;
- static struct goaldep *goal_list;
- static struct dep *goal_dep;
-
--/* Current value for pruning the scan of the goal chain (toggle 0/1). */
--static unsigned int considered;
-+/* Current value for pruning the scan of the goal chain.
-+ All files start with considered == 0. */
-+static unsigned int considered = 0;
-
- static enum update_status update_file (struct file *file, unsigned int depth);
- static enum update_status update_file_1 (struct file *file, unsigned int depth);
-@@ -90,12 +91,12 @@ update_goal_chain (struct goaldep *goald
-
- goal_list = rebuilding_makefiles ? goaldeps : NULL;
-
-- /* All files start with the considered bit 0, so the global value is 1. */
-- considered = 1;
--
- #define MTIME(file) (rebuilding_makefiles ? file_mtime_no_search (file) \
- : file_mtime (file))
-
-+ /* Start a fresh batch of consideration. */
-+ ++considered;
-+
- /* Update all the goals until they are all finished. */
-
- while (goals != 0)
-@@ -247,10 +248,10 @@ update_goal_chain (struct goaldep *goald
- }
- }
-
-- /* If we reached the end of the dependency graph toggle the considered
-- flag for the next pass. */
-+ /* If we reached the end of the dependency graph update CONSIDERED
-+ for the next pass. */
- if (g == 0)
-- considered = !considered;
-+ ++considered;
- }
-
- if (rebuilding_makefiles)
-@@ -615,8 +616,8 @@ update_file_1 (struct file *file, unsign
- break;
-
- if (!running)
-- /* The prereq is considered changed if the timestamp has changed while
-- it was built, OR it doesn't exist. */
-+ /* The prereq is considered changed if the timestamp has changed
-+ while it was built, OR it doesn't exist. */
- d->changed = ((file_mtime (d->file) != mtime)
- || (mtime == NONEXISTENT_MTIME));
-
-@@ -650,7 +651,7 @@ update_file_1 (struct file *file, unsign
- /* We may have already considered this file, when we didn't know
- we'd need to update it. Force update_file() to consider it and
- not prune it. */
-- d->file->considered = !considered;
-+ d->file->considered = 0;
-
- new = update_file (d->file, depth);
- if (new > dep_status)
-@@ -1087,7 +1088,7 @@ check_dep (struct file *file, unsigned i
- /* If the target was waiting for a dependency it has to be
- reconsidered, as that dependency might have finished. */
- if (file->command_state == cs_deps_running)
-- file->considered = !considered;
-+ file->considered = 0;
-
- set_command_state (file, cs_not_started);
- }
-diff -upr make-4.2.orig/tests/scripts/features/double_colon make-4.2/tests/scripts/features/double_colon
---- make-4.2.orig/tests/scripts/features/double_colon 2016-06-01 10:55:27.576366805 +0200
-+++ make-4.2/tests/scripts/features/double_colon 2016-06-01 10:55:48.086259674 +0200
-@@ -197,6 +197,21 @@ all:: 3
- ',
- '-rs -j2 1 2 root', "all_one\nall_two\nroot\n");
-
-+# SV 47995 : Parallel double-colon rules with FORCE
-+
-+run_make_test('
-+all:: ; @echo one
-+
-+all:: joe ; @echo four
-+
-+joe: FORCE ; touch joe-is-forced
-+
-+FORCE:
-+',
-+ '-j5', "one\ntouch joe-is-forced\nfour\n");
-+
-+unlink('joe-is-forced');
-+
- # This tells the test driver that the perl test script executed properly.
- 1;
-