aboutsummaryrefslogtreecommitdiffstats
path: root/main/make
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-08 09:03:52 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-10-08 09:03:52 +0300
commit9e243ff865781e290ec0b3252c0f57774c2ac640 (patch)
tree7fbd2de0629d6e47cfb61b3d61ca7cc63dcd245c /main/make
parent789fd64f30f0463f4c7c7ab3d05f279ed0ba76b5 (diff)
downloadaports-9e243ff865781e290ec0b3252c0f57774c2ac640.tar.bz2
aports-9e243ff865781e290ec0b3252c0f57774c2ac640.tar.xz
main/make: fix make check failure to abort build
Diffstat (limited to 'main/make')
-rw-r--r--main/make/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index 43b448e5cb..0d67c34dbb 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -43,7 +43,7 @@ build() {
--disable-nls \
|| return 1
make || return 1
- [ "$CBUILD" = "$CHOST" ] && (make check || return 1)
+ [ "$CBUILD" != "$CHOST" ] || make check || return 1
return 0
}