aboutsummaryrefslogtreecommitdiffstats
path: root/main/makekit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-22 06:05:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 06:08:08 +0000
commit8c17b09e32a9b07cb9444e8386ada52b0dd1fa55 (patch)
treeb1099560a36018a0e90e666e7f02f61ee1bf54c4 /main/makekit
parentf52d7ed66300e67177b6ab4c6f6169259a71c69c (diff)
downloadaports-8c17b09e32a9b07cb9444e8386ada52b0dd1fa55.tar.bz2
aports-8c17b09e32a9b07cb9444e8386ada52b0dd1fa55.tar.xz
main/makekit: move from unmaintained and update download url
They tagged the release. https://github.com/bkoropoff/makekit/issues/1
Diffstat (limited to 'main/makekit')
-rw-r--r--main/makekit/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/makekit/APKBUILD b/main/makekit/APKBUILD
new file mode 100644
index 0000000000..d5dc702681
--- /dev/null
+++ b/main/makekit/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=makekit
+pkgver=0.1
+pkgrel=0
+pkgdesc="modular build system for POSIX environments"
+url="http://mkbuild.sourceforge.net/"
+arch="noarch"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=
+source="makekit-$pkgver.tar.gz::https://github.com/bkoropoff/makekit/archive/release-$pkgver.tar.gz"
+
+_builddir="$srcdir"/makekit-$pkgver/build
+prepare() {
+ local i
+ cd "$_builddir"/..
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ mkdir -p "$_builddir"
+ cd "$_builddir"
+ ../configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="46b64e4a029b9b7ae09b24230cc5dc81 makekit-0.1.tar.gz"
+sha256sums="769af9ac5ff591cfd07e9eb3d64a684ac59bce3952d513fd61baa3ea6c84431b makekit-0.1.tar.gz"
+sha512sums="5a7ebec00f3edd53a0ba1ae0f8c225cbe7781b84f2be56853bd2f984fddc78b5baad316f4808ccf0a859d1ded11475474a398a9ec50c67f2a2a80cd9bde902c3 makekit-0.1.tar.gz"