aboutsummaryrefslogtreecommitdiffstats
path: root/main/mcabber
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-06 21:49:12 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-06 21:49:12 +0100
commit0c027f5c48b144ee3eabb40da09eff85a27fc214 (patch)
treef41c12d5678cc39db469892f1aa6cd546daa21d1 /main/mcabber
parent646e869e57cfbc667e6c689284d7015d1b920029 (diff)
downloadaports-0c027f5c48b144ee3eabb40da09eff85a27fc214.tar.bz2
aports-0c027f5c48b144ee3eabb40da09eff85a27fc214.tar.xz
main/mcabber: improve abuild
Diffstat (limited to 'main/mcabber')
-rw-r--r--main/mcabber/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/main/mcabber/APKBUILD b/main/mcabber/APKBUILD
index 60eb913f88..03d5dd2195 100644
--- a/main/mcabber/APKBUILD
+++ b/main/mcabber/APKBUILD
@@ -8,15 +8,12 @@ url="http://www.lilotux.net/~mikael/mcabber/"
arch="all"
license="GPL2+"
depends="beep"
-depends_dev="$makedepends"
options="libtool"
makedepends="loudmouth-dev glib-dev ncurses-dev gpgme-dev aspell-dev
libotr3-dev libidn-dev enchant-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-example::noarch"
source="http://mcabber.com/files/$pkgname-$pkgver.tar.bz2"
-
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -40,11 +37,10 @@ package() {
}
example() {
- pkgdesc="$pkgdesc (examples)"
- # Put the example file into a seperate package
- mkdir -p "$subpkgdir"/usr/share/doc/"$pkgname"/example || return 1
- mv "$builddir"/mcabberrc.example \
- "$subpkgdir"/usr/share/doc/"$pkgname"/example/mcabberrc.example || return 1
+ pkgdesc="$pkgdesc (examples)"
+
+ install -m 644 -D "$builddir"/mcabberrc.example \
+ "$subpkgdir"/usr/share/doc/$pkgname/example/mcabberrc.example
}
md5sums="c4aa104508238f3965f60c155c8beaac mcabber-1.0.3.tar.bz2"