aboutsummaryrefslogtreecommitdiffstats
path: root/main/menu-cache
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-09 21:10:15 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-10 03:26:21 +0000
commite00247ae491648c9b75b93c613123bd7b8498dca (patch)
treedcdcda2483b8e1b6eaa44e86f4f3ca4d9c964b84 /main/menu-cache
parent3e57180fdf3f90c30a25aea44f57846efc93a696 (diff)
downloadaports-e00247ae491648c9b75b93c613123bd7b8498dca.tar.bz2
aports-e00247ae491648c9b75b93c613123bd7b8498dca.tar.xz
main/menu-cache: modernise, mark no tests
Diffstat (limited to 'main/menu-cache')
-rw-r--r--main/menu-cache/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/main/menu-cache/APKBUILD b/main/menu-cache/APKBUILD
index 667cd96da0..98e3c43230 100644
--- a/main/menu-cache/APKBUILD
+++ b/main/menu-cache/APKBUILD
@@ -3,33 +3,35 @@
pkgname=menu-cache
pkgver=0.5.1
-pkgrel=1
-pkgdesc='Caching mechanism for freedesktop.org compliant menus'
-arch='all'
-license='GPL2'
-url='http://lxde.org/'
-makedepends='glib-dev'
-options='libtool'
-source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz"
+pkgrel=2
+pkgdesc="Caching mechanism for freedesktop.org compliant menus"
+arch="all"
+license="GPL-2.0+"
+url="https://lxde.org/"
+makedepends="glib-dev"
+options="!check libtool" # No test suite.
+source="https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-dev"
-builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ update_config_guess
+ default_prepare
+}
build() {
cd "$builddir"
- update_config_guess || return 1
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib/menu-cache \
- --disable-static || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="fd296c317a235782fbbd37b6f54bc985 menu-cache-0.5.1.tar.gz"
-sha256sums="08e658021faecd4eefb26cc21b207251a6b4e844e131cec491471aba9eaea122 menu-cache-0.5.1.tar.gz"
sha512sums="44d55a01f5452804e77518c4a2ba400a5b65edbf4061e346a6c02356195867eaa0bb9eaa057fbf603ddf79759acb16632bf3b7ae543eebc1544e28517cd23066 menu-cache-0.5.1.tar.gz"