aboutsummaryrefslogtreecommitdiffstats
path: root/main/mercurial
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-12-02 12:17:13 +0100
committerTimo Teräs <timo.teras@iki.fi>2016-12-02 18:12:45 +0000
commitcbfef2e5ed97c579b8e0dafdd1832d5228cecb16 (patch)
tree312769c65808e0ea3bb01107034afc9d63cfad7e /main/mercurial
parente05de4ce91f41d47706ec3df03b1727f9c11689f (diff)
downloadaports-cbfef2e5ed97c579b8e0dafdd1832d5228cecb16.tar.bz2
aports-cbfef2e5ed97c579b8e0dafdd1832d5228cecb16.tar.xz
main/mercurial: Upgrade to 4.0.1. Slightly modernize APKBUILD.
Diffstat (limited to 'main/mercurial')
-rw-r--r--main/mercurial/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/mercurial/APKBUILD b/main/mercurial/APKBUILD
index 750dee0fbb..1126798b66 100644
--- a/main/mercurial/APKBUILD
+++ b/main/mercurial/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mercurial
-pkgver=3.9.1
+pkgver=4.0.1
pkgrel=0
pkgdesc="A scalable distributed SCM tool"
url="https://www.mercurial-scm.org/"
@@ -16,14 +16,15 @@ subpackages="
$pkgname-bash-completion:bashcomp:noarch"
source="https://www.mercurial-scm.org/release/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
+
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --root="$pkgdir" || return 1
install -m755 contrib/hgk hgeditor "$pkgdir"/usr/bin || return 1
@@ -38,7 +39,7 @@ vim() {
pkgdesc="Vim syntax for $pkgname"
install_if="vim $pkgname=$pkgver-r$pkgrel"
- cd "$_builddir"/contrib/vim/
+ cd "$builddir"/contrib/vim/
mkdir -p "$subpkgdir"/usr/share/vim/vimfiles/syntax/
install -Dm644 HGAnnotate.vim hgtest.vim \
"$subpkgdir"/usr/share/vim/vimfiles/syntax/ || return 1
@@ -49,7 +50,7 @@ zshcomp() {
pkgdesc="Zsh completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- install -Dm644 "$_builddir"/contrib/zsh_completion \
+ install -Dm644 "$builddir"/contrib/zsh_completion \
"$subpkgdir"/usr/share/zsh/site-functions/_${pkgname} || return 1
}
@@ -58,10 +59,10 @@ bashcomp() {
pkgdesc="Bash completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- install -Dm644 "$_builddir"/contrib/bash_completion \
+ install -Dm644 "$builddir"/contrib/bash_completion \
"$subpkgdir"/usr/share/bash-completion/completions/${pkgname} || return 1
}
-md5sums="3759dd10edb8c1a6dfb8ff0ce82658ce mercurial-3.9.1.tar.gz"
-sha256sums="625e4fc7e85ec2278c2828bdc547fce74091b3bbe4d9eeeba2d61af51195df74 mercurial-3.9.1.tar.gz"
-sha512sums="d96e45cafd36be692d6ce5259e18140641c24f73d4731ff767df0f39af425b0630c687436fc0f53d5882495ceacacaadd5e19f8f7c701b4b94c48631123b4666 mercurial-3.9.1.tar.gz"
+md5sums="22a9b1d7c0c06a53f0ae5b386d536d08 mercurial-4.0.1.tar.gz"
+sha256sums="6aa4ade93c1b5e11937820880a466ebf1c824086d443cd799fc46e2617250d40 mercurial-4.0.1.tar.gz"
+sha512sums="145bb80d5dbefb5b770a8d74ce31929fafbd235bb3f641bcaa54b1f5278b2abef4298025152aaba212f639c307741d3aaf75be83e3fc52eaf440c86e4a804459 mercurial-4.0.1.tar.gz"