aboutsummaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-02 09:02:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-02 09:03:01 +0200
commitf984c36702bcaa4e5e372a0ba8d235266240f15d (patch)
tree1c6d7b9f63a1be7bb2d837292f716b3f718dd651 /main/mesa
parentf5b24d0fb316e328563b422c927e4b30f591510f (diff)
downloadaports-f984c36702bcaa4e5e372a0ba8d235266240f15d.tar.bz2
aports-f984c36702bcaa4e5e372a0ba8d235266240f15d.tar.xz
main/mesa: build vc4 driver for arm
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 22e0c974c4..548afea1a3 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=10.6.5
-pkgrel=0
+pkgrel=1
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -31,6 +31,7 @@ source="ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-$pkgver.tar.xz
_dri_driverdir=/usr/lib/xorg/modules/dri
_dri_drivers="r200,radeon,nouveau,swrast"
+_gallium_drivers="r300,r600,radeonsi,nouveau,svga,swrast"
_builddir="$srcdir/mesa-$pkgver"
@@ -40,6 +41,9 @@ x86*)
_dri_drivers="${_dri_drivers},i915,i965"
subpackages="$subpackages $pkgname-dri-intel:intel"
;;
+arm*)
+ _gallium_drivers="${_gallium_drivers},vc4"
+ ;;
esac
prepare() {
@@ -68,7 +72,7 @@ build() {
--disable-asm \
--disable-xvmc \
--enable-glx-rts \
- --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
+ --with-gallium-drivers=${_gallium_drivers} \
--with-dri-drivers=${_dri_drivers} \
--enable-llvm-shared-libs \
--enable-gallium-llvm \