aboutsummaryrefslogtreecommitdiffstats
path: root/main/meson
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-09-16 13:51:09 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-09-16 13:51:09 +0200
commitc83382b1877e8010ea3b62e0e58bd886a392f97c (patch)
treeea7a62d83b58b9ee89bbd8b1c1efde271a8d4f98 /main/meson
parent95cc9f41b3b0451ba9e810b7b4d9486d8e4845cc (diff)
downloadaports-c83382b1877e8010ea3b62e0e58bd886a392f97c.tar.bz2
aports-c83382b1877e8010ea3b62e0e58bd886a392f97c.tar.xz
main/meson: move from testing
Needed by libmpdclient.
Diffstat (limited to 'main/meson')
-rw-r--r--main/meson/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/meson/APKBUILD b/main/meson/APKBUILD
new file mode 100644
index 0000000000..d6309a5a5a
--- /dev/null
+++ b/main/meson/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=meson
+pkgver=0.42.1
+pkgrel=0
+pkgdesc="Build system meant to be both extremely fast and as user friendly as possible"
+url="http://mesonbuild.com/"
+arch="noarch"
+license="ASL 2.0"
+depends="python3 ninja"
+makedepends="python3-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/mesonbuild/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f9982a19160c51c53741a65a48432896799be90c2d99941a45a14c3fcc14df3469808b75d905e1ac81221b057400913e7ae0f7d24e6865d8f1e664e1686aecb4 meson-0.42.1.tar.gz"