aboutsummaryrefslogtreecommitdiffstats
path: root/main/mksh
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-15 08:38:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-15 14:07:39 +0000
commit9aab507aee50171f648c5af1aa1b9bb4199508a6 (patch)
treec156acb66d6853ec027091a99d25f0db36299066 /main/mksh
parentdd1eff4657c24e7f185570bc46d9bfa053d0bacf (diff)
downloadaports-9aab507aee50171f648c5af1aa1b9bb4199508a6.tar.bz2
aports-9aab507aee50171f648c5af1aa1b9bb4199508a6.tar.xz
main/mksh: upgrade to 59
Diffstat (limited to 'main/mksh')
-rw-r--r--main/mksh/APKBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/main/mksh/APKBUILD b/main/mksh/APKBUILD
index d18349fe4a..fb3e9de08f 100644
--- a/main/mksh/APKBUILD
+++ b/main/mksh/APKBUILD
@@ -1,27 +1,24 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: Sören Tempel <soeren+alpinelinux@soeren-tempel.net>
pkgname=mksh
-pkgver=58
+pkgver=59
_pkgver=R$pkgver
pkgrel=0
pkgdesc="MirBSD KSH Shell"
url="https://www.mirbsd.org/mksh"
arch="all"
-license="BSD"
-depends=""
-depends_dev=""
-makedepends=""
+license="MirOS"
checkdepends="perl"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
-source="https://www.mirbsd.org/MirOS/dist/mir/$pkgname/$pkgname-$_pkgver.tgz"
+source="https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-$_pkgver.tgz"
builddir="$srcdir/$pkgname"
prepare() {
default_prepare
# This test case checks if a controlling tty is not present when
- # `-C regress:no-ctty` has been passed. However, a controlling
+ # '-C regress:no-ctty' has been passed. However, a controlling
# tty might be present when building this APKBUILD locally but
# isn't present on the builder. To make sure the tests pass both
# locally and on the builders we remove this test case.
@@ -29,20 +26,17 @@ prepare() {
}
build() {
- cd "$builddir"
sh Build.sh -r
}
check() {
- cd "$builddir"
./test.sh -v -f -C regress:no-ctty
}
package() {
- cd "$builddir"
install -Dm755 mksh "$pkgdir"/bin/mksh
install -Dm644 mksh.1 "$pkgdir"/usr/share/man/man1/mksh.1
install -Dm644 dot.mkshrc "$pkgdir"/usr/share/doc/mksh/dot.mkshrc
}
-sha512sums="711351f8bbe8e44fcf9e7963f8e749938ec3ccb362fafd5350d44593841c2acb6d54ffa115dbb6b83c30865728a4c5274c05feedb063e293361e2830d263d80f mksh-R58.tgz"
+sha512sums="be5009ce8f02eab1392f95d7f85f5aad57b1445684b4fe8cd0284a7d79386170979303ef19f039fdbb53bd2a791f3e3603d2fe57e015fed4cb4a24ab710bcfbb mksh-R59.tgz"