aboutsummaryrefslogtreecommitdiffstats
path: root/main/mosquitto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-03-28 10:34:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-28 10:34:19 +0000
commit256991ce199ab1b176c08277836f9571f2f03ab5 (patch)
tree92af378ea4c56dfeb28279d894dfd04284a99ce7 /main/mosquitto
parent1820884ed3e1850e671871eacac94afa010efc5c (diff)
downloadaports-256991ce199ab1b176c08277836f9571f2f03ab5.tar.bz2
aports-256991ce199ab1b176c08277836f9571f2f03ab5.tar.xz
main/mosquitto: upgrade to 1.4.11
Diffstat (limited to 'main/mosquitto')
-rw-r--r--main/mosquitto/APKBUILD16
-rw-r--r--main/mosquitto/config.patch59
2 files changed, 65 insertions, 10 deletions
diff --git a/main/mosquitto/APKBUILD b/main/mosquitto/APKBUILD
index c82b1f6861..44648dee66 100644
--- a/main/mosquitto/APKBUILD
+++ b/main/mosquitto/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mosquitto
-pkgver=1.4.10
-pkgrel=3
+pkgver=1.4.11
+pkgrel=0
pkgdesc="An Open Source MQTT v3.1 Broker"
url="http://mosquitto.org/"
arch="all"
@@ -16,13 +16,13 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-libs++:_pp
replaces="mosquitto-utils"
source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
libressl.patch
+ config.patch
mosquitto.initd"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare || return 1
- sed -i "s|prefix=/usr/local|prefix=/usr|" config.mk || return 1
# dont strip
sed -i -e "s|(INSTALL) -s|(INSTALL)|g" \
-e 's|--strip-program=${CROSS_COMPILE}${STRIP}||' \
@@ -37,6 +37,7 @@ build() {
WITH_WEBSOCKETS=yes \
WITH_SRV=yes \
WITH_TLS_PSK=no \
+ WITH_ADNS=no \
prefix=/usr || return 1
}
@@ -69,12 +70,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-md5sums="61839b47b58c5799aab76584f13ed66f mosquitto-1.4.10.tar.gz
-60b04a0ecba85e76ddf806da343fcebb libressl.patch
-3a5c35f76efabcb7bd4fb6398caf9e5b mosquitto.initd"
-sha256sums="437648d68a4a781dd8d913814cd5451f59ab4a5fcf84cccaf7c36e6a07459770 mosquitto-1.4.10.tar.gz
-175134ccd92944f5861bd84e16c93adedac88a625c0e37091e4330e56fbf3834 libressl.patch
-97c7324f0f5e9dce52b241366bcfc3fb02ef8d2e0d622bab898eb36f261056c9 mosquitto.initd"
-sha512sums="fe5d6d7196a137a496ba6881c77d852396baefb4f0b83ccd9a22175fc05b09e48a09ea249e30ec7db966e11de134ebcc4e2e9b1fd40b31dc59fb0fa2f60b75a1 mosquitto-1.4.10.tar.gz
+sha512sums="c05ca8679b9a6f540868f4ccf701257fcabc114d5450ac0bbbe80b91bb7cd4fc52668773e945506760c7a5bd8a494e0a56100714112e5d2713d57bfab8951587 mosquitto-1.4.11.tar.gz
53859b628f965b77f6e47910c0ceba2f2737b815131ed800dc64a80419e434d25b5ba0938ae645882e9aa5d475d4940c7d35cc6d56f54bc4937a66b32d7db4ad libressl.patch
+d1e5ef833e1e624c0c45c9f7cf7cd755db7e81072e8140f5d687d6843985855aa721f72de63d738d37a43a2b2ed3de37dfaf34582958240754788aacc3c0ea5f config.patch
16f96d8f7f3a8b06e2b2e04d42d7e0d89a931b52277fc017e4802f7a3bc85aff4dd290b1a0c40382ea8f5568d0ceb7319c031d9be916f346d805231a002b0433 mosquitto.initd"
diff --git a/main/mosquitto/config.patch b/main/mosquitto/config.patch
new file mode 100644
index 0000000000..66a034365b
--- /dev/null
+++ b/main/mosquitto/config.patch
@@ -0,0 +1,59 @@
+diff --git a/config.mk b/config.mk
+index 6e369c2..ecc4990 100644
+--- a/config.mk
++++ b/config.mk
+@@ -26,7 +26,7 @@ WITH_TLS:=yes
+ # Comment out to disable TLS/PSK support in the broker and client. Requires
+ # WITH_TLS=yes.
+ # This must be disabled if using openssl < 1.0.
+-WITH_TLS_PSK:=yes
++WITH_TLS_PSK:=no
+
+ # Comment out to disable client client threading support.
+ WITH_THREADING:=yes
+@@ -46,7 +46,7 @@ WITH_PERSISTENCE:=yes
+ # Comment out to remove memory tracking support from the broker. If disabled,
+ # mosquitto won't track heap memory usage nor export '$SYS/broker/heap/current
+ # size', but will use slightly less memory and CPU time.
+-WITH_MEMORY_TRACKING:=yes
++WITH_MEMORY_TRACKING:=no
+
+ # Compile with database upgrading support? If disabled, mosquitto won't
+ # automatically upgrade old database versions.
+@@ -65,7 +65,7 @@ WITH_SRV:=yes
+ WITH_UUID:=yes
+
+ # Build with websockets support on the broker.
+-WITH_WEBSOCKETS:=no
++WITH_WEBSOCKETS:=yes
+
+ # Use elliptic keys in broker
+ WITH_EC:=yes
+@@ -78,6 +78,7 @@ WITH_SOCKS:=yes
+
+ # Build with async dns lookup support for bridges (temporary). Requires glibc.
+ #WITH_ADNS:=yes
++WITH_ADNS=no
+
+ # =============================================================================
+ # End of user configuration
+@@ -159,10 +160,6 @@ ifeq ($(UNAME),QNX)
+ LIB_LIBS:=$(LIB_LIBS) -lsocket
+ endif
+
+-ifeq ($(UNAME),Linux)
+- BROKER_LIBS:=$(BROKER_LIBS) -lanl
+-endif
+-
+ ifeq ($(WITH_WRAP),yes)
+ BROKER_LIBS:=$(BROKER_LIBS) -lwrap
+ BROKER_CFLAGS:=$(BROKER_CFLAGS) -DWITH_WRAP
+@@ -253,7 +250,7 @@ ifeq ($(WITH_DOCS),yes)
+ endif
+
+ INSTALL?=install
+-prefix=/usr/local
++prefix=/usr
+ mandir=${prefix}/share/man
+ localedir=${prefix}/share/locale
+ STRIP?=strip