aboutsummaryrefslogtreecommitdiffstats
path: root/main/motif
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-09 21:14:25 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-10 03:26:27 +0000
commit1a4bfc73312c57036a3f012709d7fc955cc07fed (patch)
tree3719d120579111582dd03852a6938b04855f83a0 /main/motif
parente00247ae491648c9b75b93c613123bd7b8498dca (diff)
downloadaports-1a4bfc73312c57036a3f012709d7fc955cc07fed.tar.bz2
aports-1a4bfc73312c57036a3f012709d7fc955cc07fed.tar.xz
main/motif: modernise, correct license, mark tests broken
Diffstat (limited to 'main/motif')
-rw-r--r--main/motif/APKBUILD61
1 files changed, 7 insertions, 54 deletions
diff --git a/main/motif/APKBUILD b/main/motif/APKBUILD
index 94024b459e..b1b9951bcb 100644
--- a/main/motif/APKBUILD
+++ b/main/motif/APKBUILD
@@ -1,14 +1,13 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
-
-
pkgname=motif
pkgver=2.3.4
pkgrel=2
pkgdesc="The Motif library"
url="http://motif.ics.com/"
arch="all"
-license="LGPL-2.0-or-later"
+options="!check" # Tests are interactive and require X11.
+license="LGPL-2.1-or-later"
depends=""
depends_dev="libx11-dev libxft-dev libxt-dev libxpm-dev libxext-dev xbitmaps"
makedepends="$depends_dev libtool autoconf automake flex flex-libs flex-dev bison"
@@ -32,17 +31,6 @@ source="http://downloads.sourceforge.net/$pkgname/Motif%20$pkgver%20Source%20Cod
17-switch-to-system-iswspace.patch
18-updated-fix-1565.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
# reasons for --disable- flags:
#png, jpeg: most programs that use png and jpeg use the libraries directly;
@@ -50,7 +38,7 @@ build() {
# png/jpeg image.
#printing: this is Xprint support; only CDE uses this, others print directly.
#demos: one of the demos can break the build
- cd "$_builddir"
+ cd "$builddir"
./autogen.sh \
--build=$CBUILD \
--host=$CHOST \
@@ -62,14 +50,13 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
mwm() {
@@ -81,40 +68,6 @@ mwm() {
}
-md5sums="612bb8127d0d31da6e5474edf8a5c247 motif-2.3.4-src.tgz
-191cee7af8137e75385153a8f334f50c 01-fix-autoconf.patch
-34044aeba20b7e4e9c543c771ce015f6 02-fix-format-security.patch
-7302c76677201e0be743fe3bb7f1cc8b 03-no-demos.patch
-bb676bc8f0a0d24fbb5c599b72dc827a 06-cast-size_t-to-int.patch
-ec750525c43510227b834d70239f7af4 07-fix_lintian_reported_manpage_typos.patch
-d6d836f83e3f9c9b2754f3486c7e3682 08-fix_hyphen_in_man_pages.patch
-829ee2d6e21de7463bc12ef35347a000 09-fix_typo_in_libxm.patch
-b993f84341d5b015ae1059b68af5ab55 10-fix_manpage-has-bad-whatis-entry.patch
-96bc3c48348c635e3ba03369632fbf09 11-fix_underlinking.patch
-7bb10fb0f0ddaa1c11a43b7110e0f3ff 12-fix_buffer_overrun_in_libxm.patch
-a283720664a1338157532e0b62164f91 13-fix_hardcoded_x11rgb_path.patch
-384688cde092594baf5a9cda9e6ea61d 14-fix_ac_find_xft.patch
-d4e5e74014da80985290d44e52e6296b 15-link_uil_against_libuil.patch
-9a7b47b601ecfc9639c54563e764851a 16-fix-undefined-use-of-sprintf.patch
-382bca380e52e377388a131df9c76245 17-switch-to-system-iswspace.patch
-6ef23e3053818411b2b75c2f40cbfa22 18-updated-fix-1565.patch"
-sha256sums="637efa09608e0b8f93465dbeb7c92e58ebb14c4bc1b488040eb79a65af3efbe0 motif-2.3.4-src.tgz
-cfdd253918b2fdbfa1803d59c7b1a20431a74de4227d20db0343aab866505c21 01-fix-autoconf.patch
-b679d4274c18fd4e29aad8fc757d0d635ce715329b28e8f46f6952ed9a8f390d 02-fix-format-security.patch
-c084ed5838c50296e18bd1354e812699e891d4a326c3fdd6e262a7a9e33eea8d 03-no-demos.patch
-85afe090f6f45ed4baef76a7d73cebf70343a6aaee0209cb4a12ac34b48610c4 06-cast-size_t-to-int.patch
-90e8ac475990c130345f0a1f9365329599184a4f1112dc863f33f727abee22d1 07-fix_lintian_reported_manpage_typos.patch
-5fda6f879619c3d9761b222114e8ee0f548f874cca8ae9122d1b436c96a58d8d 08-fix_hyphen_in_man_pages.patch
-6bd8872bf3099e57a3c47752c5c469b449901be0ede07a5301b7c05eb3a0067a 09-fix_typo_in_libxm.patch
-54481c6a3990b0c2034b759ee4bb28b03880ff6fc0cbca2e8c3f4263830358b1 10-fix_manpage-has-bad-whatis-entry.patch
-86ad1f5c40e1d8f69b927c87e5fcf39b7ce260d4cd156e4cbe9ad0a205ad72cb 11-fix_underlinking.patch
-3664820ec7c2639c4ab66f412121c1e8bcb8ce998a6a3743955e4b5ca7824d5e 12-fix_buffer_overrun_in_libxm.patch
-60b01485d2ef9302533d660eef91e5023d04e71c9d9e727c147f873f2fe86ba2 13-fix_hardcoded_x11rgb_path.patch
-1fe5efb1920c897c979f9292dc93e59d1315c145493fa591ec0000ba6e99eb7e 14-fix_ac_find_xft.patch
-ab061e0cca20b29f5337fed663eef7560defbdf6d0cf0fe21bf3377aaf516dca 15-link_uil_against_libuil.patch
-2bfb2957478f8c66554090dc171f885dc75bf3b0586e3b1abe7c3702f0ef23a2 16-fix-undefined-use-of-sprintf.patch
-8039b803716007d6959101592571f82f3be7590b86ba4d3160ae3b5362745a61 17-switch-to-system-iswspace.patch
-007dec8a19aae3a59723359bc7457692c0d2a6fbf68fc91b8d6e0e866277c8d7 18-updated-fix-1565.patch"
sha512sums="fb1033caa68f25b93282fa6700d5b7856be217b3651072d86e7c93a747df5b31219230998eb93deae22a8fa698e816b1a30e52b3ae88ae1c01c1f0aac59a2af2 motif-2.3.4-src.tgz
6ca24c74233552a4ce3ebb72f17ed277a3feca10bfa50c4680ed1eff917a11bf1f0bd39bcfdaaef1104466065c25c70251ba450f884bca637bc935565d0cdd9d 01-fix-autoconf.patch
aff5be25bd25666e6134bc18faaffd54914cc390ca4d89a498efae5aa6dd175ac2b17dc719f7b8d27cff5db2f17b714ddfd5a163f219cad5f5c949cf5eb4786d 02-fix-format-security.patch