aboutsummaryrefslogtreecommitdiffstats
path: root/main/mpc1
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-11 23:29:07 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:42 +0000
commita2ca34a5aa45c497f319a026da59a64d0a7175e7 (patch)
treeb69b72b04e70738a243ded166db64ed52a636e3f /main/mpc1
parent2e9b303e2b31836aa280ac18a5786a92657b9e85 (diff)
downloadaports-a2ca34a5aa45c497f319a026da59a64d0a7175e7.tar.bz2
aports-a2ca34a5aa45c497f319a026da59a64d0a7175e7.tar.xz
main/mpc1: add test suite, modernise APKBUILD
Diffstat (limited to 'main/mpc1')
-rw-r--r--main/mpc1/APKBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/main/mpc1/APKBUILD b/main/mpc1/APKBUILD
index c989755eae..7d0b40107a 100644
--- a/main/mpc1/APKBUILD
+++ b/main/mpc1/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpc1
pkgver=1.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Multiprecision C library"
url="http://www.multiprecision.org/"
arch="all"
@@ -13,14 +13,10 @@ install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://ftp.gnu.org/gnu/mpc/mpc-$pkgver.tar.gz"
-_builddir="$srcdir"/mpc-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
+builddir="$srcdir"/mpc-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
# workaround for a bug in configure script
EGREP=egrep \
./configure \
@@ -31,14 +27,18 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --enable-shared \
- || return 1
- make || return 1
+ --enable-shared
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
md5sums="d6a1d5f8ddea3abd2cc3e98f58352d26 mpc-1.0.3.tar.gz"