aboutsummaryrefslogtreecommitdiffstats
path: root/main/mpfr3/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-11 23:29:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:42 +0000
commit31e9fce843cb75e2fc1e725ff766030f80a58b2a (patch)
tree4ccf5be99f79fa2519c64abc712c2a66b633a3ce /main/mpfr3/APKBUILD
parenta2ca34a5aa45c497f319a026da59a64d0a7175e7 (diff)
downloadaports-31e9fce843cb75e2fc1e725ff766030f80a58b2a.tar.bz2
aports-31e9fce843cb75e2fc1e725ff766030f80a58b2a.tar.xz
main/mpfr3: add test suite, modernise APKBUILD
Diffstat (limited to 'main/mpfr3/APKBUILD')
-rw-r--r--main/mpfr3/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/main/mpfr3/APKBUILD b/main/mpfr3/APKBUILD
index c37e0c0cea..a74cccb4c1 100644
--- a/main/mpfr3/APKBUILD
+++ b/main/mpfr3/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpfr3
pkgver=3.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="multiple-precision floating-point library"
url="http://www.mpfr.org/"
arch="all"
@@ -21,14 +21,18 @@ build() {
--host=$CHOST \
--with-sysroot="$CBUILDROOT" \
--prefix=/usr \
- --enable-shared \
- || return 1;
- make || return 1
+ --enable-shared
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1;
+ make DESTDIR="$pkgdir" install
}
dev() {