aboutsummaryrefslogtreecommitdiffstats
path: root/main/mpfr3
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-06 10:58:27 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-06 11:06:29 +0000
commit10ee75ce54fa8d2964e83aec89c0554ded1374d6 (patch)
treea0add92870e2a2032c24cc3ed0e5e8de39220fb9 /main/mpfr3
parente9c0817b06893dfbd8f6bd5ee392661c8c7c5a68 (diff)
downloadaports-10ee75ce54fa8d2964e83aec89c0554ded1374d6.tar.bz2
aports-10ee75ce54fa8d2964e83aec89c0554ded1374d6.tar.xz
main/mpfr3: fix musl build, add cross build support
Diffstat (limited to 'main/mpfr3')
-rw-r--r--main/mpfr3/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/mpfr3/APKBUILD b/main/mpfr3/APKBUILD
index d920070431..e90ecf33ca 100644
--- a/main/mpfr3/APKBUILD
+++ b/main/mpfr3/APKBUILD
@@ -7,11 +7,18 @@ url="http://www.mpfr.org/"
arch="all"
license="GPL LGPL"
depends=
-makedepends="gmp-dev texinfo"
+makedepends_build="texinfo"
+makedepends_host="gmp-dev"
+makedepends="$makedepends_build $makedepends_host"
source="http://www.mpfr.org/mpfr-current/mpfr-$pkgver.tar.xz"
subpackages="$pkgname-doc mpfr-dev"
_builddir="$srcdir"/mpfr-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
cd "$_builddir"
./configure \