aboutsummaryrefslogtreecommitdiffstats
path: root/main/mtx
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
commitced1e02903a233c6ca2a36e816cea9fd6946f0ed (patch)
tree17f52ace253ef6a4baaf0d2b81cba0aaeaee6ee9 /main/mtx
parent8bd4249e988a560cb63b28238f4ed10f46ee9a23 (diff)
downloadaports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.bz2
aports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.xz
[various]: update config.sub, and update apkbuild
Diffstat (limited to 'main/mtx')
-rw-r--r--main/mtx/APKBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/main/mtx/APKBUILD b/main/mtx/APKBUILD
index 5fb9a720f3..294003ee5a 100644
--- a/main/mtx/APKBUILD
+++ b/main/mtx/APKBUILD
@@ -13,8 +13,15 @@ install=""
subpackages=""
source="http://downloads.sourceforge.net/mtx/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,6 +29,10 @@ build() {
--datadir=/usr/share \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make prefix="$pkgdir" install
}