aboutsummaryrefslogtreecommitdiffstats
path: root/main/multipath-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-17 16:32:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-20 10:49:42 +0000
commitd53e824c6c41afb8206bf32a7a8e8a134e95af5b (patch)
tree76797ca6e52f3fd4d7ce449cb89e24c1d09eca5f /main/multipath-tools
parent46127cc89c5b27cab93600b0281a149e56533d17 (diff)
downloadaports-d53e824c6c41afb8206bf32a7a8e8a134e95af5b.tar.bz2
aports-d53e824c6c41afb8206bf32a7a8e8a134e95af5b.tar.xz
main/multipath-tools: upgrade to 0.6.3
but we remove the rdb checker for now
Diffstat (limited to 'main/multipath-tools')
-rw-r--r--main/multipath-tools/APKBUILD59
-rw-r--r--main/multipath-tools/daddr_t.patch11
-rw-r--r--main/multipath-tools/fix-yield.patch13
-rw-r--r--main/multipath-tools/scsi_ident.patch28
-rw-r--r--main/multipath-tools/sys-types.patch11
5 files changed, 45 insertions, 77 deletions
diff --git a/main/multipath-tools/APKBUILD b/main/multipath-tools/APKBUILD
index a180713078..acba5f81d4 100644
--- a/main/multipath-tools/APKBUILD
+++ b/main/multipath-tools/APKBUILD
@@ -1,29 +1,37 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="multipath-tools"
-pkgver=0.5.0
-pkgrel=4
+pkgver=0.6.3
+pkgrel=0
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr/"
arch="all"
license="GPL"
depends="eudev"
-makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev eudev-dev"
+makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev eudev-dev
+ userspace-rcu-dev"
install=
subpackages="$pkgname-doc"
-source="http://christophe.varoqui.free.fr/multipath-tools/multipath-tools-$pkgver.tar.bz2
+source="http://dev.alpinelinux.org/archive/multipath-tools/multipath-tools-$pkgver.tar.gz
+ disable-rbd.patch
+ fix-yield.patch
+
multipath-tools.conf
multipath-tools.confd
multipath-tools.initd
-
- sys-types.patch
- daddr_t.patch
- scsi_ident.patch
"
-_builddir="$srcdir"/multipath-tools-$pkgver
+builddir="$srcdir"/multipath-tools-$pkgver
+snapshot() {
+ cd "$srcdir"
+ git clone http://git.opensvc.com/multipath-tools/.git
+ cd multipath-tools
+ git archive --format=tar.gz --prefix=multipath-tools-$pkgver/ \
+ -o ../multipath-tools-$pkgver.tar.gz $pkgver \
+ && scp ../multipath-tools-$pkgver.tar.gz dev.alpinelinux.org:archive/multipath-tools/
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -32,7 +40,7 @@ prepare() {
}
build() {
- cd $_builddir
+ cd $builddir
make prefix="/usr" \
sysconfdir="/etc" \
mandir="/usr/share/man" \
@@ -40,31 +48,28 @@ build() {
}
package() {
- cd $_builddir
+ cd $builddir
make DESTDIR="$pkgdir" install || return 1
install -D -m644 "$srcdir"/$pkgname.conf $pkgdir/etc/multipath.conf
install -D -m644 "$srcdir"/$pkgname.confd $pkgdir/etc/conf.d/multipathd
install -D -m755 "$srcdir"/$pkgname.initd $pkgdir/etc/init.d/multipathd
}
-md5sums="faf261d4cc717bf4c979557dc7bf5f52 multipath-tools-0.5.0.tar.bz2
+md5sums="0ed3487eb82b2b635b1a4fbd4057d43d multipath-tools-0.6.3.tar.gz
+7ddfcd64ee0b871a35cb72f22cc2b6bf disable-rbd.patch
+e19d7ed5492a23db6527fbc9c52198c3 fix-yield.patch
d364a5ef62c23da92d81baf90e7b6192 multipath-tools.conf
52dcde0446669e9d19813b28f3dd622b multipath-tools.confd
-e2032d8042fcc4b015b1dc1cc66cabe5 multipath-tools.initd
-12f2c6235caa2cc0cbe97606ae379fff sys-types.patch
-9e7673f58a2b43798877396c4d9004fc daddr_t.patch
-260d356837b3e082f5bf53f5e815ad1f scsi_ident.patch"
-sha256sums="f13cf1eb84e94e83b2019e68f7965526903c13e94246db43965d181668a0a6f9 multipath-tools-0.5.0.tar.bz2
+e2032d8042fcc4b015b1dc1cc66cabe5 multipath-tools.initd"
+sha256sums="8a8dae70b7040e5c8bf187f3ab4113cf91a3644265bcca87f982befc6cec6ea1 multipath-tools-0.6.3.tar.gz
+7a1683035f65a6be6d4ec98ba77fbef95f5b518ada93d53f3cfe8fdc73d2e638 disable-rbd.patch
+805707a503a6ffda81c235ac1f3e986d52e16be75783839a02cb927f59423cec fix-yield.patch
e5df29fc6cf01789db179e20aaac2705878975eb826157bd9f824a3f86a8dcd5 multipath-tools.conf
b13587b0865ea8c39f51e2177e4fbc0ada237408a5807fab836ff4b5ebcb3e37 multipath-tools.confd
-bb7846f6c2bfdfb4ee50fe1965271909a9864b2b913d4892bb406d66f794ce9a multipath-tools.initd
-d7bd2b5e3de194a151aaf15de4a3b136a218d064b78539027e7f2fa4613072fb sys-types.patch
-cb6877ba73f7e8ed6efded8af902ecb16ee5be901149b3f771b5c6ccdb3fe452 daddr_t.patch
-a14de8791b7b6e7f64e0a07786a88bfd1c26820e18a2f1f3f66abc341a04332c scsi_ident.patch"
-sha512sums="dfad21c45d0f69e39041d30d203a582c8ee8329bf390c51cde10155b3de379e7ad8fead2ac4beb268a924fd7e7dc8e1cf538ea3c70d41479fd8786fa30ba22a9 multipath-tools-0.5.0.tar.bz2
+bb7846f6c2bfdfb4ee50fe1965271909a9864b2b913d4892bb406d66f794ce9a multipath-tools.initd"
+sha512sums="669fa3f915da29769b21f8fa81227a4d8aefc779d54378b3899ec06d62508382ce8924978feb81b0b92abdcdf2c4b9206ea32f3231b7594475c4de76d13fb694 multipath-tools-0.6.3.tar.gz
+2460a2d0e3787a3862e9258c3821ac13819c7b1cbe03abc9b53a728ef502086692d643a15c655d6b73c909d917387548c08b182bc82d698e5b4c64a77b1e6858 disable-rbd.patch
+6f55b2c0ae6696ff819fc3f5ea5e59407db06bdac0097709034325e2a53cfd1025d4134df343f952bb13be4b1058b38ce54ffcb9e2faf2f53331afc529052cc1 fix-yield.patch
e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213 multipath-tools.conf
303c62b7506b207ba2266310e7a701d76151e6f1544b44faf666dfabdc59c5aeb98544d380988e18b4a7b8235e4000380f025c4dd6c95d45a7b8b51bbf39dce5 multipath-tools.confd
-1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c multipath-tools.initd
-bee0b1d18c0359a2c43719bd2cf7bc80ce073aa27e1315c9a9b9efa805474359df1b796dc832b0162a686b11b0d1aeb2c85b5bb2b36892dd472b53694c939cd4 sys-types.patch
-526707621ca2747b07192824e1269a17c81ffb7c19606d45388bb80ae7da027f68c25edd53a690d1485d00fc4ce6dab646e097d53a33394860f6c9d5b072e463 daddr_t.patch
-12d126c5e61b6834d9d38e9ca6ea693b00bf08fa90a94b583c5ae846b3599b3c757fe37db73043e459ba60140a919583cf34107f9a87edab5457eb14f18af84f scsi_ident.patch"
+1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c multipath-tools.initd"
diff --git a/main/multipath-tools/daddr_t.patch b/main/multipath-tools/daddr_t.patch
deleted file mode 100644
index 3922b123db..0000000000
--- a/main/multipath-tools/daddr_t.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./kpartx/solaris.c.orig
-+++ ./kpartx/solaris.c
-@@ -11,7 +11,7 @@
- struct solaris_x86_slice {
- unsigned short s_tag; /* ID tag of partition */
- unsigned short s_flag; /* permision flags */
-- daddr_t s_start; /* start sector no of partition */
-+ long s_start; /* start sector no of partition */
- long s_size; /* # of blocks in partition */
- };
-
diff --git a/main/multipath-tools/fix-yield.patch b/main/multipath-tools/fix-yield.patch
new file mode 100644
index 0000000000..e93d3bce25
--- /dev/null
+++ b/main/multipath-tools/fix-yield.patch
@@ -0,0 +1,13 @@
+diff --git a/multipathd/uxlsnr.c b/multipathd/uxlsnr.c
+index 7a9faf3..4e6a197 100644
+--- a/multipathd/uxlsnr.c
++++ b/multipathd/uxlsnr.c
+@@ -180,7 +180,7 @@ void * uxsock_listen(uxsock_trigger_fn uxsock_trigger, void * trigger_data)
+ pthread_mutex_unlock(&client_lock);
+ condlog(0, "%s: failed to realloc %d poll fds",
+ "uxsock", 1 + num_clients);
+- pthread_yield();
++ sched_yield();
+ continue;
+ }
+ old_clients = num_clients;
diff --git a/main/multipath-tools/scsi_ident.patch b/main/multipath-tools/scsi_ident.patch
deleted file mode 100644
index c626c0e507..0000000000
--- a/main/multipath-tools/scsi_ident.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From: Hannes Reinecke <hare@suse.de>
-Date: Thu, 10 Apr 2014 10:21:52 +0000 (+0200)
-Subject: Use 'SCSI_IDENT_.*' as the default property whitelist
-X-Git-Url: http://git.opensvc.com/gitweb.cgi?p=multipath-tools%2F.git;a=commitdiff_plain;h=d041591e42b69e2ff99d9cc5c1111c83ccde3207
-
-Use 'SCSI_IDENT_.*' as the default property whitelist
-
-59-scsi-sg_utils.rules export the VPD pages as
-SCSI_IDENT_<association>_<type>.
-So whenever we have a SCSI_IDENT_* property we know it
-has come from VPD pages and we have a legit device.
-
-Signed-off-by: Hannes Reinecke <hare@suse.de>
----
-
-diff --git a/libmultipath/blacklist.c b/libmultipath/blacklist.c
-index cea128c..30c5031 100644
---- a/libmultipath/blacklist.c
-+++ b/libmultipath/blacklist.c
-@@ -196,7 +196,7 @@ setup_default_blist (struct config * conf)
- if (store_ble(conf->blist_devnode, str, ORIGIN_DEFAULT))
- return 1;
-
-- str = STRDUP("(ID_SCSI_VPD|ID_WWN)");
-+ str = STRDUP("(SCSI_IDENT_.*|ID_WWN)");
- if (!str)
- return 1;
- if (store_ble(conf->elist_property, str, ORIGIN_DEFAULT))
diff --git a/main/multipath-tools/sys-types.patch b/main/multipath-tools/sys-types.patch
deleted file mode 100644
index 6ee0311b30..0000000000
--- a/main/multipath-tools/sys-types.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libmultipath/util.h.orig
-+++ ./libmultipath/util.h
-@@ -1,6 +1,8 @@
- #ifndef _UTIL_H
- #define _UTIL_H
-
-+#include <sys/types.h>
-+
- size_t strchop(char *);
- int basenamecpy (const char * src, char * dst, int);
- int filepresent (char * run);