aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-22 22:09:06 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-22 22:09:57 +0000
commit765c858d306c713051abcdfca64a875f05462d2b (patch)
tree47641056bab8b8741da9cf22d0d188649f77928c /main/musl
parenta4bfa375739e0b009392cb6aac06b59ff998d0f6 (diff)
downloadaports-765c858d306c713051abcdfca64a875f05462d2b.tar.bz2
aports-765c858d306c713051abcdfca64a875f05462d2b.tar.xz
main/musl: apply proactive mitigation against bugs like glibc CVE-2017-1000366
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch29
-rw-r--r--main/musl/APKBUILD3
2 files changed, 31 insertions, 1 deletions
diff --git a/main/musl/2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch b/main/musl/2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
new file mode 100644
index 0000000000..b39664dacb
--- /dev/null
+++ b/main/musl/2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
@@ -0,0 +1,29 @@
+From 58dec23397e3fcc4300cc03839ce5e508389abbc Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Thu, 22 Jun 2017 22:04:51 +0000
+Subject: [PATCH] pthread internals: increase DEFAULT_GUARD_SIZE to 2 pages
+ instead of 1 page.
+
+This is intended to be a proactive mitigation against any bugs similar to CVE-2017-1000366.
+
+Signed-off-by: William Pitcock <nenolod@dereferenced.org>
+---
+ src/internal/pthread_impl.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/internal/pthread_impl.h b/src/internal/pthread_impl.h
+index ae0ab1c5..ad4ea3fa 100644
+--- a/src/internal/pthread_impl.h
++++ b/src/internal/pthread_impl.h
+@@ -146,7 +146,7 @@ void __block_app_sigs(void *);
+ void __restore_sigs(void *);
+
+ #define DEFAULT_STACK_SIZE 81920
+-#define DEFAULT_GUARD_SIZE 4096
++#define DEFAULT_GUARD_SIZE 8192
+
+ #define __ATTRP_C11_THREAD ((void*)(uintptr_t)-1)
+
+--
+2.13.0
+
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 6317ea7657..cbb8ab9d81 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.16
-pkgrel=13
+pkgrel=14
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -67,6 +67,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0048-handle-errors-from-localtime_r-in-ctime_r.patch
0049-fix-iconv-conversions-for-iso88592-iso885916.patch
1000-implement-strftime-GNU-extension-padding-specifiers-.patch
+ 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
ldconfig
__stack_chk_fail_local.c