aboutsummaryrefslogtreecommitdiffstats
path: root/main/mutt
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-28 12:28:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-28 12:29:30 +0000
commit45270f5c6eaf059a8d9e784dee7de05bd6a65936 (patch)
tree965361d29f1517c4b4e85460c539229bd1fd983b /main/mutt
parent3bcdfd488ace0b68eff4d1e9a9f4b9395fff28f0 (diff)
downloadaports-45270f5c6eaf059a8d9e784dee7de05bd6a65936.tar.bz2
aports-45270f5c6eaf059a8d9e784dee7de05bd6a65936.tar.xz
main/mutt: moved from testing
works like a charm
Diffstat (limited to 'main/mutt')
-rw-r--r--main/mutt/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/mutt/APKBUILD b/main/mutt/APKBUILD
new file mode 100644
index 0000000000..e8cfa03fd1
--- /dev/null
+++ b/main/mutt/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Andrew Manison<amanison@anselsystems.com>
+# Maintainer: Andrew Manison<amanison@anselsystems.com>
+pkgname=mutt
+pkgver=1.4.2.3
+pkgrel=0
+pkgdesc="a small but very powerful text-mode email client"
+url="http://www.mutt.org"
+license="GPL"
+depends="openssl ncurses libiconv"
+makedepends="openssl-dev ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="ftp://ftp.mutt.org/$pkgname/$pkgname-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-imap \
+ --enable-pop \
+ --enable-smtp \
+ --with-curses \
+ --with-mailpath=/var/spool/mail \
+ --with-ssl
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="dcb94661827dd090fa813e73e122ea0c mutt-1.4.2.3.tar.gz"