aboutsummaryrefslogtreecommitdiffstats
path: root/main/nano
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-04-02 15:59:52 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-04-03 02:00:02 +0000
commitc66acd7b780be1346aed7066f302a94587d59ca3 (patch)
tree1cf63da6c656f3a417326750aca2ccee97ca740a /main/nano
parent5a65fddad7fc2abbd2e0ff12bc03e101dd64f9d8 (diff)
downloadaports-c66acd7b780be1346aed7066f302a94587d59ca3.tar.bz2
aports-c66acd7b780be1346aed7066f302a94587d59ca3.tar.xz
main/nano: fix regex syntax 'Invalid character class name'
add --with-wordbounds to configure to fix bad regexes: https://lists.gnu.org/archive/html/help-nano/2013-01/msg00001.html See https://savannah.gnu.org/bugs/?50705 TL;DR: seems like a bug in configure which ends up wrongly assuming it needs to use an alternative word-boundary regex syntax [[:<:]] - which the resulting binary doesn't actually support, and so it spawns a lot of errors while trying to load and parse color syntax files. As a workaround until it's resolved upstream, adding --with-wordbounds forces it to use a regex syntax which the binary does support, and color syntax files are now loaded and used correctly and without errors.
Diffstat (limited to 'main/nano')
-rw-r--r--main/nano/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/nano/APKBUILD b/main/nano/APKBUILD
index 6d2c07fd89..04b8d0bcc2 100644
--- a/main/nano/APKBUILD
+++ b/main/nano/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nano
pkgver=2.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="Text Editor. GNU nano is designed to be a free replacement for the Pico text editor."
url="http://www.nano-editor.org/"
arch="all"
@@ -22,6 +22,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-nls \
+ --with-wordbounds \
|| return 1
make || return 1
}