aboutsummaryrefslogtreecommitdiffstats
path: root/main/nasm
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-20 08:48:35 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-20 13:40:51 +0000
commitba05d56727b98b779b51e2600758bfe4d5282189 (patch)
treef53e7d8899755f752e9cc156290145fd8c8e2b8d /main/nasm
parent2d8f6ec4d9048e42c9aa44b764653ec619f510fd (diff)
downloadaports-ba05d56727b98b779b51e2600758bfe4d5282189.tar.bz2
aports-ba05d56727b98b779b51e2600758bfe4d5282189.tar.xz
main/nasm: upgrade to 2.13.01
Diffstat (limited to 'main/nasm')
-rw-r--r--main/nasm/APKBUILD15
-rw-r--r--main/nasm/space-after-backslash.patch31
2 files changed, 5 insertions, 41 deletions
diff --git a/main/nasm/APKBUILD b/main/nasm/APKBUILD
index a8f0f3ce2e..778f36503d 100644
--- a/main/nasm/APKBUILD
+++ b/main/nasm/APKBUILD
@@ -1,14 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nasm
-pkgver=2.12.02
+pkgver=2.13.01
pkgrel=0
pkgdesc="80x86 assembler designed for portability and modularity"
url="http://nasm.sourceforge.net"
arch="all"
license="BSD-2"
-depends=
source="http://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2"
-
subpackages="$pkgname-doc"
builddir="$srcdir"/$pkgname-$pkgver
@@ -19,16 +17,13 @@ build () {
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make nasmlib.o || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
cd "$builddir"
make INSTALLROOT="$pkgdir" install
}
-md5sums="d15843c3fb7db39af80571ee27ec6fad nasm-2.12.02.tar.bz2"
-sha256sums="00b0891c678c065446ca59bcee64719d0096d54d6886e6e472aeee2e170ae324 nasm-2.12.02.tar.bz2"
-sha512sums="7744a078647861382212de798d200b683cc4044881474fc1931acb14dfa0340ce026d1b3f64ac1ece87878ccd0ddcb69b8c0c850415313f47e01f0332e56a8f8 nasm-2.12.02.tar.bz2"
+
+sha512sums="3caf1a3bb9c2f406adce1de37afa92fbf7d7f8d2d274baab08b0e9dc6712c09347fc57d04c3962b6820ad303040efe7e3de0b923c3010c8da00051633bf00c5b nasm-2.13.01.tar.bz2"
diff --git a/main/nasm/space-after-backslash.patch b/main/nasm/space-after-backslash.patch
deleted file mode 100644
index c6e0df5dd7..0000000000
--- a/main/nasm/space-after-backslash.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 490f85e73d8bca15ada1c0bacc101c136e5d9cee Mon Sep 17 00:00:00 2001
-From: Cyrill Gorcunov <gorcunov@gmail.com>
-Date: Thu, 27 Dec 2012 20:02:17 +0400
-Subject: [PATCH] br3392236: Don't treat \Space after \BackSlash as a sign for line continuation
-
-In commit f1fe4fdeabeaf2e5e4d02ef43beeb09a6fbfed1b I occasionally
-made a \Space after \BackSlash being a sign of line continuation.
-
-Fix it.
-
-Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
----
- preproc.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/preproc.c b/preproc.c
-index 8c5bf7a..9d65917 100644
---- a/preproc.c
-+++ b/preproc.c
-@@ -844,7 +844,7 @@ static char *read_line(void)
- case '\\':
- next = fgetc(istk->fp);
- ungetc(next, istk->fp);
-- if (next == ' ' || next == '\r' || next == '\n') {
-+ if (next == '\r' || next == '\n') {
- cont = true;
- nr_cont++;
- continue;
---
-1.6.5.GIT
-