aboutsummaryrefslogtreecommitdiffstats
path: root/main/ncdu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-22 14:34:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-22 14:34:04 +0000
commit8c15f7520747e20bfe61f032038f0879dd776e1d (patch)
treed3aa8d06c08d5a938a233de8307601be4ef261d2 /main/ncdu
parent4d33d662fa961cc4d7145e500730848bb0884b05 (diff)
downloadaports-8c15f7520747e20bfe61f032038f0879dd776e1d.tar.bz2
aports-8c15f7520747e20bfe61f032038f0879dd776e1d.tar.xz
main/ncdu: moved from testing
Diffstat (limited to 'main/ncdu')
-rw-r--r--main/ncdu/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/ncdu/APKBUILD b/main/ncdu/APKBUILD
new file mode 100644
index 0000000000..a00cbe0b67
--- /dev/null
+++ b/main/ncdu/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ncdu
+pkgver=1.7
+pkgrel=0
+pkgdesc="Text-based disk usage viewer"
+url="http://dev.yorhel.nl/ncdu"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="172047c29d232724cc62e773e82e592a ncdu-1.7.tar.gz"