aboutsummaryrefslogtreecommitdiffstats
path: root/main/ncdu
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-06 22:04:58 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-06 22:04:58 +0100
commit92d0832aa5e1d1c95d9006537c078df041dc1089 (patch)
tree2d0c58ab5bc2a8208a7e553a147a8514cf325093 /main/ncdu
parentd4a82139f5b5d543963d475e34be76d97273ef9a (diff)
downloadaports-92d0832aa5e1d1c95d9006537c078df041dc1089.tar.bz2
aports-92d0832aa5e1d1c95d9006537c078df041dc1089.tar.xz
main/ncdu: improve abuild
Diffstat (limited to 'main/ncdu')
-rw-r--r--main/ncdu/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/main/ncdu/APKBUILD b/main/ncdu/APKBUILD
index 434a013048..b2a4e33950 100644
--- a/main/ncdu/APKBUILD
+++ b/main/ncdu/APKBUILD
@@ -8,15 +8,13 @@ url="http://dev.yorhel.nl/ncdu"
arch="all"
license="MIT"
depends=""
-depends_dev=""
makedepends="ncurses-dev"
-install=""
subpackages="$pkgname-doc"
source="http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +26,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}