aboutsummaryrefslogtreecommitdiffstats
path: root/main/nfs-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-12 14:16:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-12 14:16:54 +0000
commit35038f4a2af51efed7265a064fd4a43ffd8a4b95 (patch)
tree781c3633801f9fb3abfe269f57e2dc09df0bf8d6 /main/nfs-utils
parent31c5760db1020fee1de508e573f21a284c11c8e4 (diff)
downloadaports-35038f4a2af51efed7265a064fd4a43ffd8a4b95.tar.bz2
aports-35038f4a2af51efed7265a064fd4a43ffd8a4b95.tar.xz
main/nfs-utils: build fixes for musl
Diffstat (limited to 'main/nfs-utils')
-rw-r--r--main/nfs-utils/0001-conffile-use-standard-uint-_t-and-unsigned-char.patch74
-rw-r--r--main/nfs-utils/0002-Fix-header-include-for-definition-of-NULL.patch27
-rw-r--r--main/nfs-utils/0003-replace-__attribute_malloc__-with-the-more-portable-.patch208
-rw-r--r--main/nfs-utils/0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch61
-rw-r--r--main/nfs-utils/0005-exportfs-define-_GNU_SOURCE-for-stat64.patch28
-rw-r--r--main/nfs-utils/0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch38
-rw-r--r--main/nfs-utils/0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch27
-rw-r--r--main/nfs-utils/APKBUILD38
8 files changed, 498 insertions, 3 deletions
diff --git a/main/nfs-utils/0001-conffile-use-standard-uint-_t-and-unsigned-char.patch b/main/nfs-utils/0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
new file mode 100644
index 0000000000..fdd76c71b6
--- /dev/null
+++ b/main/nfs-utils/0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
@@ -0,0 +1,74 @@
+From ae1a0a0fd0191ccc7dd4bbbf0a1803db0bd7ccca Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 13:40:36 +0000
+Subject: [PATCH 1/7] conffile: use standard uint*_t and unsigned char
+
+Use the standard integer types. This fixes compiling errors with musl
+libc.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ support/include/conffile.h | 2 +-
+ support/nfs/conffile.c | 14 +++++++-------
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/support/include/conffile.h b/support/include/conffile.h
+index 05ea5d2..94fb005 100644
+--- a/support/include/conffile.h
++++ b/support/include/conffile.h
+@@ -49,7 +49,7 @@ struct conf_list {
+ extern char *conf_path;
+
+ extern int conf_begin(void);
+-extern int conf_decode_base64(u_int8_t *, u_int32_t *, u_char *);
++extern int conf_decode_base64(uint8_t *, uint32_t *, unsigned char *);
+ extern int conf_end(int, int);
+ extern void conf_free_list(struct conf_list *);
+ extern struct sockaddr *conf_get_address(char *, char *);
+diff --git a/support/nfs/conffile.c b/support/nfs/conffile.c
+index c3434d5..6b94ec0 100644
+--- a/support/nfs/conffile.c
++++ b/support/nfs/conffile.c
+@@ -72,10 +72,10 @@ TAILQ_HEAD (conf_trans_head, conf_trans) conf_trans_queue;
+ /*
+ * Radix-64 Encoding.
+ */
+-static const u_int8_t bin2asc[]
++static const uint8_t bin2asc[]
+ = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
+
+-static const u_int8_t asc2bin[] =
++static const uint8_t asc2bin[] =
+ {
+ 255, 255, 255, 255, 255, 255, 255, 255,
+ 255, 255, 255, 255, 255, 255, 255, 255,
+@@ -109,10 +109,10 @@ LIST_HEAD (conf_bindings, conf_binding) conf_bindings[256];
+
+ static char *conf_addr;
+
+-static __inline__ u_int8_t
++static __inline__ uint8_t
+ conf_hash(char *s)
+ {
+- u_int8_t hash = 0;
++ uint8_t hash = 0;
+
+ while (*s) {
+ hash = ((hash << 1) | (hash >> 7)) ^ tolower (*s);
+@@ -603,10 +603,10 @@ cleanup:
+
+ /* Decode a PEM encoded buffer. */
+ int
+-conf_decode_base64 (u_int8_t *out, u_int32_t *len, u_char *buf)
++conf_decode_base64 (uint8_t *out, uint32_t *len, unsigned char *buf)
+ {
+- u_int32_t c = 0;
+- u_int8_t c1, c2, c3, c4;
++ uint32_t c = 0;
++ uint8_t c1, c2, c3, c4;
+
+ while (*buf) {
+ if (*buf > 127 || (c1 = asc2bin[*buf]) == 255)
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0002-Fix-header-include-for-definition-of-NULL.patch b/main/nfs-utils/0002-Fix-header-include-for-definition-of-NULL.patch
new file mode 100644
index 0000000000..ba7c56c44a
--- /dev/null
+++ b/main/nfs-utils/0002-Fix-header-include-for-definition-of-NULL.patch
@@ -0,0 +1,27 @@
+From 7bb18315852601df9fd02f714d12fa09b9adbdba Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 13:43:34 +0000
+Subject: [PATCH 2/7] Fix header include for definition of NULL
+
+NULL is defined in stdlib.h so we need to include that.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ support/include/sockaddr.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/support/include/sockaddr.h b/support/include/sockaddr.h
+index a1c30f9..446b537 100644
+--- a/support/include/sockaddr.h
++++ b/support/include/sockaddr.h
+@@ -27,6 +27,7 @@
+ #ifdef HAVE_LIBIO_H
+ #include <libio.h>
+ #endif
++#include <stdlib.h>
+ #include <stdbool.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0003-replace-__attribute_malloc__-with-the-more-portable-.patch b/main/nfs-utils/0003-replace-__attribute_malloc__-with-the-more-portable-.patch
new file mode 100644
index 0000000000..569acede0c
--- /dev/null
+++ b/main/nfs-utils/0003-replace-__attribute_malloc__-with-the-more-portable-.patch
@@ -0,0 +1,208 @@
+From 1364f15b4b5654da8af64fc8e77bb184115ad445 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 13:46:51 +0000
+Subject: [PATCH 3/7] replace __attribute_malloc__ with the more portable
+ __attribute__((__malloc__))
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ support/export/hostname.c | 14 +++++++-------
+ support/include/exportfs.h | 10 +++++-----
+ support/nfs/svc_create.c | 2 +-
+ utils/statd/hostname.c | 6 +++---
+ utils/statd/sm-notify.c | 8 ++++----
+ utils/statd/statd.h | 2 +-
+ 6 files changed, 21 insertions(+), 21 deletions(-)
+
+diff --git a/support/export/hostname.c b/support/export/hostname.c
+index 3e949a1..ad595d1 100644
+--- a/support/export/hostname.c
++++ b/support/export/hostname.c
+@@ -91,7 +91,7 @@ host_ntop(const struct sockaddr *sap, char *buf, const size_t buflen)
+ * Returns address info structure, or NULL if an error occurs. Caller
+ * must free the returned structure with freeaddrinfo(3).
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo *
+ host_pton(const char *paddr)
+ {
+@@ -153,7 +153,7 @@ host_pton(const char *paddr)
+ * if no information is available for @hostname. Caller must free the
+ * returned structure with freeaddrinfo(3).
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo *
+ host_addrinfo(const char *hostname)
+ {
+@@ -199,7 +199,7 @@ host_addrinfo(const char *hostname)
+ * the string.
+ */
+ #ifdef HAVE_GETNAMEINFO
+-__attribute_malloc__
++__attribute__((__malloc__))
+ char *
+ host_canonname(const struct sockaddr *sap)
+ {
+@@ -234,7 +234,7 @@ host_canonname(const struct sockaddr *sap)
+ return strdup(buf);
+ }
+ #else /* !HAVE_GETNAMEINFO */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ char *
+ host_canonname(const struct sockaddr *sap)
+ {
+@@ -266,7 +266,7 @@ host_canonname(const struct sockaddr *sap)
+ *
+ * Caller must free the returned structure with freeaddrinfo(3).
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo *
+ host_reliable_addrinfo(const struct sockaddr *sap)
+ {
+@@ -313,7 +313,7 @@ out_free_hostname:
+ * Caller must free the returned structure with freeaddrinfo(3).
+ */
+ #ifdef HAVE_GETNAMEINFO
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo *
+ host_numeric_addrinfo(const struct sockaddr *sap)
+ {
+@@ -361,7 +361,7 @@ host_numeric_addrinfo(const struct sockaddr *sap)
+ return ai;
+ }
+ #else /* !HAVE_GETNAMEINFO */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo *
+ host_numeric_addrinfo(const struct sockaddr *sap)
+ {
+diff --git a/support/include/exportfs.h b/support/include/exportfs.h
+index 97b2327..9021fae 100644
+--- a/support/include/exportfs.h
++++ b/support/include/exportfs.h
+@@ -156,15 +156,15 @@ int secinfo_addflavor(struct flav_info *, struct exportent *);
+
+ char * host_ntop(const struct sockaddr *sap,
+ char *buf, const size_t buflen);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo * host_pton(const char *paddr);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo * host_addrinfo(const char *hostname);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ char * host_canonname(const struct sockaddr *sap);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo * host_reliable_addrinfo(const struct sockaddr *sap);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ struct addrinfo * host_numeric_addrinfo(const struct sockaddr *sap);
+
+ int rmtab_read(void);
+diff --git a/support/nfs/svc_create.c b/support/nfs/svc_create.c
+index 6b9e85b..a706f87 100644
+--- a/support/nfs/svc_create.c
++++ b/support/nfs/svc_create.c
+@@ -113,7 +113,7 @@ svc_create_find_xprt(const struct sockaddr *bindaddr, const struct netconfig *nc
+ *
+ * Otherwise NULL is returned if an error occurs.
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct addrinfo *
+ svc_create_bindaddr(struct netconfig *nconf, const uint16_t port)
+ {
+diff --git a/utils/statd/hostname.c b/utils/statd/hostname.c
+index 746ecc7..c61087c 100644
+--- a/utils/statd/hostname.c
++++ b/utils/statd/hostname.c
+@@ -105,7 +105,7 @@ statd_present_address(const struct sockaddr *sap, char *buf, const size_t buflen
+ * Look up the hostname; report exceptional errors. Caller must
+ * call freeaddrinfo(3) if a valid addrinfo is returned.
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct addrinfo *
+ get_addrinfo(const char *hostname, const struct addrinfo *hint)
+ {
+@@ -184,7 +184,7 @@ get_nameinfo(const struct sockaddr *sap,
+ * We won't monitor peers that don't have a reverse map. The canonical
+ * name gives us a key for our monitor list.
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ char *
+ statd_canonical_name(const char *hostname)
+ {
+@@ -234,7 +234,7 @@ statd_canonical_name(const char *hostname)
+ * NULL if some error occurs. Caller must free the returned
+ * list with freeaddrinfo(3).
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct addrinfo *
+ statd_canonical_list(const char *hostname)
+ {
+diff --git a/utils/statd/sm-notify.c b/utils/statd/sm-notify.c
+index 9dbe5d9..5994b2f 100644
+--- a/utils/statd/sm-notify.c
++++ b/utils/statd/sm-notify.c
+@@ -74,7 +74,7 @@ static int record_pid(void);
+
+ static struct nsm_host * hosts = NULL;
+
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct addrinfo *
+ smn_lookup(const char *name)
+ {
+@@ -149,7 +149,7 @@ smn_get_hostname(const struct sockaddr *sap,
+ * if the canonical name doesn't exist or cannot be determined.
+ * The caller must free the result with free(3).
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static char *
+ smn_verify_my_name(const char *name)
+ {
+@@ -189,7 +189,7 @@ smn_verify_my_name(const char *name)
+ return retval;
+ }
+
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct nsm_host *
+ smn_alloc_host(const char *hostname, const char *mon_name,
+ const char *my_name, const time_t timestamp)
+@@ -343,7 +343,7 @@ static int smn_socket(void)
+ * If admin specified a source address or srcport, then convert those
+ * to a sockaddr and return it. Otherwise, return an ANYADDR address.
+ */
+-__attribute_malloc__
++__attribute__((__malloc__))
+ static struct addrinfo *
+ smn_bind_address(const char *srcaddr, const char *srcport)
+ {
+diff --git a/utils/statd/statd.h b/utils/statd/statd.h
+index e89e666..a1d8035 100644
+--- a/utils/statd/statd.h
++++ b/utils/statd/statd.h
+@@ -25,7 +25,7 @@
+ extern _Bool statd_matchhostname(const char *hostname1, const char *hostname2);
+ extern _Bool statd_present_address(const struct sockaddr *sap, char *buf,
+ const size_t buflen);
+-__attribute_malloc__
++__attribute__((__malloc__))
+ extern char * statd_canonical_name(const char *hostname);
+
+ extern void my_svc_run(void);
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch b/main/nfs-utils/0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
new file mode 100644
index 0000000000..2544a59646
--- /dev/null
+++ b/main/nfs-utils/0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
@@ -0,0 +1,61 @@
+From c2fc4ac0819b4e6f9591b86245ad537906f9d0cb Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 13:54:31 +0000
+Subject: [PATCH 4/7] Allow usage of getrpcbynumber() when getrpcbynumber_r()
+ is unavailable
+
+---
+ configure.ac | 6 +-----
+ support/nfs/svc_socket.c | 6 ++++++
+ 2 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bf433d6..c758cc7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -247,9 +247,6 @@ AC_CHECK_FUNC([connect], ,
+ AC_CHECK_FUNC([getaddrinfo], ,
+ [AC_MSG_ERROR([Function 'getaddrinfo' not found.])])
+
+-AC_CHECK_FUNC([getrpcbynumber], ,
+- [AC_MSG_ERROR([Function 'getrpcbynumber' not found.])])
+-
+ AC_CHECK_FUNC([getservbyname], ,
+ [AC_MSG_ERROR([Function 'getservbyname' not found.])])
+
+@@ -408,12 +405,11 @@ AC_FUNC_STAT
+ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([alarm atexit dup2 fdatasync ftruncate getcwd \
+ gethostbyaddr gethostbyname gethostname getmntent \
+- getnameinfo getrpcbyname getifaddrs \
++ getnameinfo getrpcbyname getrpcbynumber getrpcbynumber_r getifaddrs \
+ gettimeofday hasmntopt inet_ntoa innetgr memset mkdir pathconf \
+ ppoll realpath rmdir select socket strcasecmp strchr strdup \
+ strerror strrchr strtol strtoul sigprocmask])
+
+-
+ dnl *************************************************************
+ dnl Check for data sizes
+ dnl *************************************************************
+diff --git a/support/nfs/svc_socket.c b/support/nfs/svc_socket.c
+index f56f310..61ccf5b 100644
+--- a/support/nfs/svc_socket.c
++++ b/support/nfs/svc_socket.c
+@@ -42,8 +42,14 @@ int getservport(u_long number, const char *proto)
+ struct servent servbuf, *servp = NULL;
+ int ret;
+
++#if HAVE_GETRPCBYNUMBER_R
+ ret = getrpcbynumber_r(number, &rpcbuf, rpcdata, sizeof rpcdata,
+ &rpcp);
++#else
++ rpcp = getrpcbynumber(number);
++ ret = 0;
++#endif
++
+ if (ret == 0 && rpcp != NULL) {
+ /* First try name. */
+ ret = getservbyname_r(rpcp->r_name, proto, &servbuf, servdata,
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0005-exportfs-define-_GNU_SOURCE-for-stat64.patch b/main/nfs-utils/0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
new file mode 100644
index 0000000000..29f094ca0b
--- /dev/null
+++ b/main/nfs-utils/0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
@@ -0,0 +1,28 @@
+From 2ab92ce00f420d98e10f2b04eee229ffcf540015 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 14:00:50 +0000
+Subject: [PATCH 5/7] exportfs: define _GNU_SOURCE for stat64
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ utils/exportfs/exportfs.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/utils/exportfs/exportfs.c b/utils/exportfs/exportfs.c
+index 8c86790..1feadaa 100644
+--- a/utils/exportfs/exportfs.c
++++ b/utils/exportfs/exportfs.c
+@@ -12,6 +12,10 @@
+ #include <config.h>
+ #endif
+
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/vfs.h>
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch b/main/nfs-utils/0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
new file mode 100644
index 0000000000..263c75102e
--- /dev/null
+++ b/main/nfs-utils/0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
@@ -0,0 +1,38 @@
+From c4e7010b9d25b07650ed965243512190f75e8b9c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 14:04:30 +0000
+Subject: [PATCH 6/7] mountd: define _GNU_SOURCE for statfs64 and use standard
+ dev_t
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ utils/mountd/cache.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/utils/mountd/cache.c b/utils/mountd/cache.c
+index ca35de2..0a4eba5 100644
+--- a/utils/mountd/cache.c
++++ b/utils/mountd/cache.c
+@@ -11,6 +11,10 @@
+ #include <config.h>
+ #endif
+
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++
+ #include <sys/types.h>
+ #include <sys/select.h>
+ #include <sys/stat.h>
+@@ -1334,7 +1338,7 @@ static int cache_export_ent(char *domain, struct exportent *exp, char *path)
+ */
+ struct stat stb;
+ size_t l = strlen(exp->e_path);
+- __dev_t dev;
++ dev_t dev;
+
+ if (strlen(path) <= l || path[l] != '/' ||
+ strncmp(exp->e_path, path, l) != 0)
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch b/main/nfs-utils/0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
new file mode 100644
index 0000000000..09a26b3d09
--- /dev/null
+++ b/main/nfs-utils/0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
@@ -0,0 +1,27 @@
+From e1e75caa7781fc7c8e641516cae214dfe65e6eb6 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 12 Feb 2014 14:07:16 +0000
+Subject: [PATCH 7/7] nfsstat: replace the legacy SA_ONESHOT with standard
+ SA_RESETHAND
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ utils/nfsstat/nfsstat.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/nfsstat/nfsstat.c b/utils/nfsstat/nfsstat.c
+index 70f8d10..3612bfe 100644
+--- a/utils/nfsstat/nfsstat.c
++++ b/utils/nfsstat/nfsstat.c
+@@ -336,7 +336,7 @@ main(int argc, char **argv)
+
+ struct sigaction act = {
+ .sa_handler = unpause,
+- .sa_flags = SA_ONESHOT,
++ .sa_flags = SA_RESETHAND,
+ };
+
+ if ((progname = strrchr(argv[0], '/')))
+--
+1.8.5.3
+
diff --git a/main/nfs-utils/APKBUILD b/main/nfs-utils/APKBUILD
index 8f1d366b95..2f25b4d314 100644
--- a/main/nfs-utils/APKBUILD
+++ b/main/nfs-utils/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nfs-utils
pkgver=1.2.9
-pkgrel=0
+pkgrel=1
pkgdesc="kernel-mode NFS"
url="http://nfs.sourceforge.net/"
arch="all"
license="GPL"
depends="rpcbind"
makedepends="util-linux-dev libtirpc-dev libcap-dev libevent-dev
- libnfsidmap-dev keyutils-dev lvm2-dev krb5-dev sqlite-dev"
+ libnfsidmap-dev keyutils-dev lvm2-dev krb5-dev sqlite-dev
+ autoconf automake libtool"
subpackages="$pkgname-doc"
[ "$ALPINE_LIBC" != "eglibc" ] && subpackages="$subpackages rpcgen"
@@ -24,6 +25,15 @@ source="http://downloads.sourceforge.net/nfs/$pkgname-$pkgver.tar.bz2
nfs.confd
nfs.exports
+
+ 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
+ 0002-Fix-header-include-for-definition-of-NULL.patch
+ 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
+ 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
+ 0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
+ 0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
+ 0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
+
nfs-utils-mtab-sym.patch
uclibc-getaddrinfo-canonname.patch
"
@@ -47,6 +57,8 @@ prepare() {
tools/nfs-iostat/Makefile.in \
tools/mountstats/Makefile.am \
tools/mountstats/Makefile.in || return 1
+
+ ./autogen.sh || return 1
}
build() {
@@ -65,7 +77,6 @@ build() {
--enable-uuid \
--enable-gss \
--enable-libmount-mount \
- --enable-mounting \
|| return 1
make || return 1
@@ -102,6 +113,13 @@ d514fb87ce5de9909f43d99012352f09 nfsmount.initd
20e71ab412555b2dc9b50f346f68e5c8 rpc.svcgssd.initd
09135438d6df50b868bbe5a2260f973c nfs.confd
4f1bb7b2412ce5952ecb5ec22d8ed99d nfs.exports
+e78522fa674479e26efbb07e1f533343 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
+db146c3e263de1825ec94dd62167d79c 0002-Fix-header-include-for-definition-of-NULL.patch
+4bf2fd07d60fbebb0b3dd7d5cef34b9b 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
+14b241265b47f698aae7818d2cfb3051 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
+5dc7e475e8bf2ae3df304cf9db6454a7 0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
+334e6124ce5cb3a1c75c426ab6669ba6 0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
+ed80396c06a84bb86d9f6a1f88b2afbc 0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
2b2d228f9947581c924a691a84664fa1 nfs-utils-mtab-sym.patch
37a82a3a81410b483790ca30d564f4ba uclibc-getaddrinfo-canonname.patch"
sha256sums="90b76d5692a520b74273e607a4fd69df4cc35f65e242e22e2bc61b58759722f3 nfs-utils-1.2.9.tar.bz2
@@ -114,6 +132,13 @@ a727948ccf665b6bb1977ac3014b7086ff654173d1a2be1e2b38a43e97f84ca8 rpc.statd.init
f1c460d8b0e91e54a551397d755135d05a3728d81de596535bf8bda074455677 rpc.svcgssd.initd
9ca3b7dfbac5bedd818a3637805380f4e873ef8e809c21c26f410c86ac16e03e nfs.confd
f2aaf1c92e07172adeb65f7f2bc0140c533ae453a3477e99be677ef2e05f2d4b nfs.exports
+a49a858dd127aeff608e2facd3734765e6113e2e26120d1b5a1a1feacb270157 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
+11ea62d8b2c5c9ea050ddd04c43cbe7169c097f2ba1402dff0b5340d88e7a972 0002-Fix-header-include-for-definition-of-NULL.patch
+d0d76cbe0a7929019b29690e2a43bada5f51a18bb4db9172212969c32dfefd38 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
+0a4099ec1c38ed19b3f9fe9c6c068b16aeff37294287ddc0ea637e8bd58af718 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
+7987f2e9a54e31008e0116ca63aba120005ded2b0404f2ab73d866c021975dd3 0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
+ab843e7feb4d51d44bd4d185867b30ed0bbeec2d27ce947689b5b0cb072b0a15 0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
+47fc077b1093388f6a81bd69eb41dce624d4f5aa4c2cf66f192c23ddd9963f30 0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
5a1c6875f43ecc93d5db7bcf84b4ceda16c09b6109c28696eb55d05247511706 nfs-utils-mtab-sym.patch
7c7451365001f1672abd6fd6dd53da03617a9baa4758ec515b3adf8b7bb7ad93 uclibc-getaddrinfo-canonname.patch"
sha512sums="c71f986a7e8f38492f8411540b32fef904f689b45b831e0e3c193628085d09742c6352dc42d6d374b8ded12e2b54f8fb3c8de66695a36cf038fc4afa5c29879e nfs-utils-1.2.9.tar.bz2
@@ -126,5 +151,12 @@ cf0272e42310b1ff8d40ff37dc839df2dd4fba4cb408f8fa67ce445e2975b37cafbb35e6d41af2bb
844e8d41a6a8b632d98585724aca2e9ae596f72c67e17e4e8fb9eb81e6c58eed9e10cf8b2a96896dba8fd1efaa95d846954e712bdf3402a847ae17742dae2157 rpc.svcgssd.initd
1711803f848f73fef9fa74bd572fa7643c586f06eeedf62ed91bd2aa06ad59c7b1f1c585b6f7b7a8ce67ff7fd6b601d88dc99ca1000dd1d3f5991f420da9761b nfs.confd
70f96bb3a465ee0fa857a6e511051ca3ced9f5a5d1e6b8b32eec843a2067f2475d8979c724a3661de0a2b078eef143f55d75ed184d823841d9de5038da91fb91 nfs.exports
+1b59dcb7f7a11a0cd8ee4ab25f22f85a57a3e8fd5fb54eb6add1a4933b5a96d333b3bff3955d36999a1f9b0b312b52c83e4efc5ed0cdecbd305a95e676129f6d 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
+18f5c50ace27d88984b85b0fa529257ba151ec2295af8f66b3637b32df817063426ab56d1c9eca4b6437614338ff74865cd918c12695927b4da6af6b639dd0ed 0002-Fix-header-include-for-definition-of-NULL.patch
+bdef9397da387b51b9774e21c92b0850c082d6b250bfbecc680e5b22cd8fb7f14fea7e4f4febeefbd56494bfe4e56f585880664d6413b0f1290eac06d5b7712f 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
+495642168b11a642581dd574b2f0530a5bf7b6c5e89fae4926d8427afc6bb01e5170d9348207d3b97af7d70b795ebf208fb04a41636556d9ca66c0cee1554962 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
+80ba9146befdcb9d60625f9d224145a34cae2614ff69e91357b3c3049ff983f82ebad1b29a8a17ae2e16062f685d1660cc6007bb4287fcdc6b7e889a1b8a3f82 0005-exportfs-define-_GNU_SOURCE-for-stat64.patch
+c41e853bc156ab37cfe074a9c14d13fa94d3efff1351861668fe09cc6f1079b8d695ddb857a214db607500cef946d1aba45d748bd839a0184cd8ea5f34f8cb2d 0006-mountd-define-_GNU_SOURCE-for-statfs64-and-use-stand.patch
+939c11c66532c5a70699fa01744dfe2ffb2926307c771e055f4e04132b58f4715d7f81e233911a4ac1c0715190e64b7d2fff3a007c02cea939fee98351b3ca16 0007-nfsstat-replace-the-legacy-SA_ONESHOT-with-standard-.patch
5fd9039a61a0cdaeb57b5332ea545034101e6f15be200b7cf8fc7d0a3d22836a6fc778e0560656c1825808a4dc09046d9923d81b4d1324a6e526b226c657d064 nfs-utils-mtab-sym.patch
b9f0820773d3ab82cfa9ba603c83f98a71ad2e7205418c1223344b5b3e1bdfbb6aa183ab830df25ded660a4950d0e54098485fa08a4f6b6363a62c0f6c713489 uclibc-getaddrinfo-canonname.patch"