aboutsummaryrefslogtreecommitdiffstats
path: root/main/nfs-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-28 15:44:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-28 15:50:10 +0200
commit8603f58746e0bb6b1deeef36bea5ea3d6fe5afe4 (patch)
tree4f556ffaf788ea582bb72cef3dc74dbb1c79fe1e /main/nfs-utils
parent1164a45081f2c3b9916d7f42da66353d39a70666 (diff)
downloadaports-8603f58746e0bb6b1deeef36bea5ea3d6fe5afe4.tar.bz2
aports-8603f58746e0bb6b1deeef36bea5ea3d6fe5afe4.tar.xz
main/nfs-utils: fix segfault for rpcdebug, mount, and idmap
Diffstat (limited to 'main/nfs-utils')
-rw-r--r--main/nfs-utils/0001-include-libgen.h-for-basename.patch82
-rw-r--r--main/nfs-utils/0001-nfsd-include-libgen.h-for-basename.patch27
-rw-r--r--main/nfs-utils/APKBUILD10
3 files changed, 87 insertions, 32 deletions
diff --git a/main/nfs-utils/0001-include-libgen.h-for-basename.patch b/main/nfs-utils/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 0000000000..b10ba929f1
--- /dev/null
+++ b/main/nfs-utils/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,82 @@
+From 4d3810176cab64e3d748d6cefcea77a258f94c1d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 24 Apr 2014 10:38:26 +0200
+Subject: [PATCH] include libgen.h for basename
+
+According POSIX basename(3) should have an #include <libgen.h>
+
+There are a different GNU implementation too, that can be used with
+_GNU_SOURCE, but the POSIX version is good enough and more portable.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ tools/rpcdebug/rpcdebug.c | 1 +
+ utils/mount/mount.c | 1 +
+ utils/mount/mount_libmount.c | 1 +
+ utils/nfsd/nfsd.c | 1 +
+ utils/nfsidmap/nfsidmap.c | 1 +
+ 5 files changed, 5 insertions(+)
+
+diff --git a/tools/rpcdebug/rpcdebug.c b/tools/rpcdebug/rpcdebug.c
+index d6e10d3..18b1622 100644
+--- a/tools/rpcdebug/rpcdebug.c
++++ b/tools/rpcdebug/rpcdebug.c
+@@ -26,6 +26,7 @@
+ #include <malloc.h>
+ #include <fcntl.h>
+ #include <ctype.h>
++#include <libgen.h>
+ /* RPC debug flags
+ #include <sunrpc/debug.h> */
+ /* NFS debug flags
+diff --git a/utils/mount/mount.c b/utils/mount/mount.c
+index eea00af..91f1087 100644
+--- a/utils/mount/mount.c
++++ b/utils/mount/mount.c
+@@ -33,6 +33,7 @@
+ #include <getopt.h>
+ #include <mntent.h>
+ #include <pwd.h>
++#include <libgen.h>
+
+ #include "fstab.h"
+ #include "xcommon.h"
+diff --git a/utils/mount/mount_libmount.c b/utils/mount/mount_libmount.c
+index 701d41e..6f85dc9 100644
+--- a/utils/mount/mount_libmount.c
++++ b/utils/mount/mount_libmount.c
+@@ -29,6 +29,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <getopt.h>
++#include <libgen.h>
+
+ #include <libmount/libmount.h>
+
+diff --git a/utils/nfsd/nfsd.c b/utils/nfsd/nfsd.c
+index 73d6a92..b781c20 100644
+--- a/utils/nfsd/nfsd.c
++++ b/utils/nfsd/nfsd.c
+@@ -19,6 +19,7 @@
+ #include <errno.h>
+ #include <getopt.h>
+ #include <netdb.h>
++#include <libgen.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+diff --git a/utils/nfsidmap/nfsidmap.c b/utils/nfsidmap/nfsidmap.c
+index 3f51b4d..e0d31e7 100644
+--- a/utils/nfsidmap/nfsidmap.c
++++ b/utils/nfsidmap/nfsidmap.c
+@@ -4,6 +4,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
++#include <libgen.h>
+
+ #include <pwd.h>
+ #include <grp.h>
+--
+1.9.2
+
diff --git a/main/nfs-utils/0001-nfsd-include-libgen.h-for-basename.patch b/main/nfs-utils/0001-nfsd-include-libgen.h-for-basename.patch
deleted file mode 100644
index 72bc0097f8..0000000000
--- a/main/nfs-utils/0001-nfsd-include-libgen.h-for-basename.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From aa09509de961a5859f0518bd55ff3c8ca6c8ef5c Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 24 Apr 2014 10:38:26 +0200
-Subject: [PATCH] nfsd: include libgen.h for basename
-
-according POSIX basename(3) should have an #include <libgen.h>
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- utils/nfsd/nfsd.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/utils/nfsd/nfsd.c b/utils/nfsd/nfsd.c
-index 73d6a92..b781c20 100644
---- a/utils/nfsd/nfsd.c
-+++ b/utils/nfsd/nfsd.c
-@@ -19,6 +19,7 @@
- #include <errno.h>
- #include <getopt.h>
- #include <netdb.h>
-+#include <libgen.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
---
-1.9.2
-
diff --git a/main/nfs-utils/APKBUILD b/main/nfs-utils/APKBUILD
index 23e228ad26..dd7b03e190 100644
--- a/main/nfs-utils/APKBUILD
+++ b/main/nfs-utils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nfs-utils
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="kernel-mode NFS"
url="http://nfs.sourceforge.net/"
arch="all"
@@ -28,7 +28,7 @@ source="http://downloads.sourceforge.net/nfs/$pkgname-$pkgver.tar.bz2
0001-Only-work-around-glibc-bugs-on-glibc.patch
0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
- 0001-nfsd-include-libgen.h-for-basename.patch
+ 0001-include-libgen.h-for-basename.patch
0002-Fix-header-include-for-definition-of-NULL.patch
0003-replace-__attribute_malloc__-with-the-more-portable-.patch
0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
@@ -118,7 +118,7 @@ d514fb87ce5de9909f43d99012352f09 nfsmount.initd
4f1bb7b2412ce5952ecb5ec22d8ed99d nfs.exports
879a1320eefb5a6261693d5dd87a4a09 0001-Only-work-around-glibc-bugs-on-glibc.patch
e78522fa674479e26efbb07e1f533343 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
-72e31ddc393b69a11df5301a2ed30aac 0001-nfsd-include-libgen.h-for-basename.patch
+469cd865ee09a353ccffd0a7a1f10ae7 0001-include-libgen.h-for-basename.patch
db146c3e263de1825ec94dd62167d79c 0002-Fix-header-include-for-definition-of-NULL.patch
4bf2fd07d60fbebb0b3dd7d5cef34b9b 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
14b241265b47f698aae7818d2cfb3051 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
@@ -140,7 +140,7 @@ f1c460d8b0e91e54a551397d755135d05a3728d81de596535bf8bda074455677 rpc.svcgssd.in
f2aaf1c92e07172adeb65f7f2bc0140c533ae453a3477e99be677ef2e05f2d4b nfs.exports
6c5be8ce258313d12c1e4ce6ea28d5dcde9c3abc047ac0d8d2bdbf58fe8746f6 0001-Only-work-around-glibc-bugs-on-glibc.patch
a49a858dd127aeff608e2facd3734765e6113e2e26120d1b5a1a1feacb270157 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
-0abd3cc27e48b8792ec919b17d51456d3b2bd4e2853e9a1af242348eb8bd0f6f 0001-nfsd-include-libgen.h-for-basename.patch
+76d0be35b835ce8facb7eae915f3362268aa6d84a5d1c4a40d72e0f5006ca42e 0001-include-libgen.h-for-basename.patch
11ea62d8b2c5c9ea050ddd04c43cbe7169c097f2ba1402dff0b5340d88e7a972 0002-Fix-header-include-for-definition-of-NULL.patch
d0d76cbe0a7929019b29690e2a43bada5f51a18bb4db9172212969c32dfefd38 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
0a4099ec1c38ed19b3f9fe9c6c068b16aeff37294287ddc0ea637e8bd58af718 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
@@ -162,7 +162,7 @@ cf0272e42310b1ff8d40ff37dc839df2dd4fba4cb408f8fa67ce445e2975b37cafbb35e6d41af2bb
70f96bb3a465ee0fa857a6e511051ca3ced9f5a5d1e6b8b32eec843a2067f2475d8979c724a3661de0a2b078eef143f55d75ed184d823841d9de5038da91fb91 nfs.exports
9d0c4498691019a515cc194dd717d139230aa29ac1db4aa74beecd4817484f8b49632ddb33abd7d649940134f663e24a07fdf35fcaec72312aabc633e284e51e 0001-Only-work-around-glibc-bugs-on-glibc.patch
1b59dcb7f7a11a0cd8ee4ab25f22f85a57a3e8fd5fb54eb6add1a4933b5a96d333b3bff3955d36999a1f9b0b312b52c83e4efc5ed0cdecbd305a95e676129f6d 0001-conffile-use-standard-uint-_t-and-unsigned-char.patch
-c56578c5b8c5f359471b69ffda4300e1aace9c1cf9687abae121f16f22542127252bcd62ae3b749377406de96c22fc0f5b4aebe056e0240470da25cf6f89eb0c 0001-nfsd-include-libgen.h-for-basename.patch
+070fe49430d973c0d0142a0ce65ece2265abc34b0e53661d6b5eda9b911f7bf9b5b6561125b6bbb1a4739f92b916d5bf3080b67c87a429e959454b13f5aa6c38 0001-include-libgen.h-for-basename.patch
18f5c50ace27d88984b85b0fa529257ba151ec2295af8f66b3637b32df817063426ab56d1c9eca4b6437614338ff74865cd918c12695927b4da6af6b639dd0ed 0002-Fix-header-include-for-definition-of-NULL.patch
bdef9397da387b51b9774e21c92b0850c082d6b250bfbecc680e5b22cd8fb7f14fea7e4f4febeefbd56494bfe4e56f585880664d6413b0f1290eac06d5b7712f 0003-replace-__attribute_malloc__-with-the-more-portable-.patch
495642168b11a642581dd574b2f0530a5bf7b6c5e89fae4926d8427afc6bb01e5170d9348207d3b97af7d70b795ebf208fb04a41636556d9ca66c0cee1554962 0004-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch