aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-27 00:21:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-28 00:45:03 +0200
commit5115c24f94eab7d3be8ad11e59c82494c05ce3a2 (patch)
treef46e80df73a4f93eb731f1b47978814dee5dbb1f /main/nginx/APKBUILD
parentfda86691c22f67327a08e3b68ae3ead7fc1b6f9c (diff)
downloadaports-5115c24f94eab7d3be8ad11e59c82494c05ce3a2.tar.bz2
aports-5115c24f94eab7d3be8ad11e59c82494c05ce3a2.tar.xz
main/nginx: upgrade to 1.12.0
Upgraded modules: * lua-nginx-module to 0.10.8 * nchan to 1.1.4 * nginx-rtmp-module to 1.1.11
Diffstat (limited to 'main/nginx/APKBUILD')
-rw-r--r--main/nginx/APKBUILD52
1 files changed, 38 insertions, 14 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 9c6301f331..596a1d60d5 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -4,8 +4,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=nginx
-pkgver=1.10.3
-pkgrel=5
+pkgver=1.12.0
+pkgrel=0
pkgdesc="HTTP and reverse proxy server (stable version)"
url="http://www.nginx.org/en"
arch="all"
@@ -39,14 +39,14 @@ _http_headers_more_dir="$srcdir/$_http_headers_more_name-$_http_headers_more_ver
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
_http_lua_name=lua-nginx-module
-_http_lua_ver=0.10.7
+_http_lua_ver=0.10.8
_http_lua_url="https://github.com/openresty/lua-nginx-module"
_http_lua_dir="$srcdir/$_http_lua_name-$_http_lua_ver"
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
_http_nchan_name=nchan
-_http_nchan_ver=1.1.0
+_http_nchan_ver=1.1.4
_http_nchan_url="https://github.com/slact/nchan"
_http_nchan_dir="$srcdir/$_http_nchan_name-$_http_nchan_ver"
_http_nchan_so="ngx_nchan_module.so"
@@ -58,7 +58,7 @@ _http_upload_progress_dir="$srcdir/$_http_upload_progress_name-$_http_upload_pro
_http_upload_progress_so="ngx_http_uploadprogress_module.so"
_rtmp_name=nginx-rtmp-module
-_rtmp_ver=1.1.10
+_rtmp_ver=1.1.11
_rtmp_url="https://github.com/arut/nginx-rtmp-module"
_rtmp_dir="$srcdir/$_rtmp_name-$_rtmp_ver"
_rtmp_provides="$pkgname-rtmp" # for backward compatibility
@@ -79,9 +79,12 @@ source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
$pkgname-tests-$_tests_hgrev.tar.gz::http://hg.nginx.org/nginx-tests/archive/$_tests_hgrev.tar.gz
$_devel_kit_name-$_devel_kit_ver.tar.gz::$_devel_kit_url/archive/v$_devel_kit_ver.tar.gz
$_http_echo_name-$_http_echo_ver.tar.gz::$_http_echo_url/archive/v$_http_echo_ver.tar.gz
+ $_http_echo_name~fix-nginx-1.12.patch
$_http_fancyindex_name-$_http_fancyindex_ver.tar.gz::$_http_fancyindex_url/archive/v$_http_fancyindex_ver.tar.gz
$_http_headers_more_name-$_http_headers_more_ver.tar.gz::$_http_headers_more_url/archive/v$_http_headers_more_ver.tar.gz
$_http_lua_name-$_http_lua_ver.tar.gz::$_http_lua_url/archive/v$_http_lua_ver.tar.gz
+ $_http_lua_name~fix-nginx-1.12.patch
+ $_http_lua_name~fix-libressl.patch
$_http_nchan_name-$_http_nchan_ver.tar.gz::$_http_nchan_url/archive/v$_http_nchan_ver.tar.gz
$_http_upload_progress_name-$_http_upload_progress_ver.tar.gz::$_http_upload_progress_url/archive/v$_http_upload_progress_ver.tar.gz
$_rtmp_name-$_rtmp_ver.tar.gz::$_rtmp_url/archive/v$_rtmp_ver.tar.gz
@@ -89,7 +92,6 @@ source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
default.conf
$pkgname.logrotate
$pkgname.initd
- ipv6.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -107,6 +109,7 @@ _modules="
http-xslt-filter
mail
stream
+ stream-geoip
devel-kit
http-echo
http-fancyindex
@@ -120,6 +123,23 @@ for _m in $_modules; do
done
+prepare() {
+ local file; for file in $source; do
+ case $file in
+ *~*.patch)
+ msg $file
+ cd "$srcdir"/${file%%~*}-*
+ patch -p 1 -i "$srcdir/$file"
+ ;;
+ *.patch)
+ msg $file
+ cd "$builddir"
+ patch -p 1 -i "$srcdir/$file"
+ ;;
+ esac
+ done
+}
+
build() {
cd "$builddir"
@@ -143,7 +163,6 @@ build() {
--group=$_grp_ngx \
--with-threads \
--with-file-aio \
- --with-ipv6 \
\
--with-http_ssl_module \
--with-http_v2_module \
@@ -161,14 +180,17 @@ build() {
--with-http_auth_request_module \
--with-http_random_index_module \
--with-http_secure_link_module \
+ --with-http_degradation_module \
--with-http_slice_module \
--with-http_stub_status_module \
--with-http_perl_module=dynamic \
- --with-http_realip_module \
--with-mail=dynamic \
--with-mail_ssl_module \
--with-stream=dynamic \
--with-stream_ssl_module \
+ --with-stream_realip_module \
+ --with-stream_geoip_module=dynamic \
+ --with-stream_ssl_preread_module \
\
--add-dynamic-module="$_devel_kit_dir" \
--add-dynamic-module="$_http_echo_dir" \
@@ -261,18 +283,20 @@ _module() {
echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
}
-sha512sums="25cddbe5c419700aeca41bff3be5b7c3accfb38ad846ec8d91d81ab7c15f10db719f02d9263edf1fa12f59805ff7001b62864dc2885370b24afeea1d7d2afbbf nginx-1.10.3.tar.gz
+sha512sums="e2e930b61491d91090090d4716740895fc7812e8e266c427ac2b40c5a70493150e5c81e769c6b7563baf5f0e15b32fae8f2b11fd5699e468e1cc40706defb8ee nginx-1.12.0.tar.gz
ca8be839aef71c537d6d3a79e2894f38790834d6310c6d15ad06900c7c2d7cf71a113847ab96ef9be0fbdfff3b7808e74dea427502b275cfd6c909550f9ba9ab nginx-tests-cdd44ff602db.tar.gz
558764c9be913a4f61d0e277d07bf3c272e1ce086b3fadb85b693a7e92805cd9fca4da7a8d29c96e53fc0d23b331327d3b2561ff61f19d2330e7d5d35ac7d614 ngx_devel_kit-0.3.0.tar.gz
c455bee73cebd0752449472452d15614b9587ddd199263d366484ede890c4d108eacbbeaef31adc9dc7732b56ef2bfc73c0fef3366366db03a8ec3fdc27a985c echo-nginx-module-0.60.tar.gz
+401f57ed73941619cdd41061bd92fffc00730e34cc647ea3c9345225723e9c7ebd72d9d15a703cffd93b0a99d458a05fe5efa7373ae24f41b35279285b5ca0fa echo-nginx-module~fix-nginx-1.12.patch
ce0043ad4a2b638c5d99244d6caaa65ad142cea78884084a9aeca5a9593c68dbe508c9e4dd85dc5722eb63ef386612bffc48d4b6fc1487df244fbcb7a73bffe1 ngx-fancyindex-0.4.1.tar.gz
e42582b45c3111de3940bbeb67ce161aca2d55adcfb00c61c12256fa0e36221d38723013f36edbcf6d1b520f8dfb49d4657df8a956e66d36e68425afad382bd1 headers-more-nginx-module-0.32.tar.gz
-d060a13de4d01d77e6d6cd1635ecbb405330e4326b71b89341c1c128ee4182978a51d53355bc07c350e3c3a7df15325e3df380d9c3a98b2ff7d7efa18fa09b32 lua-nginx-module-0.10.7.tar.gz
-bb3a9aec5e4c9f1c376126b4b07c2e5c6cddae3659a9218bd7b0dcaa5b0e1772036eea2c7e45bbb46f61a3a9090f0092fc93e91dbb57fc5b4e65eef6ba14fc23 nchan-1.1.0.tar.gz
+ad621cec178eb37109f16ebc30dbab7b1ea344ac4b523ff1e6ad62364b8cf437488a89c593ca44b446b729a1c578e3a97685851847b4b16a147ac9eca8f23a2a lua-nginx-module-0.10.8.tar.gz
+04f7d75ce15eba99be99a76d266903c17e48742ab4bf237b988bf84f00cdbf6510c3d4eee88a24620e56dc426220192df39f4736af157fdc4e4c50b4f1d794f2 lua-nginx-module~fix-nginx-1.12.patch
+fd8bce0e7d69552267b8e405b07fc9323e25e06cceb8912a2d143952447a4299756e6a9a8a40f4eabe8b00fed475fd87ee4a982f5ad7449d59783e872c682451 lua-nginx-module~fix-libressl.patch
+458bddfb27b8aa8a99a6324a600620531b2c71f035c10304868a1acb523a288ee6f90746dbe43cd8c476ed55ad01649a225a5ea73eedf3a199387fe2049c529e nchan-1.1.4.tar.gz
c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
-bcc0aee3308af7c61bf01a5530fcf1dae938e6778306f6e3eb5995e6d0529f43d33b7ee2acb813d5a39acc92e4853d207a01e8e41b766a6e0dd07aade60cd98f nginx-rtmp-module-1.1.10.tar.gz
+e7c897265d1e93b06f7e46a653b113e24d2451e2112a7a6da415f130928437444a0346832fd9c10042397fea6120e4e44acc2bccf649ec30ca5bffbf985672e2 nginx-rtmp-module-1.1.11.tar.gz
ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf
0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
-1ea032cf88021ec8aa1401d284ea738364511cdb9f8c01670deb8e59aae570f5bbe17f0cbab73c0e08d6b342a621b6a9c014832168ed41f6028ecfa4211b60cf nginx.initd
-68d64a84568ec2df0366925ab282a05ebe21a85044b6c7844a47573cfd8cc8ed119cc772358bc3fff36e2d4fdf583a730592825f5f98632993ca86d1f8438d5f ipv6.patch"
+1ea032cf88021ec8aa1401d284ea738364511cdb9f8c01670deb8e59aae570f5bbe17f0cbab73c0e08d6b342a621b6a9c014832168ed41f6028ecfa4211b60cf nginx.initd"