aboutsummaryrefslogtreecommitdiffstats
path: root/main/ngrep
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-04-08 07:20:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-08 07:43:03 +0000
commit163e2083ab9656e013615e8ec4804678b6ca06e9 (patch)
tree9dc7c12a8be85f82ca4e2d674438e2e973fc6da9 /main/ngrep
parent498b8b3d3c837c3fe4255cfed3959e3b69176542 (diff)
downloadaports-163e2083ab9656e013615e8ec4804678b6ca06e9.tar.bz2
aports-163e2083ab9656e013615e8ec4804678b6ca06e9.tar.xz
main/ngrep: upgrade to 1.47
Diffstat (limited to 'main/ngrep')
-rw-r--r--main/ngrep/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/main/ngrep/APKBUILD b/main/ngrep/APKBUILD
index 00fe0d5448..c3e8caefd7 100644
--- a/main/ngrep/APKBUILD
+++ b/main/ngrep/APKBUILD
@@ -1,35 +1,37 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=ngrep
-pkgver=1.45
-pkgrel=4
+pkgver=1.47
+_pkgver="${pkgver/./_}"
+pkgrel=0
pkgdesc="A grep-like utility that allows you to search for network packets on an interface"
url="http://ngrep.sourceforge.net/"
arch="all"
license="BSD"
-makedepends="autoconf automake libpcap-dev"
+makedepends="autoconf automake libpcap-dev pcre-dev"
options="!check"
subpackages="$pkgname-dbg $pkgname-doc"
-source="https://downloads.sourceforge.net/sourceforge/ngrep/$pkgname-$pkgver.tar.bz2
- no-strip.patch"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpr5/$pkgname/archive/V${_pkgver}.tar.gz"
+builddir="$srcdir"/$pkgname-$_pkgver
prepare() {
cd "$builddir"
default_prepare
update_config_sub
- update_config_guess
autoreconf -vif
}
build() {
cd "$builddir"
+ export EXTRA_INCLUDES=$(pcre-config --cflags)
+ export EXTRA_LIBS=$(pcre-config --libs)
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
+ --enable-pcre \
+ --enable-ipv6 \
--with-pcap-includes=/usr/include/pcap \
--disable-pcap-restart
make
@@ -38,9 +40,8 @@ build() {
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE.txt \
+ install -Dm644 LICENSE \
"$pkgdir"/usr/share/licenses/custom/$pkgname/LICENSE
}
-sha512sums="0feb4080f834449d57ae99897c573d2b8148711cfb550fa4ff415169dedb1f0d23f4b03f625660162ca72f8ad06e19874c1af46da6afd8f8fe8dd553558c14f7 ngrep-1.45.tar.bz2
-28488c548cd409ac99af7eead37e3d7596b8c0ac2b9064de5ae7cc815beb65fc8488e8400d6a5d81eab128dc0a97b4e252e2503baf35704138a2226f7d3375d7 no-strip.patch"
+sha512sums="47ba65878df6b555701c866721a8a935eabdcce636d398284cbfe5f63baf68c62d994a2f373ea4fc8f44fbed3eecee149f2ee48d39c71c04d34e5a088db8c657 ngrep-1.47.tar.gz"