aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs/APKBUILD
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-30 10:36:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 13:12:19 +0000
commit21966630200d0258153232ae8c4e07190305449e (patch)
tree61a2745bda5a88fe2767436695c28fb9a38d6036 /main/nodejs/APKBUILD
parent3504d219b0e7d01ad37b971a6448399d21b43430 (diff)
downloadaports-21966630200d0258153232ae8c4e07190305449e.tar.bz2
aports-21966630200d0258153232ae8c4e07190305449e.tar.xz
main/nodejs: fix build on mips{el} (-latomic), disable on mips64*
1) Add the usual -latomic for pre-R6 MIPS32. 2) Alpine mips64* definitions assume MIPS III but nodejs wants MIPS32 at least and can actually generate instructions missing in MIPS III, e.g. movn/movz. There is also some support for Loongson 2 (which is a MIPS III CPU) however it apparently always targets hard-float O32 ABI so be safe and disable build on mips64* completely. Keep pkgrel intact since no previously built mips* apks exist and changes are strictly mips-specific.
Diffstat (limited to 'main/nodejs/APKBUILD')
-rw-r--r--main/nodejs/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index 63dffdf469..784d5f8d4f 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -37,7 +37,7 @@ pkgver=10.14.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="https://nodejs.org/"
-arch="all"
+arch="all !mips64 !mips64el"
license="MIT"
depends="ca-certificates"
depends_dev="libuv"
@@ -48,7 +48,9 @@ subpackages="$pkgname-dev $pkgname-doc npm::noarch"
provides="nodejs-lts=$pkgver" # for backward compatibility
replaces="nodejs-current nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
- dont-run-gyp-files-for-bundled-deps.patch"
+ dont-run-gyp-files-for-bundled-deps.patch
+ link-with-libatomic-on-mips32.patch
+ "
builddir="$srcdir/node-v$pkgver"
prepare() {
@@ -61,7 +63,12 @@ prepare() {
build() {
cd "$builddir"
+ case "$CARCH" in
+ mips*) _carchflags="--with-mips-arch-variant=r1 --with-mips-float-abi=soft";;
+ esac
+
./configure --prefix=/usr \
+ $_carchflags \
--shared-zlib \
--shared-libuv \
--shared-openssl \
@@ -120,4 +127,5 @@ npm() {
}
sha512sums="35506ab4cb2d3fa8ab2540aa3df87df5bd7e254ee092bd8872895bcac256ad0f54eab0277d3f67fed223a2634e75143a3a796657a9c8981fa444d599bc93cecc node-v10.14.0.tar.gz
-9d09a88074bf0093f35c5b610e73ebf4c5381df2a2b29feb69da1af0b18776a683b13f1276375bbcfc60936cc27769539e1f01b4ba94b22cad2d5f4daae14c46 dont-run-gyp-files-for-bundled-deps.patch"
+9d09a88074bf0093f35c5b610e73ebf4c5381df2a2b29feb69da1af0b18776a683b13f1276375bbcfc60936cc27769539e1f01b4ba94b22cad2d5f4daae14c46 dont-run-gyp-files-for-bundled-deps.patch
+9256f6f84978c4fea7ac625bbf3934e85de5d00393d28a50df2c234a7309fdf5c49b59da1825e8817a3794044af0219c698a0c57367cc6f1fe0ef813f837aa97 link-with-libatomic-on-mips32.patch"